Results 1 to 4 of 4

Thread: My units gets 'blocked' and can't response to my orders, help

  1. #1
    MerkeKING's Avatar Foederatus
    Join Date
    Jan 2024
    Location
    Ecuador
    Posts
    34

    Icon5 My units gets 'blocked' and can't response to my orders, help

    Lately I'm seeing a super weird bug that I've never experienced before, and apparently it only happens in the campaign. You see, the only pattern I have found is when units charge against the enemy, and apparently it is with all units (infantry, cavalry, missiles).


    The units stop responding to orders and stay fighting for a long time. I've noticed that when this happens, the attributes interface goes gray, as if the unit is 'locked' or something; I share a screenshot in the attachments. I have stupidly lost units and my general because of this damn bug, which I don't know why it happens. Does anyone know what's happening?
    Attached Thumbnails Attached Thumbnails 20240212194509_1.jpg  

  2. #2
    Gigantus's Avatar I am not special - I am a limited edition.
    Patrician took an arrow to the knee spy of the council

    Join Date
    Aug 2006
    Location
    Goa - India
    Posts
    53,150
    Blog Entries
    36

    Default Re: My units gets 'blocked' and can't response to my orders, help

    The unit isn't routing, so any chance you may have accidentally used a weird keyboard short cut?
    'Long fighting' reminds me of 'fighting to the death' but that's normally only in siege battles when the unit has nowhere to retreat.










  3. #3
    MerkeKING's Avatar Foederatus
    Join Date
    Jan 2024
    Location
    Ecuador
    Posts
    34

    Default

    No I didn't, and I noticed that in the deployment happens the same. For some reason, when I deploy my units several times, there's a moment that I can not move them anymore. They no respond my orders to deploy in certain position, and I'm forced to start the battle, so that they finally answer my orders.
    Last edited by Gigantus; February 14, 2024 at 12:08 AM. Reason: double post

  4. #4
    Gigantus's Avatar I am not special - I am a limited edition.
    Patrician took an arrow to the knee spy of the council

    Join Date
    Aug 2006
    Location
    Goa - India
    Posts
    53,150
    Blog Entries
    36

    Default Re: My units gets 'blocked' and can't response to my orders, help

    The 'unresponsive when deployed too much' issue reminds of the bug that happens when you click on too many factions in the faction select menu or click back and forth in the menu pages. It's a memory leak issue if I remember correctly. Best solution: don't do it. Long term solution: change the layout of the menu page (several mods do that).

    Other then the 'don't do it' I really have no advice. Maybe clicking on another unit or simply clicking 'escape' or 'delete' will reactive access. Delete is actually used to fix the camera on a unit which then follows the unit's movement.










Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •