Results 1 to 4 of 4

Thread: Lighting flips on units - normal map issue?

  1. #1

    Default Lighting flips on units - normal map issue?

    Hey there!

    I'm having this odd problem with normal maps (see pic below). I made a custom normal map for this unit (DXT5, iterative fit compression, no mipmaps) in Paint.net, and for some reason it's flipping the lighting and doing weird things with it. Note how far away the model works fine, but the moment I get closer, the lighting flips around.



    For context, I'm not making the normal map myself, but essentially making a collage of existing ones from the Stainless Steel mod.

    I have already tried using other compression (Cluster Fit and Range Fit, in both DXT5 and DXT3), weighting color by alpha, and even tried mipmaps to see what would happen. Nothing changed.

    Ideas?

  2. #2

    Default Re: Lighting flips on units - normal map issue?

    Can't edit the post, so I'll add this as a reply.

    I noted the normal map works fine on Medium unit detail, but it gets all weird again in High and Highest.


  3. #3

    Default Re: Lighting flips on units - normal map issue?

    What you and the game call a "normal map" isn't strictly a normal map. Iirc, one of the channels handles topology similar to a normal map and one of the channels acts like a specular map. The latter is significantly more noticeable than the former in my experience.

    From the looks of it, your distant and low-settings models aren't using the "normal map" at all. The bump and specular effects only appear to be applied to the highest detail model, and the weirdness of the result suggests something wrong with the texture file itself, perhaps not being converted correctly or having dimensions that don't match the diffuse map.

    By the way, I strongly recommend GIMP over Paint.NET.

  4. #4

    Default Re: Lighting flips on units - normal map issue?

    I've been doing skins for games (Empire, Napoleon, Warhammer 1 TW, countless Source engine mods, M&B Warband, Skyrim, etc) since 2011 in PdN and it's always worked fine for me, and that includes normal maps with the specular alpha channel. Never before, in any game, has this happened to me lol.

    So far I managed to "solve" the problem by saving the image as .dds DXT5, opening it in DXTBmp, and overwriting the save with it. That said, this less than ideal.

    Also, it worked in PdN before! Some normal textures, like those of the mailed horse, work just fine. I have no clue why.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •