Results 1 to 11 of 11

Thread: GuildDestroyed Event Broken?

  1. #1

    Default GuildDestroyed Event Broken?

    Has anyone managed to get the GuildDestroyed event to fire? GuildUpgraded works fine when any level of guild is built, but I can't trigger the destroyed event. I have tried deconstructing and capturing the settlement to auto-destroy the guild, but neither trip the event. I can't think of any other way to destroy the guild except maybe with a disaster, but I believe disasters can only damage, not destroy buildings. Here is a test script:

    Code:
    monitor_event GuildDestroyed TrueCondition
     historic_event any_event
    end_monitor
    The vanilla game has a GuildDestroyed trigger in EDG, which some older threads on TWC just assumed was functional. But since nobody has had any idea what their guild points were until the advent of EOP, those old threads on guilds are full of wishful thinking.

    Is this event broken or does it just have really obscure trigger conditions?

  2. #2
    Gigantus's Avatar I am not going crazy - I am crazy. I just go normal every now and then.
    Patrician Citizen Moderator Emeritus Administrator Emeritus

    Join Date
    Aug 2006
    Location
    Goa - India
    Posts
    52,404
    Blog Entries
    35

    Default Re: GuildDestroyed Event Broken?

    It's a fairly obscure event to start with, it's used in the teutonic script I believe for the hanse guild. I guess I may have to add it to the 'non functional script stuff' list.



  3. #3
    Jadli's Avatar The Fallen God
    Citizen

    Join Date
    Dec 2013
    Location
    Czech Republic
    Posts
    8,355

    Default Re: GuildDestroyed Event Broken?

    Well, its used even in vanilla, no? The Trigger 0002_Guild_Destroyed

    Gig, in what way was it used with the script in teutonic? I dont have the script rn,
    but wasnt it used with some commands like this? Maybe when the entire guild is eradicated from a faction, it would trigger.... or its just broken, like other fundamental guild mechanics

    destroy_buildings byzantium guild_mages_guild false
    reset_guild_standing fighters_guild

  4. #4
    Jadli's Avatar The Fallen God
    Citizen

    Join Date
    Dec 2013
    Location
    Czech Republic
    Posts
    8,355

    Default Re: GuildDestroyed Event Broken?

    This thread is probably NVM...

    I tested this trigger with EOP... it works fine (just takes a second to upgrade the value I guess)... went from -1 to -351, as expected based on the sample trigger above)... deleted the building in a normal way, nothing fancy (right click on info and choose to destroy it... not the fancy way from previous post)
    Last edited by Jadli; August 15, 2022 at 10:45 AM.

  5. #5
    Gigantus's Avatar I am not going crazy - I am crazy. I just go normal every now and then.
    Patrician Citizen Moderator Emeritus Administrator Emeritus

    Join Date
    Aug 2006
    Location
    Goa - India
    Posts
    52,404
    Blog Entries
    35

    Default Re: GuildDestroyed Event Broken?

    In teutonic you have the hanse guild script, I seem to remember that there was a 'destroyed' monitor.

    Edit: there is a grand total of 7 of them, they do however all use the BuildingDestroyed event, seems to be an indicator that the guild one doesn't work:
    Code:
        monitor_event BuildingDestroyed BuildingName = hanseatic_guild
            and FactionType teutonic_order
    
            if I_EventCounter lithuania_conversion_accepted = 1
                historic_event hanseatic_destroyed factions { lithuania, denmark, novgorod, poland, hre, }
            end_if
            
            if I_EventCounter lithuania_conversion_accepted = 0
                historic_event hanseatic_destroyed factions { denmark, novgorod, poland, hre, }
            end_if
            
        end_monitor



  6. #6
    Jadli's Avatar The Fallen God
    Citizen

    Join Date
    Dec 2013
    Location
    Czech Republic
    Posts
    8,355

    Default Re: GuildDestroyed Event Broken?

    Well, thats weird then... GuildDestroyed works, as I demonstrated above...

  7. #7
    Gigantus's Avatar I am not going crazy - I am crazy. I just go normal every now and then.
    Patrician Citizen Moderator Emeritus Administrator Emeritus

    Join Date
    Aug 2006
    Location
    Goa - India
    Posts
    52,404
    Blog Entries
    35

    Default Re: GuildDestroyed Event Broken?

    That trigger deducts 100 points, why would you say a reduction of 350 would be to be expected?
    Code:
    Trigger 0002_Guild_Destroyed
        WhenToTest GuildDestroyed
    
    
        Guild this s -100 
        Guild this o -20
    I take it EOP has a way to display guild points for individual factions\guilds? And what would be the purpose of the false\true flag?

    In other words callis' monitor should work, provided he adds true or false?



  8. #8
    Jadli's Avatar The Fallen God
    Citizen

    Join Date
    Dec 2013
    Location
    Czech Republic
    Posts
    8,355

    Default Re: GuildDestroyed Event Broken?

    Ah, didnt realise I edited my EDG, for me its set up like this
    Code:
    ;------------------------------------------
    Trigger 0002_Guild_Destroyed
        WhenToTest GuildDestroyed
    
        Guild this s -250
        Guild this o -100
    So -350 is correct (for you it would have been -120)... cause as was researched in the other thread https://www.twcenter.net/forums/show...1#post16070158 and found many great and completely new finidngs, "o" and "s" are essentily the same for evens that export settlements. (I havent had time to rewrite my EDG to take all the new findings into account yet)

    Yea, EOP can display the points (with the script I made) for every guild in every settlement, thats why Im showing it... You mean false/true flag for destroy_buildings command? Thats to determine whether the faction receives money from destruction or not

    I suppose his monitor should work... but perhaps if its in CS and not in EDG, it may not work (cant see why else it wouldnt work for him...)
    Last edited by Jadli; August 18, 2022 at 08:01 AM.

  9. #9

    Default Re: GuildDestroyed Event Broken?

    For the hundredth time in the last year, I have reported a peculiarity of my mod's setup rather than an actual bug. I had removed the "guild_" prefix in EDB, which prevented the GuildDestroyed event from tripping. I'm getting quite tired of this happening... my mod isn't M2 anymore so there's really no point asking for help in M2 forums...

    For academic value: I had been testing using regular buildings (without "guild_") in EDG. You still get offers to build the first level but the game just keeps sending the same offer ad infinitum because, as far as it knows, there is no guild present in the settlement. Interestingly, GuildUpgraded still works for such buildings, but GuildDestroyed does not (although this is most likely an invalid finding, I just have to assume it's another quirk from my mod's setup).

  10. #10
    Gigantus's Avatar I am not going crazy - I am crazy. I just go normal every now and then.
    Patrician Citizen Moderator Emeritus Administrator Emeritus

    Join Date
    Aug 2006
    Location
    Goa - India
    Posts
    52,404
    Blog Entries
    35

    Default Re: GuildDestroyed Event Broken?

    Stands to reason that the game at some point requires the guild prefix as descr_missions doesn't define the building, EDB does. DM rather has a building condition, which enables you to add points to that settlement regardless if a 'prefixed' guild is present, in hind sight rather logical.

    May I inquire what motivated the omission of the prefix? It would seem that it would create a huge work around, akin to scripting 'destroy_buildings' instead of using the 'temple religion' prefix combo.
    Last edited by Gigantus; August 22, 2022 at 09:52 PM.



  11. #11

    Default Re: GuildDestroyed Event Broken?

    My idea was to make use of some of the features of the guild system (offers for instantaneous construction based on points/standing, limit of one per settlement) without the limitation of 3 levels per chain (really 1 level since the second level is limited to one per faction while the third is one on the map). It almost worked except that GuildDestroyed doesn't trip and, more significantly, the first level of the guild keeps getting offered ad infinitum because the game code checks for the "guild_" substring in the building type name, without which it will assume there is no guild present in the settlement.

    Btw, the auto-destroy feature is a combination of city/castle specification and religion specification, I don't think the "temple_" substring is needed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •