Results 1 to 2 of 2

Thread: BOB doesn't want to create startpos.esf file with multiple changes to the start_pos_regions table

  1. #1

    Icon5 BOB doesn't want to create startpos.esf file with multiple changes to the start_pos_regions table

    Hello everyone,
    I've been running into an issue with BOB not creating startpos.esf files when I make certain changes to the start_pos_regions table in DAVE.

    I want to make a mod with Han Sui having more land at the start of a 190 campaign. To be more precise: I want him to have the city of Wuwei and the livestock farm of Anding at the beginning of the campaign. Both are originally owned by the Han Empire.

    The steps I went through are similar to those seen in Zades' Simple Startpos/CEOs change.

    I started with a cleanly and freshly (re)installed Assembly Kit and went to DAVE to change the ownership of the city of Wuwei from the Han Empire to Han Sui.

    [ ]

    After applying the change I went to Export -> Build CEOs.
    Then I created a new .pack file using the Rusted PackFile Manager and added a folder aswell as the CEO.
    After changing the pack type to Movie I saved the file in the data folder for 3K and used BOB and the provider action "Campaign/process start pos" to build the startpos_romance.esf file.

    [ ]

    Lastly, I would put the 3k_main_campaign_map folderwith the newly made startpos from working_data in my .pack file. The final .pack file looks like this:

    [ ]

    Booting up the game and opening up a campaign ( in my case a Ma Teng campaign ) reveals that the change has worked.

    [ ]

    Of course I wasn't content with just changing the ownership of a single settlement, so I wanted him to have Anding's Livestock Farm aswell.
    I proceeded with the same steps for the second change...

    [ ]

    and did exactly what I did previously (including starting off with a clean Assembly Kit and a new .pack file) The issue is that BOB doesn't want to create a startpos file now. (font "campaign" is red, and clicking on the red message reveals "startpos file not found after running the game")

    [ ]

    Double-checking with the 3k_main_campaign_map folder reveals that a startpos.esf file was not made.

    I don't know where the mistake is, and I couldn't find a post anywhere with a similar issue.

    In case anyone asks why I keep installing and uninstalling the Assembly Kit:
    for some reason BOB creates a startpos file when I add a second change to the table after building a CEO and a startpos.esf with the first change. The newly made startpos (BOB says the processing was successful) doesn't show up in the respective folder. There is only the previously made startpos inside, rendering the change I made useless, because its not picked up. For that reason, I uninstalled the Assembly Kit and tried making multiple changes in the table at once. As you can see, it didn't work for me either.

    I'm out of ideas, and I hope one of you can shine some light in the darkness.

    Cheers, Britzler.

  2. #2

    Default Re: BOB doesn't want to create startpos.esf file with multiple changes to the start_pos_regions table

    So, i was having the same issue, and there might be two things you can try.

    the first is if you are using two disc drives, and the game is on a different drive (game is on D:\ & assemble Kit is on C:\)

    the second is to run a verification on your assembly kit. Right click on the assembly kit in steam and click on "Properties" go to "Local Files" and click on "Verify Integrity of Tools file"

    hope that helps, the second one is what ended up working for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts