Results 1 to 17 of 17

Thread: Difficulty Applying the hotfix

  1. #1

    Default Difficulty Applying the hotfix

    When applying the Hotfix do I (After deleting the 8 files specified in the readme.)

    a. Just copy and paste it into the main Data folder?

    or

    b. Direct it to a sub folder within the Data folder. If so which is it?
    Last edited by jim600; May 04, 2021 at 04:19 AM.

  2. #2

    Default Re: Difficulty Applying the hotfix

    Just copy the data folder and paste into the into the ebii folder in the mods folder of your medieval II install.

    Quote Originally Posted by realm56 View Post
    I got the install to work, the zip was never the issue, it is the fact that you have to copy the data folder for the patch into the eb2 folder in the common/Medieval 2/mods/eb2 pathway instead of copying the file into the data folder in the eb2 folder itself.

  3. #3

    Default Re: Difficulty Applying the hotfix

    Are you sure? It`s just contrary to the install instructions posted on page 1.

    Could someone please confirm the way to apply 2.3A

    Thany you

  4. #4

    Default Re: Difficulty Applying the hotfix

    Drag the data folder from the zip and drop it on top of your data folder. It should ask you if you're sure you want to overwrite various things (which you do).

  5. #5

    Default Re: Difficulty Applying the hotfix

    Thank you Quintus.S.

    For the Hotfix

    Do I just copy and paste the unzipped Hotfix folder to the Data folder - just like the 2.35A file?

    Thank you

  6. #6
    Raiuga's Avatar Civis
    Join Date
    Sep 2014
    Location
    Portugal
    Posts
    155

    Default Re: Difficulty Applying the hotfix

    Quote Originally Posted by jim600 View Post
    Thank you Quintus.S.

    For the Hotfix

    Do I just copy and paste the unzipped Hotfix folder to the Data folder - just like the 2.35A file?

    Thank you
    Extract "data" folder in the hot fix to the ebii folder. if it doesn't ask you to replace files, you are doing it wrong.

  7. #7

    Default Re: Difficulty Applying the hotfix

    Hey,

    I am having issue with the patching. I succesfully installed the mod but when I drag the files into the game it tells me to overwrite 4271 files. I replace the files and then go and delete the selected files - however I don not see the effect_evt, music and sfx folder there under data/sounds, only voice.

    And then when I launch the game it still says only EB2 v2.35, which tells me the patch has not been succesfully applied.

    I am using the steam version, I have it installed outside of program files under D:/STEAM/...

    Any idea what might be the issue?

    More information:
    I did a clean installation, ran the M:TW2 campaign, then installed EB2 and ran it without any problems. Then when I try to apply the patch I encountered errors. BTW the game is running perfectly, no crashes etc, fast and crisp. Just it seems the patch is not registering.

    Also - the file I downloaded say EBII 2.35A Patch FINAL R1 (inside it just says 2.35 patch) even though I downloaded it from the R2 thread so not sure if it doesn't lead to a wrong file?

    Thanks in advance!

  8. #8

    Default Re: Difficulty Applying the hotfix

    If your loading screen doesn't have a changed version number, the patch has not been applied. Did you drop the folder in the right place? It should ask you to overwrite files if you did.

    Also there are two patches, the Final R1, plus the little R2. You need to apply both, in that order.

  9. #9

    Default Re: Difficulty Applying the hotfix

    Hello Quintus,

    thank you for a quick reply. I think I patched it in the right place, as I mentioned it asks to overwrite 4271 files. What is the correct folder? I thought it would be the root where I see the EB2 launcher. Is that not correct?

    I know this is a lot to ask but could you maybe link here the two donwloads? I think my issue might be I just applied the R1 patch (600 MB) and not the second one (R2)? Or link the threads where I can find them please, the direct downloads in the R2 and the torrent only lead to one file which is called EBII 2.35A Patch FINAL R1.

  10. #10

    Default Re: Difficulty Applying the hotfix

    Update: I found the other file, my bad for misreading the instructions.

    So now I have EB2 v2.35A R1 and R2 patch. I tried applying them both again but no change.

    I guess I will try to do a clean install tonight and do it all over again. Something had to go wrong during the installation

    I will install the Medieval II, then Patch 1 and patch 2 and see if it works next time. I might have screwed up somewhere, can't figure out where though. Weird. Thanks for the help so far though, I appreciate it!

  11. #11

    Default Re: Difficulty Applying the hotfix

    No, you install Med 2, then EBII v2.35, then patch R1, then patch R2.

    You drop the two patches into mods\ebii\data\

  12. #12

    Default Re: Difficulty Applying the hotfix

    Quote Originally Posted by QuintusSertorius View Post
    No, you install Med 2, then EBII v2.35, then patch R1, then patch R2.

    You drop the two patches into mods\ebii\data\
    Hah, yes, that is what I meant! Sorry, I was in a hurry when writting the last post. My apology!

    Now I decided to do it all over again so this is what I did (every step):


    • Uninstalled EB2, uninstalled Medieval and deleted all files left behind in install folder
    • Restarted the computer
    • Clean Steam install of EB2 into D:\Steam\SteamApps\common\medieval ii total war
    • Started a campaign as Venice, then quit – everything OK in game
    • Installed EB2 into D:\Steam\SteamApps\common\medieval ii total war
    • Started the game via the launcher on desktop for Steam users, Game states EB2 v2.35
    • Ran a campaign as Malkuta – everything OK in the game
    • Restarted computer (just in case)
    • Moved folders: “Data and logs” from file EBII 2.35A Patch FINAL R1 into D:\Steam\SteamApps\common\medieval ii total war
    • Got a prompt to Rewrite 11 files with the same name (events.dat, events.idx, music.dat, music.idx, SFX.dat, SFX.idx, descr_regions.txt, map.rwm, campaign_script.txt, descr_mercenaries.txt, descr_strat.txt), confirmed it
    • Deleted the files mentioned in the “delete_these_files.png”
    • Started the game via the launcher on desktop for Steam users, I see loading screen and then immediately CTD with: Unspecified error: Please compress your error log into a zip format and upload it on EB2 Technical help forum


    I got the system.log.txt prepared if you want me to upload it somewhere? Not sure if I can upload it here

  13. #13

    Default Re: Difficulty Applying the hotfix

    Ah, got it. Upload function was hidden behind advanced
    Attached Files Attached Files

  14. #14

    Default Re: Difficulty Applying the hotfix

    Additional info - I have Steam version of Total War: Medieval II - Definite edition. No betas opted in so that should be OK.

    I checked the sizes of the files I downloaded:

    EBII is torrented at size 6.36GB
    EBII 2.35A Patch FINAL R1 has size of 916 349 KB, can be unzipped without any issues
    EBII v2.35A R2 fix-patch has a size of 45 707 KB (I haven't even touch it yet)

  15. #15

    Default Re: Difficulty Applying the hotfix

    Oh god I realized what I did now! I copied the files over the original installation and not the mod itself! I am so dumb, let me try to correct it!

  16. #16

    Default Re: Difficulty Applying the hotfix

    It works now for me. Apology, the error was located between the computer keyboard and chair.

    Thanks for the time!

  17. #17

    Default Re: Difficulty Applying the hotfix

    Yeah, you have a \mods\ folder so you can install multiple mods without ever changing your vanilla files. That's the point of them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •