Quote Originally Posted by will19011 View Post
I actually came here to post that I had found a solution and yes it is to modify the normal config file. Hopefully this will help others or you could sticky it as a fix for Mac users.

You must go to the normal config file while is not in the steamapps/med2 folder as it would be on Windows.

The file is in users/username/library/applicationsupport/feralinteractive/med2/vfs/local/preferences/medieval2.preference.cfg

I copied the hotseat parameters from the TGC.cfg file and replaced the ones in the medieval2.preference.cfg file and now it works normally. No hotseat notification at the start of a campaign and none at the beginning of a turn.

You must also check "unlock all factions" in the Feral Interactive MED2 launcher.

Thanks for the help and hopefully this will help others as well.
I hope this will help our friends.