Results 1 to 6 of 6

Thread: Completely messed up modded units

  1. #1
    shineoneucd's Avatar Laetus
    Join Date
    Aug 2020
    Location
    Somewhere in Indiana
    Posts
    4

    Default Completely messed up modded units

    Hello! I am very new to total war modding, and this is my first post on the TWC forums, but I have a huge problem and can't find a solution to it anywhere. I wanted to make a new unit in ss 6.4, called Polish Handgunners. Basically I just took the models of the polish knights and gave the unit handcannons. The gameplay works fine, it's basically just handgunners with a different model. But the model is What's messed up. For one, there's no animation, and two, most of the body parts are missing. I have no idea what I did or what happened that caused this, I even went into milkshade and changed the vertices to what I THOUGHT were the proper joints. I really have no idea what I'm doing, all of my knowledge comes from https://www.twcenter.net/forums/show...dieval-2-units and http://www.twcenter.net/forums/showt...glish-speakers. If any of you know what could have cause this, or how to fix it, I would be very greatful. I'll leave some images below so you can see what the problem might be

    Image links:
    https://imgur.com/bnpEKZc
    https://imgur.com/ACHWNuv

    Milkshade links:
    https://imgur.com/vgAMozz
    https://imgur.com/uYnEBqx
    https://imgur.com/VbpRLwY

    Files links:
    https://imgur.com/RVWR6jb
    https://imgur.com/LVfXBxY

  2. #2
    shineoneucd's Avatar Laetus
    Join Date
    Aug 2020
    Location
    Somewhere in Indiana
    Posts
    4

    Default Re: Completely messed up modded units

    I forgot to mention, I used the LOD2 of the polish knights, and for some reason they don't show up at all, they just go completely invisible. I have no idea why.

  3. #3
    Vladyvid's Avatar Wizard of Turmish
    Artifex

    Join Date
    Aug 2011
    Location
    Athkatla
    Posts
    1,547

    Default Re: Completely messed up modded units

    First, welcome to the TWC! As for your problems, might need more details on whats been edited and what not. I cant check those files right now, i could take a look later and give you some feedback if nobody else will do that earlier.

    For now, from what you are describing im suspecting 2 problems: some vertices are not assigned to the bones, and there can be missing/wrong comments in the model and/or groups. I would check that first.

  4. #4
    shineoneucd's Avatar Laetus
    Join Date
    Aug 2020
    Location
    Somewhere in Indiana
    Posts
    4

    Default Re: Completely messed up modded units

    Thank you for responding but I actually found out what the problem was, I forgot to comment it here. I merged the handgun and unit files using ms3d instead of GOM. I re-read the tutorial and noticed it said merge using GOM not ms3d, so I know that for the future at least.

  5. #5

    Default Re: Completely messed up modded units

    I got a question! I want to change mailed knights to italian mailed horses as a new unit but idk what i am doing. Any ideas on I can do change the unit? I can't put an image on here bc milkshape does not allow me to save unless I have bought it.

  6. #6
    Vladyvid's Avatar Wizard of Turmish
    Artifex

    Join Date
    Aug 2011
    Location
    Athkatla
    Posts
    1,547

    Default Re: Completely messed up modded units

    I dont understand your question, or what is exactly the question.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •