Results 1 to 7 of 7

Thread: AI (enemy)Units Not Acting Cohesively

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Agrippa19's Avatar Tiro
    Join Date
    Mar 2012
    On top of the hill

    Default AI (enemy)Units Not Acting Cohesively

    Recently dived back into RS3 as I want to fight out a diadochi war, I've had this problem on a previous install and have posted before about it but didn't get an answer to solve the porblem

    Playing on Steam - ALX.
    RS3 patched to RS3.1.
    1 Turn (Seleuicids and Rome)
    I've copied the Alex formation AI from the 'Important Stuff' folder.
    I've chosen Sinuhet formations and tried Athenogras as well.
    I've tried subbing in and out units stats form RS2.6 and RS3 original.


    Battle of Raphia;
    I (Seleucids) attack Ptolemy. I advance. Ptolemy general charges my phalanes leaving his entire army behind him. His phalanx run forward, break formation and run back. Ptolemy dies. The enemy send one phalanx at a time forward. I destroy them one by one.

    Battle of Lake trasimene;
    Hannibal attacks.
    Hannibal charges ahead of his army. His numidian cavalry charge head on into my polybian cohorts and don't flank. They lose head to head. Infantry stays behind, but one unit at a time advances allowing me to deal with them one by one. Hannibal stays fighting allowing me to surround and kill him as he's isolated.

    This seems to be the case no matter what battle Ai formation I choose and I have subbed in and out the old RS2.6 units stats and new RS3 unit stats.

    We're all downloading the same RS3 files aren't we? Is this not a common problem and if so how have you fixed it? Please help
    Last edited by Agrippa19; March 29, 2020 at 02:44 PM. Reason: More info

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts