Page 3 of 3 FirstFirst 123
Results 41 to 50 of 50

Thread: Ports and trade fleets are bugged it seems

  1. #41
    Jurand of Cracow's Avatar History and gameplay!
    Join Date
    Oct 2012
    Location
    Cracovia
    Posts
    6,525

    Default Re: Ports and trade fleets are bugged it seems

    Quote Originally Posted by Nordlaender View Post
    I'm sorry. What do you mean by a "working version"? The photos or screenshots I made are from my SS 6.4 mod working on the campaign map.

    Can you be a little more exact as to what you want me to show you?


    Also, I notice that in your set-up above, the wharves all require additional buildings to be present. Are those buildings present?
    The ERROR message in the bottom left corner means that the script has not been loaded due to an important error in this script. It may impact on the performance of the buildings, I guess. The additional building is needed for the wharf to be built, but has no impact on capabilities (so no impact on the trade fleets).

  2. #42

    Default Re: Ports and trade fleets are bugged it seems

    Quote Originally Posted by Jurand of Cracow View Post
    The ERROR message in the bottom left corner means that the script has not been loaded due to an important error in this script. It may impact on the performance of the buildings, I guess. The additional building is needed for the wharf to be built, but has no impact on capabilities (so no impact on the trade fleets).
    Hmmm... I have not received any ERROR messages regarding the trade fleets or ports in my mod of SS 6.4, neither in the system.log nor on the campaign map.

  3. #43

    Default Re: Ports and trade fleets are bugged it seems

    Quote Originally Posted by Jurand of Cracow View Post
    Can you show a working version of those 4 fleets? ERROR here is shown - fortunately, Stainless Steel is programmed to show when the script is not working.
    I had RR/RC 2.0 lingering, so I renamed the folder to british_isles and used the console on Venice.
    Spoiler Alert, click show to read: 


    Note I am not dumping the data folder - I am renaming the root folder of the mod. From there, you have 3 options for running it:
    1) the steam drop down menu;
    2) a shortcut to medieval2.exe with launch options (when using a shortcut I put the original folder name in the shortcut name to make undoing this simple - [modname]_[launching folder]);
    These are the least hassle but use your root medieval2.preference, you also can miss out on extras that require a launcher; RR/RC has an opponent formation bias you can select for example, I think in some mods it impacts music?

    3) create a shortcut to the bat/exe (after you've renamed the folder, otherwise the shortcut points in the wrong place)
    - change in the mod's config file, the mod path in
    [features]
    mod = X

    and
    [log]
    to = X
    - check that the bat file is universal, some old ones (like retrofit, in my previous screenshots) have a specific path and you need to right click->edit->change the path. If there's an exe that isn't universal you're kind of hardstuck, haven't seen that just yet
    Currently playing JLMP's vanilla kingdoms this way, no issues

    When you want to get rid of it, you rename the root folder to the original name and rename the new mod to the kingdoms name.
    Quote Originally Posted by Jadli View Post
    This is interesting... curious, if for example you have a save (or a hotseat) made in one of the folders, and then sometimes played in the renamed folder, whther it changes each time, or it stays as in the folder where it was created?
    Saves are stored in the mod folder/saves (for example crusades/saves), when it gets renamed (crusades->retrofit) the saves are thus transferred (retrofit/saves) and there is no issue.
    Edit: I may have misunderstood what you meant - are you asking if the trade behaviour changes depending on how you load a save? If so, yes. But I have noticed that if you load in one way a save that was created the other way (creating the save in retrofit and loading in crusades as well as vice versa), the victory condition tga in the faction overview window disappears. So I am not entirely convinced it is save compatible to create a game one way and load it the other.
    Last edited by Artorath; January 23, 2022 at 09:08 PM.

  4. #44
    Jurand of Cracow's Avatar History and gameplay!
    Join Date
    Oct 2012
    Location
    Cracovia
    Posts
    6,525

    Default Re: Ports and trade fleets are bugged it seems

    Quote Originally Posted by Artorath View Post
    I had RR/RC 2.0 lingering, so I renamed the folder to british_isles and used the console on Venice.
    Spoiler Alert, click show to read: 
    Well, you're showing that indeed 4 export fleets are possible, as Nordlaender had shown before. This is a puzzle to me why I cannot replicate it.

    Quote Originally Posted by Nordlaender View Post
    Hmmm... I have not received any ERROR messages regarding the trade fleets or ports in my mod of SS 6.4, neither in the system.log nor on the campaign map.
    In your pic in the bottom left corner there's ERROR message in red, in your UI. In the SS it signifies that the script.txt is not loaded, but you may have changed something so it may not matter after all.

  5. #45

    Default Re: Ports and trade fleets are bugged it seems

    Quote Originally Posted by Jurand of Cracow View Post
    Well, you're showing that indeed 4 export fleets are possible, as Nordlaender had shown before. This is a puzzle to me why I cannot replicate it.


    In your pic in the bottom left corner there's ERROR message in red, in your UI. In the SS it signifies that the script.txt is not loaded, but you may have changed something so it may not matter after all.

    Oh wow! I never noticed that before. I didn't know it was a word. Just thought it was some kind of design. Thanks for bringing that to my attention.

    I have no idea what it means, but I will look for it again. I did have a problem with a merchant standing too close to a princess that made the game crash, but I don't think that was it. I will check again and see if it is still there.

    Thanks!
    Last edited by Nordlaender; January 24, 2022 at 03:21 PM.

  6. #46

    Default Re: Ports and trade fleets are bugged it seems

    Quote Originally Posted by Jurand of Cracow View Post
    Well, you're showing that indeed 4 export fleets are possible, as Nordlaender had shown before. This is a puzzle to me why I cannot replicate it.


    In your pic in the bottom left corner there's ERROR message in red, in your UI. In the SS it signifies that the script.txt is not loaded, but you may have changed something so it may not matter after all.
    Uhh... you're right. It appears there at the start of every campaign, regardless of faction, and stays there turn after turn. I don't know what should go there or if it has any effect on the game. I cannot find a specific reference to it in the system.log, so...

    Guess I'll have to live with it.

  7. #47
    Jurand of Cracow's Avatar History and gameplay!
    Join Date
    Oct 2012
    Location
    Cracovia
    Posts
    6,525

    Default Re: Ports and trade fleets are bugged it seems

    Quote Originally Posted by Nordlaender View Post
    Uhh... you're right. It appears there at the start of every campaign, regardless of faction, and stays there turn after turn. I don't know what should go there or if it has any effect on the game. I cannot find a specific reference to it in the system.log, so...

    Guess I'll have to live with it.
    If your script works, then it's ok. Otherwise - I cannot imagine how does your game look like with scripts.

  8. #48

    Default Re: Ports and trade fleets are bugged it seems

    Quote Originally Posted by Jurand of Cracow View Post
    Well, you're showing that indeed 4 export fleets are possible, as Nordlaender had shown before. This is a puzzle to me why I cannot replicate it.
    To be clear: you are saying you cannot replicate it with the alternative launch strategy (kingdoms-named folder)? Or you cannot replicate it with a normal launch?
    I gave comparative screenshots in my first post because how a mod is run on Steam is a reliable predictor of the trade behaviour for me.

  9. #49
    Jurand of Cracow's Avatar History and gameplay!
    Join Date
    Oct 2012
    Location
    Cracovia
    Posts
    6,525

    Default Re: Ports and trade fleets are bugged it seems

    Quote Originally Posted by Artorath View Post
    To be clear: you are saying you cannot replicate it with the alternative launch strategy (kingdoms-named folder)? Or you cannot replicate it with a normal launch?
    I gave comparative screenshots in my first post because how a mod is run on Steam is a reliable predictor of the trade behaviour for me.
    With a normal launch of a mod. I can't understand how putting anything in a kingdoms named folder would impact on parameters in a mod...

  10. #50

    Default Re: Ports and trade fleets are bugged it seems

    Quote Originally Posted by Jurand of Cracow View Post
    I can't understand how putting anything in a kingdoms named folder would impact on parameters in a mod...
    because CA has unfortunately made/patched the Steam exe to act that way, it's like an engine switch
    Quote Originally Posted by Jojo00182 View Post
    The game checks your modfolder name wether you are playing one of the four dlcs.
    And if you do from i what i can tell so far two things happen slighty different.
    1. The port trade fleet thing
    2. Something with the siege hold_out times is slighty differently calculated (so +/- one turn)
    just use bare geomod and the console to test it yourself, it won't take very long

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •