Results 1 to 7 of 7

Thread: Prec bugged ? Or is it my installation gone wrong ?

  1. #1
    Marvzilla's Avatar Ducenarius
    Join Date
    Apr 2010
    Location
    North-Rhine Westphalia,Germany.
    Posts
    972

    Default Prec bugged ? Or is it my installation gone wrong ?

    As the title says. Did some test battles in custom where I took two units, one to pin down one enemy unit and one non-skirmisher heavy infantry to throw at them. On right clicking once, or twice, on the enemy the unit would slowly walk or trot into melee and charge. Also the charge sound came way too early. After that I disengaged them, reformed, and tried again. This time they would throw, but at best maybe a fourth of the unit would pick their javelins and throw, the rest standing idly by. Of note: I am able to toggle fire-at-will for every heavy infantry unit with prec missiles, they are untoggled at the start of the battle though. It only seems to work correctly if I toggle fire-at-will for them as in 2.3.

    I am pretty certain I have a clean install. I played mutiple battles in two campaigns and never noticed this due to managing the battles, though I just toggled on fire-at-will most of the time. Ive gotten one CTD due to this in a custom battle, though the logs say nothing. Help ?

    Edit: Playtesting if this happens in the campaign, apparently not. Here the units such as Hastati seem to work as intended, right click, whole units throws precursors and then charges. If I halt them before that and give the command again, they repeat the whole, so more micro but better functioning charges etc. Here the whole units does it aswell, mostly. Though I am still able to toggle on fire-at-will. Tried this with both Pergamon and Rome.
    Last edited by Marvzilla; December 15, 2018 at 11:14 PM.

  2. #2

    Default Re: Prec bugged ? Or is it my installation gone wrong ?

    I just confirmed that yes, you can toggle "fire-at-will" mode for at least some (maybe all) of these units. There does seem to be an incompatibility with prec (to include causing CTDs) so for now I highly recommend against using that toggle. We'll have to research this further, as I was pretty certain it didn't work when first implemented.
    EBII Council

  3. #3
    Marvzilla's Avatar Ducenarius
    Join Date
    Apr 2010
    Location
    North-Rhine Westphalia,Germany.
    Posts
    972

    Default Re: Prec bugged ? Or is it my installation gone wrong ?

    I think its also worth looking into that the prec system functions nicely in campaign battles, but custom seems to be bugged out.

  4. #4

    Default Re: Prec bugged ? Or is it my installation gone wrong ?

    Quote Originally Posted by Marvzilla View Post
    I think its also worth looking into that the prec system functions nicely in campaign battles, but custom seems to be bugged out.
    Actually it isn't. I ran a ton of tests back in September just prior to reintroducing prec into the dev build, and didn't have a single CTD. In fact, I just re-ran several of them this morning (involving Rome, Makedonian, Aedui, and Arverni), and even when I toggled "FAW-on" for all my javelin infantry, there wasn't a single CTD. That's not to say there isn't a likely issue involving prec units set to FAW-on. You and at least one other guy have reported CTDs which seem to be related. But I can say with absolute certainty that I've had almost 100 field battles over the last 4 months, most involving javelin heavy infantry, and didn't get a single battle CTD.

    Of course, every one of those battles utilized the default "FAW-off" setting. Which should tell us something about how to avoid this CTD.
    EBII Council

  5. #5
    Marvzilla's Avatar Ducenarius
    Join Date
    Apr 2010
    Location
    North-Rhine Westphalia,Germany.
    Posts
    972

    Default Re: Prec bugged ? Or is it my installation gone wrong ?

    Maybe but what I also mean by the difference is how they perform with FAW off (so using them as intended) where in the campaign Hastati for example use their pila how theyre supposed to, where as in the custom battles only a few will use them if they even try to use them and not walk right into melee.

  6. #6

    Default Re: Prec bugged ? Or is it my installation gone wrong ?

    Quote Originally Posted by Marvzilla View Post
    Maybe but what I also mean by the difference is how they perform with FAW off (so using them as intended) where in the campaign Hastati for example use their pila how theyre supposed to, where as in the custom battles only a few will use them if they even try to use them and not walk right into melee.
    I have seen that, but it's not consistent. The majority of the time they operate properly.

    At the end of the day, combat with javelin infantry was awful without prec, and it was compounded by their inexplicable ability to ghost through phalanx formations, destroying them from the inside.
    EBII Council

  7. #7
    QuintusSertorius's Avatar EBII Hod Carrier
    Artifex

    Join Date
    Feb 2008
    Location
    UK
    Posts
    11,631

    Default Re: Prec bugged ? Or is it my installation gone wrong ?

    Also worth noting the AI will not switch FAW on, as indeed it doesn't tend to toggle anything, so this is only a risk to the human player tinkering with things.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •