Page 12 of 12 FirstFirst ... 23456789101112
Results 221 to 237 of 237

Thread: PFM 5.0 - Warhammer 2 support

  1. #221

    Default Re: PFM 5.0 - Warhammer 2 support

    I would also love it if someone could make EditSF work for 3K and allow for 42 unit armies. Though as it stands, after you recruit 3 characters the "Recruit" button becomes grayed out, so there might need to be a workaround to allow the "Recruit" button to not be grayed out so we could have more characters in a single army

  2. #222

    Default Re: PFM 5.0 - Warhammer 2 support

    I'm completely new to this. How do I edit save files using PFM?

  3. #223

    Default Re: PFM 5.0 - Warhammer 2 support

    I believe you're looking for EditSF or a dedicated save file editor rather than PFM. The newest version of Edit SF is available on PFM's Sourceforge page in the Files tab -> EditSF folder.

  4. #224

    Default Re: PFM 5.0 - Warhammer 2 support

    Does someone know how to make different characters in only one units? Like many officers

  5. #225

    Default Re: PFM 5.0 - Warhammer 2 support

    Depends on the game. In Three Kingdoms, I'm pretty sure it is done using land_units_templates_tables. Before Three Kingdoms, I'm not sure of an easy method, though I haven't looked into it before.

  6. #226

    Default Re: PFM 5.0 - Warhammer 2 support

    Hi all
    Hey i have a serious problem using PFM and it really annoys me...
    Well when i clicking on the exe file it takes 5-6 secs and then two same errors pops up one after another.
    It's a very long error message that i never seen it before on any other application.
    What i should do with that?
    please any body help
    Thank you
    It's the message:
    system.net.webexeption:unable to connect to the remote server --->
    system.net.sockets.socketexception:A connection attempt failed because the connected party did not properly respond after a period of time ..............etc

    and it goes on for about 30 line of error!!!!!
    Our great god AHURA MAZDA demands:
    "Good thoughts of the mind, Good deeds of the hand, and Good words of the tongue"


  7. #227

    Default Re: PFM 5.0 - Warhammer 2 support

    Are you using the newest version of PFM? That error message sounds like the auto-updater failing to connect to sourceforge, which happens with all versions prior to 5.0.1. If you are using a newer version of PFM than 5.0, I would appreciate it if you could post the full detail text of the error message to help me find the problem.

  8. #228

    Default Re: PFM 5.0 - Warhammer 2 support

    Quote Originally Posted by Genreless View Post
    Are you using the newest version of PFM? That error message sounds like the auto-updater failing to connect to sourceforge, which happens with all versions prior to 5.0.1. If you are using a newer version of PFM than 5.0, I would appreciate it if you could post the full detail text of the error message to help me find the problem.

    thanks friend for your response
    Yeah unfortunately i use the newest version v 5.2.0 and the full message is a very very long message but i will wright it down just for you:
    ERROR:
    system.net.webexception:unable to connect to the remote server --->
    system.net.sockets.socketexception:A connection attempt failed because the connected party did not properly respond after a period of time,or established connection party did not not properly respond after a period of time,or established connection failed because connected host has fail to respond 216.105.38.13:443
    at system.net.sockets.socket.do connect(Endpointendpointsnapshot,socketAdress socketAdress)
    at system.net.serveicepoint.connectsocketinternal(booleanconnectfailure,socket s4,socket s6,Socket & socket,ip adress & adress,connectsocketstate state,IAsyncResult asyncResult,Exeption & exeption)
    ---End of inner exception stack trace ---
    at system.net.httpwebrequest.getrespond()
    at PackFileManager.findonpage.search()
    at system.threading.executioncontext.runinternal(excutioncontextexcutioncontext,contextcallback callback,object state,boolean preserveSyncCtx)
    at system.threading.execution.context.run(ExcutionContextexcutioncontext,contextcallback callback,object state)
    at system.threading.threadhelper.threadstart()
    Our great god AHURA MAZDA demands:
    "Good thoughts of the mind, Good deeds of the hand, and Good words of the tongue"


  9. #229

    Default Re: PFM 5.0 - Warhammer 2 support

    Hi all,


    Are there any other "tables" that need to be modified to increase the number of soldiers per unit, other than these :
    Land_units_tables
    main_units_tables


    I wanted to modify the units of the "High Elf" faction a little bit (as I had already done before) but this time it doesn't work... the game doesn't even launch...
    (I downloaded PFM version 5.2.0 when in doubt...)


    Any ideas?


    Thank you in advance.




    PS: Sorry for my poor level of English...

  10. #230

    Default Re: PFM 5.0 - Warhammer 2 support

    Quote Originally Posted by Ariamanesh View Post
    thanks friend for your response
    Yeah unfortunately i use the newest version v 5.2.0 and the full message is a very very long message but i will wright it down just for you:
    ERROR:
    system.net.webexception:unable to connect to the remote server --->
    system.net.sockets.socketexception:A connection attempt failed because the connected party did not properly respond after a period of time,or established connection party did not not properly respond after a period of time,or established connection failed because connected host has fail to respond 216.105.38.13:443
    at system.net.sockets.socket.do connect(Endpointendpointsnapshot,socketAdress socketAdress)
    at system.net.serveicepoint.connectsocketinternal(booleanconnectfailure,socket s4,socket s6,Socket & socket,ip adress & adress,connectsocketstate state,IAsyncResult asyncResult,Exeption & exeption)
    ---End of inner exception stack trace ---
    at system.net.httpwebrequest.getrespond()
    at PackFileManager.findonpage.search()
    at system.threading.executioncontext.runinternal(excutioncontextexcutioncontext,contextcallback callback,object state,boolean preserveSyncCtx)
    at system.threading.execution.context.run(ExcutionContextexcutioncontext,contextcallback callback,object state)
    at system.threading.threadhelper.threadstart()
    That's definitely a error from the auto-updater due to the connection either timing out or being refused by Sourceforge. Unfortunately, I couldn't reproduce it on my end. The only problem I can think of other than using the wrong version (which you said isn't the problem) is that while PFM only requires .NET 4.0 to run, the autoupdater looks for an internet protocol introduced to .NET in 4.5. If your installation of the .NET framework doesn't include 4.5 or newer, you could try updating the version you have installed. Otherwise the only thing I could recommend if the error bothers you is to disable the auto-updater running automatically in the options.

    Quote Originally Posted by KhorsKan View Post
    Are there any other "tables" that need to be modified to increase the number of soldiers per unit, other than these :
    Land_units_tables
    main_units_tables


    I wanted to modify the units of the "High Elf" faction a little bit (as I had already done before) but this time it doesn't work... the game doesn't even launch...
    (I downloaded PFM version 5.2.0 when in doubt...)


    Any ideas?
    If you are trying to mod Warhammer 2, it looks like main_units_tables is the only table that needs to be altered to change the number of soldiers per unit. If you're trying to mod Three Kingdoms, the table it is in is different (though the reference to high elves suggests Three Kingdoms isn't relevant to your case). If the game isn't launching with your mod enabled, you probably did something to the files that prevents the game from loading. If you modified the game's files directly, I would recommend moving your changes to their own pack file and reverting the game's files to their default state.

    If you need a reference for the basic process of making a mod here it is:
    1. Make a new pack file.
    2. Add the tables you want to mod using the Files->Add->From Pack... menu.
    3. Rename the new tables in your pack file (identically named files overwrite each other when loaded, the only thing that matters is that they are in the same directory as the vanilla files would be).
    4. Modify the tables.
    5. Delete unmodified rows from your mod or use the Postprocess->Minimize_DB_Files menu option to remove rows and tables that are identical to vanilla to reduce the chance of conflicts with other mods or future game patches.
    6. Place your new mod in the game's data folder so it can be loaded by the game.

  11. #231

    Default Re: PFM 5.0 - Warhammer 2 support

    Quote Originally Posted by Genreless View Post
    That's definitely a error from the auto-updater due to the connection either timing out or being refused by Sourceforge. Unfortunately, I couldn't reproduce it on my end. The only problem I can think of other than using the wrong version (which you said isn't the problem) is that while PFM only requires .NET 4.0 to run, the autoupdater looks for an internet protocol introduced to .NET in 4.5. If your installation of the .NET framework doesn't include 4.5 or newer, you could try updating the version you have installed. Otherwise the only thing I could recommend if the error bothers you is to disable the auto-updater running automatically in the options.
    What option?!I see nothing...Just click on the packfilemmanager.exe and boom the error just pops up.
    About .net framework i should add that i have that last version 4.8
    What should i do?
    Please if you can just help me make it run it just make me mad every time i want to got into it.
    thanks again
    Our great god AHURA MAZDA demands:
    "Good thoughts of the mind, Good deeds of the hand, and Good words of the tongue"


  12. #232

    Default Re: PFM 5.0 - Warhammer 2 support

    Quote Originally Posted by Genreless View Post
    That's definitely a error from the auto-updater due to the connection either timing out or being refused by Sourceforge. Unfortunately, I couldn't reproduce it on my end. The only problem I can think of other than using the wrong version (which you said isn't the problem) is that while PFM only requires .NET 4.0 to run, the autoupdater looks for an internet protocol introduced to .NET in 4.5. If your installation of the .NET framework doesn't include 4.5 or newer, you could try updating the version you have installed. Otherwise the only thing I could recommend if the error bothers you is to disable the auto-updater running automatically in the options.
    Ok i just removed it and extracted it again and this time i deactivated the autoupdater but the the problem still insist and nothing changed!!
    What should i do now?
    Please any body just know any better tool for editing this ing pack files?!
    This PFM seems to be garbage it won't work
    Our great god AHURA MAZDA demands:
    "Good thoughts of the mind, Good deeds of the hand, and Good words of the tongue"


  13. #233

    Default Re: PFM 5.0 - Warhammer 2 support

    Edit: My initial post was made after only seeing your first post. I have changed it to make it relevant to your second post's status. I disabled my network connection to get the error you are experiencing so I could troubleshoot it. It seems the auto-updater runs automatically the first time PFM is run on a new installation or after its settings file is deleted. If you selected for it to not run automatically and then it crashed because its connection timed out or was refused, it will run fine the second time since the settings file remembers your choice and that it is no longer the first run. I'll fix the crash on startup auto-updater failure in the next PFM release.

    For future reference, here is a corrected version my initial post: If you can get PFM to open, it is a toggle in the dropdown menus at the top as "Options->Update on Startup." If PFM isn't opening, the setting is set during initial startup and can be reset by deleting the folders that contain the user settings file altering the settings in the user settings xml file located in "%User_Folder%\AppData\Local\PackFileManager\PackFileManager.exe_Url_*\2.0.0.0\user.config". Where %User_Folder% is your user folder, AppData is a hidden folder in that, and the asterisk in the 'PackFileManager.exe_Url_*' is a number assigned to each installation by the operating system.
    Last edited by Genreless; July 23, 2019 at 08:33 AM.

  14. #234

    Default Re: PFM 5.0 - Warhammer 2 support

    Quote Originally Posted by Genreless View Post
    If you are trying to mod Warhammer 2, it looks like main_units_tables is the only table that needs to be altered to change the number of soldiers per unit. If you're trying to mod Three Kingdoms, the table it is in is different (though the reference to high elves suggests Three Kingdoms isn't relevant to your case). If the game isn't launching with your mod enabled, you probably did something to the files that prevents the game from loading. If you modified the game's files directly, I would recommend moving your changes to their own pack file and reverting the game's files to their default state.

    If you need a reference for the basic process of making a mod here it is:
    1. Make a new pack file.
    2. Add the tables you want to mod using the Files->Add->From Pack... menu.
    3. Rename the new tables in your pack file (identically named files overwrite each other when loaded, the only thing that matters is that they are in the same directory as the vanilla files would be).
    4. Modify the tables.
    5. Delete unmodified rows from your mod or use the Postprocess->Minimize_DB_Files menu option to remove rows and tables that are identical to vanilla to reduce the chance of conflicts with other mods or future game patches.
    6. Place your new mod in the game's data folder so it can be loaded by the game.
    Thank you very much. It works !!

  15. #235
    Steph's Avatar Maréchal de France
    Patrician Artifex

    Join Date
    Apr 2010
    Location
    Pont de l'Arn, France
    Posts
    8,301

    Default Re: PFM 5.0 - Warhammer 2 support

    This is not completly correct. If you modify the number of men of a cavalry unit, you also need to change the land_units (number of mounts), main_unit is not sufficient. Same with number of engines for chariots or artillery.

  16. #236

    Default Re: PFM 5.0 - Warhammer 2 support

    True, I wasn't thinking about those cases, I was interpreting the question more along the lines of their problem with their mod preventing the game from loading.

  17. #237

    Default Re: PFM 5.0 - Warhammer 2 support

    PFM 5.2.1 is out now along with schema 137. PFM 5.2.1 resolves a potential crash when the auto-updater runs and fails to connect to the repository as well as making the auto-updater respect users' choice about whether it should run during PFM's first startup on a new install. Schema 137 is a minor update of tables I had decoded already or recently promised to release. I'm now going back to working on a tool to automatically decode un-decoded table schemas so I can do a bulk release of the undecoded schemas soon hopefully.

Page 12 of 12 FirstFirst ... 23456789101112

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •