Page 298 of 300 FirstFirst ... 198248273288289290291292293294295296297298299300 LastLast
Results 5,941 to 5,960 of 5999

Thread: [Support] 1.2 Bug Reports

  1. #5941

    Default Re: [Support] 1.2 Bug Reports

    Quote Originally Posted by Jake Armitage View Post
    yeah. just make an external pack with dei vanilla scripts and load them before your packs
    how it will work... depends on what you did previously
    Sorry for the noobish question, but what are the file names for the dei vanilla scripts? And just to double check -- loading first means putting them higher in the Rome 2 mod manager list i.e. the first mod in the list gets loaded first?

  2. #5942

    Default Re: [Support] 1.2 Bug Reports

    Yes that is correct. And the vanilla scripts are found in a couple spots, depending on what you need. campaigns/main_rome/scripting.lua is the file that loads the scripts for the main campaign (each campaign has their own)
    Then you will find the scripts themselves under lua_scripts and /script/_lib All in part 1

    ----> Website -- Patreon -- Steam -- Forums -- Youtube -- Facebook <----

  3. #5943

    Default Re: [Support] 1.2 Bug Reports

    Quote Originally Posted by Dresden View Post
    Yes that is correct. And the vanilla scripts are found in a couple spots, depending on what you need. campaigns/main_rome/scripting.lua is the file that loads the scripts for the main campaign (each campaign has their own)
    Then you will find the scripts themselves under lua_scripts and /script/_lib All in part 1
    So I've tried making a new mod with all of lua_scripts and /script/_lib scripts in it and loaded that at the top of the load order and still no luck. Dresden you mentioned campaigns/main_rome/scripting.lua, is there anything I actually need to do with that file? So far no luck on getting pops to grow in any of my settlements even after end turning twice. Any other ideas I can try?

    Thanks!

  4. #5944

    Default Re: [Support] 1.2 Bug Reports

    Update: I 'fixed' the issue by installing and running the No Population submod for one turn and then uninstalling it and ending turn again. The pop levels reset to standard values but it seems to be working. I'll almost certainly encounter some issues because of this but it's allowed me to get a few more turns out of an almost bricked campaign.

  5. #5945

    Default Re: [Support] 1.2 Bug Reports

    It sounds like the script got bugged somehow, very odd. Hopefully your fix works!

    ----> Website -- Patreon -- Steam -- Forums -- Youtube -- Facebook <----

  6. #5946
    GM207's Avatar Semisalis
    Join Date
    Nov 2010
    Location
    Mew York
    Posts
    498

    Default Re: [Support] 1.2 Bug Reports

    Dear Dresden,
    I just wanted to report a bug and see if there was a fix for it, I believe it's a CA bug from all the research I've made, and it involves the AI power and influence rising despite not having them get involved in any political actions and or battles.
    I am playing as Julia and now at 19% influence, Cornelia is at 8% influence, Junia is at 8%, and the Plebians are at 59% influence and rising, no matter what I do.
    I am playing a very slow campaign 12TPY and now at my 209th turn, everything seems to be going very well, except for that small annoying problem.
    Not sure if you are aware of this, but many many other people are, some have reported it without having mods at all!
    When you can if you would please let me know if there's something that could be done about it.
    Thank you and regards.
    GM207
    Last edited by GM207; November 01, 2020 at 01:07 PM.

  7. #5947

    Default Re: [Support] 1.2 Bug Reports

    Spoiler Alert, click show to read: 


    Latest version. No submods. Caesar In Gaul -multiplayer campaign. The Nervii seem to have a permanent -10 to -15 public order debuff due to "events". Lower public order debuffs are normal but when they have gone on for the duration of the entire campaign (now 43 turns) it starts to seem kinda weird what is causing this. This causes constant rebellions and stops the development of every region. Might not be a bug but something that I have missed to notice but can't figure out what

  8. #5948

    Default Re: [Support] 1.2 Bug Reports

    Dear Dei team,

    Cretan Infantry(those with no equipment who wields from battlefield) is bugged, most of the time when I give attack order, they have the old pre-cursor javelin animation without actually throwing while wasting ammonution. When I give throw javelin orders when they have 1 ammo, they charge instead. I hope you get what I mean.

    Regards.

  9. #5949

    Default Re: [Support] 1.2 Bug Reports

    Hi DEI team. im getting some weird bug i think were some units icons stay in vanilla, and the games UI stays vanilla aswell, never had this problem before, it just appear out of the blue. I did tray reinstalling the game and only installing DEI mods just to make sure there wasnt any sort of mod conflict but the bug persists, everything else seems to be as regular DEI.

    Thanks for any help in advance

  10. #5950

    Default Re: [Support] 1.2 Bug Reports

    Hello!
    I experienced a population bug. From one turn to another the population switched completely. Unfortunately I noticed it after a couple of turns and cannot tell when it happened exactly.
    I continued the game from an older save when all has still be fine and till now it did not occur again. So, it is just for your information. I make a save game now each turn and if it will happen again, I will provide you with the saves.


    Click image for larger version. 

Name:	pop.jpg 
Views:	9 
Size:	345.4 KB 
ID:	362930

  11. #5951

    Default Re: [Support] 1.2 Bug Reports

    Quote Originally Posted by tndgu View Post
    Dear Dei team,

    Cretan Infantry(those with no equipment who wields from battlefield) is bugged, most of the time when I give attack order, they have the old pre-cursor javelin animation without actually throwing while wasting ammonution. When I give throw javelin orders when they have 1 ammo, they charge instead. I hope you get what I mean.

    Regards.
    Thanks will check it out
    Quote Originally Posted by Oryx View Post
    Hi DEI team. im getting some weird bug i think were some units icons stay in vanilla, and the games UI stays vanilla aswell, never had this problem before, it just appear out of the blue. I did tray reinstalling the game and only installing DEI mods just to make sure there wasnt any sort of mod conflict but the bug persists, everything else seems to be as regular DEI.

    Thanks for any help in advance
    The only way I know of the UI not showing up properly would be if one of the DeI packs is not loaded, if they are loaded in the wrong order, if another mod is loaded, or if there is some sort of weird install/launcher issue.
    Quote Originally Posted by macabre View Post
    Hello!
    I experienced a population bug. From one turn to another the population switched completely. Unfortunately I noticed it after a couple of turns and cannot tell when it happened exactly.
    I continued the game from an older save when all has still be fine and till now it did not occur again. So, it is just for your information. I make a save game now each turn and if it will happen again, I will provide you with the saves.


    Click image for larger version. 

Name:	pop.jpg 
Views:	9 
Size:	345.4 KB 
ID:	362930
    Thanks, if it happens again please do post the saves! Sometimes weird things happen with the pop system.

    ----> Website -- Patreon -- Steam -- Forums -- Youtube -- Facebook <----

  12. #5952

    Default Re: [Support] 1.2 Bug Reports

    Dear DeI Team,
    Here is the VIDEO of the bug I have mentioned before which happens quite often.

    AI units retreat towards deep inside my lines rather than backwards to theirs, they can push phalanx units, pike units, regardless of their Mass.
    As I have posted before, a light cavalry unit can literally push and break formation of 2 lines of phalanx infantry without actually dying.

    https://youtu.be/869USnFBhok

    I didn't lose the battle this time since bronze shield pikes are solid units, but if they were trash units against heavy sword infantry, my lines would get annihilated which happened in the past. My 5 units of pontic pikes routed because enemy azat noble cavalary just were in the same spot as this spearman, and once they decided to not route and continue the fight, they charged my pikes from behind...

    note: I don't use kam's alternative pike-phalanx mode here.

    Here is the other post where I have alternative phalanx mod and enemy light cavalary literally ruining my entire formation,

    https://www.twcenter.net/forums/show...=#post15963927

    Regards.
    Last edited by tndgu; November 04, 2020 at 07:53 AM.

  13. #5953
    KAM 2150's Avatar Artifex
    Join Date
    Jul 2013
    Location
    Gdańsk, Poland
    Posts
    10,753

    Default Re: [Support] 1.2 Bug Reports

    Nothing we can do about it, this bug is still is recently released Troy Total War. Bascially CA never added proper collission to infantry so they can be pushed by any other unit type.

    For example check Darrens review of Troy at around 3:07 to 3:27.
    https://www.youtube.com/watch?v=8Ftky2uu1ow
    Last edited by KAM 2150; November 04, 2020 at 09:02 AM.
    Official DeI Instagram Account! https://www.instagram.com/divideetimperamod/
    Official DeI Facebook Page! https://www.facebook.com/divideetimperamod

  14. #5954

    Default Re: [Support] 1.2 Bug Reports

    Quote Originally Posted by KAM 2150 View Post
    Nothing we can do about it, this bug is still is recently released Troy Total War. Bascially CA never added proper collission to infantry so they can be pushed by any other unit type.

    For example check Darrens review of Troy at around 3:07 to 3:27.
    https://www.youtube.com/watch?v=8Ftky2uu1ow

    Ouch, nothing to do in this case. For most of us rome2 doesn't exist without divide et impera, so we forget that CA must get the complaint.

    As far as I remember, in vanilla units die way faster so I thought that it wouldn't be possible to simply break through pike formation without actually dying...

    Do people in multiplayer games abuse those glitches?

  15. #5955
    KAM 2150's Avatar Artifex
    Join Date
    Jul 2013
    Location
    Gdańsk, Poland
    Posts
    10,753

    Default Re: [Support] 1.2 Bug Reports

    They used too but like you said, in vanilla due to very fast pace you might not notice it as that unit will just die. In Attila they tried to combat it by simply making moving unit to be one hit killed but that casued a ton of other issues, for example often AI would pull away some elite units from you levy, which would trigger your levy to charge and destroy it.


    Also to add to above, you can in fact make units impossible to pass through other by increasing their mass, it would also apply to friendly units. As always, issues it creates is that it throws whole cav/elephant charges out through the window and it would not work for similar units. For example if you make levy archer to have 1 mass and hoplites to have 10000 mass, these archers will not be able to pass through them. Now if these hoplites would find another unit of hoplites, they would be able to pass through them again since their mass would be same anyway. In case of cav, 1 mass units would be outright destroyed even by currently lightest cav units on charge while these hoplites with 10000 mass would kill cavalry smashing into them as if they are brick wall. Even elephants would be stopped in place.
    Last edited by KAM 2150; November 04, 2020 at 10:37 AM.
    Official DeI Instagram Account! https://www.instagram.com/divideetimperamod/
    Official DeI Facebook Page! https://www.facebook.com/divideetimperamod

  16. #5956

    Default Re: [Support] 1.2 Bug Reports

    Quote Originally Posted by KAM 2150 View Post
    They used too but like you said, in vanilla due to very fast pace you might not notice it as that unit will just die. In Attila they tried to combat it by simply making moving unit to be one hit killed but that casued a ton of other issues, for example often AI would pull away some elite units from you levy, which would trigger your levy to charge and destroy it.


    Also to add to above, you can in fact make units impossible to pass through other by increasing their mass, it would also apply to friendly units. As always, issues it creates is that it throws whole cav/elephant charges out through the window and it would not work for similar units. For example if you make levy archer to have 1 mass and hoplites to have 10000 mass, these archers will not be able to pass through them. Now if these hoplites would find another unit of hoplites, they would be able to pass through them again since their mass would be same anyway. In case of cav, 1 mass units would be outright destroyed even by currently lightest cav units on charge while these hoplites with 10000 mass would kill cavalry smashing into them as if they are brick wall. Even elephants would be stopped in place.

    I understand now. So technically, it can't be solved.
    Can nothing be done to prevent units routing towards the unit they are fighting? AI don't abuse this bug it only occours when enemy units route and then they don't...

    Also, I somehow found your cav.pack in the forum, and used for a week or so, what changed did you make there in order to make cavalry so light but at the same time heavier?

  17. #5957
    KAM 2150's Avatar Artifex
    Join Date
    Jul 2013
    Location
    Gdańsk, Poland
    Posts
    10,753

    Default Re: [Support] 1.2 Bug Reports

    Just increased their mass and acceleration.
    Official DeI Instagram Account! https://www.instagram.com/divideetimperamod/
    Official DeI Facebook Page! https://www.facebook.com/divideetimperamod

  18. #5958

    Default Re: [Support] 1.2 Bug Reports

    this may seem really minor but Octavian's full name is not in the family tree when you play the imperator augustus campaign

  19. #5959

    Default Re: [Support] 1.2 Bug Reports

    Quote Originally Posted by Dresden View Post
    Thanks, if it happens again please do post the saves! Sometimes weird things happen with the pop system.
    Hello,
    it did happen again and now I have the saves for it, it is even reproducable. Its about the City Taras - unfortunately I get an error when uploading the saves to the attachments in the forum (and the forum is extremely slow at each action, btw). Shall I send it via email or upload it somewhere else?

  20. #5960

    Default Re: [Support] 1.2 Bug Reports

    Hello and health to all! When translating the Divide et Impera mod for Russian-speaking fans of the Total var series of games, I found several inaccuracies when translating long/historical descriptions for several units:
    - two Cimbri units "Nakwašaz" ("land_units_onscreen_name_Ger_Cimbri_naked_spearmen") and "Dugunžiz" ("land_units_onscreen_name_Ger_Cimbri_heavy_spearmen") in the table __Unit_Descriptions_Long_CORE_Barbarian probably have their descriptions mixed up. For example, heavy spearmen ("unit_description_historical_texts_text_ger_cimbri_heavy_spearmen_tooltip") say: "Naked warriors stun and awe enemies not used to their appearance on the battlefield...", and naked spearmen ("unit_description_historical_texts_text_ger_cimbri_naked_spearmen_tooltip") say: "These warriors are the cimbrian answer to triarii…";



    - in table the __Unit_Names_AOR shows the name of the unit "Keltohellenikoi Thorakitai" ("land_units_onscreen_name_AOR_11_celto_hellenic_infantry"), this unit is a heavily-armed warrior, but in the historical descriptions for it ("unit_description_historical_texts_text_aor_11_celto_hellenic_infantry_tooltip") the following text is given - "Thureophoroi were a new class of Hellenic infantry...". Probably this is just a mistake, then maybe it was necessary to assign a text for this unit for Thorakitai - "The Thorakitai represents the second evolution of the concept of the Thureophoroi, and show definite influence from the Roman...". Or a unit can call a unit "Keltohellenikoi Pezoi"?
    I think that in the next update of the Divide et Impera mod, these possible errors in historical descriptions will be corrected.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •