Results 1 to 4 of 4

Thread: Stretched picture. Widescreen issue.

  1. #1
    saamohod's Avatar Tiro
    Join Date
    May 2008
    Unoccupied Ukraine

    Default Stretched picture. Widescreen issue.

    Despite the fact there is a "widescreen" to be ticked in the video options, it doesn't remedy that most of the picture in game is stretched. The circles become ovals etc. I play on 3440*1440 which is pretty wide.
    If anyone knows how to fix it, your help will be much appreciated.
    "Orcs were mustering, and far to the east and the south the wild peoples were arming."

  2. #2

    Default Re: Stretched picture. Widescreen issue.

    Use a more appropriate(smaller) resolution. M2TW game engine is more than 10 years old, there hasn't been an update for so long to address these newest/modern monitors/GPUs/CPUs, and that's why there are issues with playing the game and its mods.
    American, French, Israeli and British government's ILLEGAL aggression against the Syrian people, without any proof for chemical attacks in Douma, and without waiting for OPCW to conduct their investigation..
    Sons of *******, leave that poor, war torn country in peace.
    If you are a citizen of one of these countries, then DO NOT ask any help from me on these forums, since, in protest against this aggression by your governments, I do not provide assistance/help anymore.
    Let Syria be finally in peace.

    A video of false chemical attack in Douma, Syria, which led to Western illegal attacks.

  3. #3
    Withwnar's Avatar Script To The Waist
    Join Date
    Oct 2008

    Default Re: Stretched picture. Widescreen issue.

    The widescreen option only affects the 'main view': the campaign and battle maps. The UI is 1024x768 (4:3) and it is scaled and stretched to fit whatever screen size is chosen; the further away from 4:3 your proportions are the worse it will look. The only fix would be to redesign the UI so everything is squished horizontally, so when it is stretched it looks 'normal'.

  4. #4

    Default Re: Stretched picture. Widescreen issue.

    Allow me to add to an 8 year old thread just in case another nostalgia seeker is looking for a solution to this.

    So I was finally able to fix this using a workaround.

    At first the problem was that the UI behaves completely independently from whatever you put into your preferences.cfg, like Withwnar said. Those lines only affect in-game resolutions, not UI. What the UI in fact does is it'll stretch to fit any aspect ratio that's wider than 4:3. Meaning, if you wanna get rid of UI stretch, your device resolution has to be in 4:3 aspect ratio.

    So I did that on my Mac (which, natively you can only do 1024x768 but it's no problem because I think it's the base resolution for 2006's M2TW). And UI stretching was gone. What's more is if you don't enable widescreen at this resolution, in-game graphics as well as movies run in the correct aspect ratio as well.

    So now the whole game is stretching-free, which happens to be one of my worst pet peeves ever. Yay.

    Computer's native resolution > 4:3
    Then disable widescreen prefs in case you'd enabled it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts