I have the 1.60.22 version, everything runs fine (with the exception of russian texts still showing up, even though I used the english translation after installing the lastest patch), but, my game crashes when I get too near or look too much at these units : Squigs, Dire wolves and Chaos hounds. It's annoying to deal with this but I read in the "Easy and Painfree install" that they were fixed (more tests needed as said in the post). Appreciate any help.