Page 3 of 3 FirstFirst 123
Results 41 to 56 of 56

Thread: {IND} Bugs & Problems

  1. #41
    Morthrug's Avatar Laetus
    Join Date
    May 2009
    Location
    Yggdrasil
    Posts
    21

    Default Re: {IND} Bugs & Problems

    Another one: got a mission to conquer a settlement, but the enemy army (not the one in the city) attacked my siege-laying troops (city troops fought as their reinforcements). I won the battle, the faction got destroyed (their leader and heir killed in combat), so the besieged city went rebel, but since it was completely empty (no troops), one of my 3 armies automatically stepped in and conquered it. I got the message that... another faction has taken the settlement :v I can't remember if it is the original MTW:K "bug", or...

  2. #42
    Aneirin's Avatar of flowing verse
    Join Date
    Nov 2012
    Location
    Gododdin
    Posts
    2,717

    Default Re: {IND} Bugs & Problems

    Allright, I'll have a look after Christmas
    Proud son of Aikanár and brother of Iskar

  3. #43
    Morthrug's Avatar Laetus
    Join Date
    May 2009
    Location
    Yggdrasil
    Posts
    21

    Default Re: {IND} Bugs & Problems

    Since my Christmas are partially devoted to playing your mod, I'll just keep'em coming:

    1) Can't befriend a faction, even though there are no diplomatic discrepancies involved. I destroyed the factied they allied, but never went to war with them personally.
    2) Playing as Edessa: I can't build any ships (I bought a sea region from the Byzantines), but I can build merchant port buldings... in ANY region, even those in the middle of the desert.

  4. #44
    Aneirin's Avatar of flowing verse
    Join Date
    Nov 2012
    Location
    Gododdin
    Posts
    2,717

    Default Re: {IND} Bugs & Problems

    Quote Originally Posted by Morthrug View Post
    Another one: got a mission to conquer a settlement, but the enemy army (not the one in the city) attacked my siege-laying troops (city troops fought as their reinforcements). I won the battle, the faction got destroyed (their leader and heir killed in combat), so the besieged city went rebel, but since it was completely empty (no troops), one of my 3 armies automatically stepped in and conquered it. I got the message that... another faction has taken the settlement :v I can't remember if it is the original MTW:K "bug", or...
    Well, that sounds more like a MTW:K bug rather than one caused by my mod.

    Quote Originally Posted by Morthrug View Post
    Since my Christmas are partially devoted to playing your mod, I'll just keep'em coming:

    1) Can't befriend a faction, even though there are no diplomatic discrepancies involved. I destroyed the factied they allied, but never went to war with them personally.
    2) Playing as Edessa: I can't build any ships (I bought a sea region from the Byzantines), but I can build merchant port buldings... in ANY region, even those in the middle of the desert.
    To 1) Sorry, but what do you mean by 'befriend a faction'? Could you give me some more details?
    To 2) Yes, that is simply because they have none implemented yet. You see, this is just a beta and not a full version. That is why you may encounter some bugs, which actually shouldn't be there for a full version.

    As for your first problem: Would you mind sending me the whole log file? But I guess you haven't got that one any more, right?

    P.S. A happy new year!
    Proud son of Aikanár and brother of Iskar

  5. #45

    Default Re: {IND} Bugs & Problems

    "1) Can't befriend a faction, even though there are no diplomatic discrepancies involved. I destroyed the factied they allied, but never went to war with them personally."

    This sounds like the bug from TATW which prevented Isengard from allying with Gondor after killing Rohan. I forget what the fix for it was.

  6. #46

    Default Re: {IND} Bugs & Problems

    I loaded the game and played for a couple hours. I saved and quit. Now when I try to start the game it will not load on my computer screen. It starts to load and then goes right back to the desktop. Any ideas for me to try?

  7. #47
    ForGondor 68's Avatar Civis
    Join Date
    Mar 2015
    Location
    Nantes, France
    Posts
    177

    Default Re: {IND} Bugs & Problems

    Do you try to delete the map.rwm ?

  8. #48
    Aneirin's Avatar of flowing verse
    Join Date
    Nov 2012
    Location
    Gododdin
    Posts
    2,717

    Default Re: {IND} Bugs & Problems

    I'd recommend you try it just one more time and then send us the log.txt file.
    So we might have a look at it
    Proud son of Aikanár and brother of Iskar

  9. #49

    Default Re: {IND} Download - Beta

    Quote Originally Posted by jester204 View Post
    I downloaded all 4 parts and then ran the installer and went over smoothly however whenever I start it up it plays vanilla m2tw.
    This is my problem right now.
    Running the mod shortcut makes the game run vanilla M2TW.
    Could the developers help me?

  10. #50
    Jurand of Cracow's Avatar History and gameplay!
    Join Date
    Oct 2012
    Location
    Cracovia
    Posts
    3,831

    Default Re: {IND} Download - Beta

    Me, I didn't have problems with installing some time ago - maybe it required the change of the path in the config file, I'm not sure.

    Unfortunately, Aenerin has disappeared and doesn't seem to drop for a look to TWC, even for his more developed mod, The Italian Wars.

    Fortunately, you can play this area in the Broken Crescent mod (and obviously in some bigger-scale mods, like SS-family).
    If you want to play a historical mod in the medieval setting the best are:
    the Stainless Steel Historical Improvement Project,
    and the Broken Crescent + Buff and Shine.
    ........................................................................................................................................
    Reviews of the mods (all made in 2018): SSHIP, Wrath of the Norsemen, Broken Crescent.
    Pros and cons of having merchants in an M2TW mod. Arguments against the forts in M2TW.
    Home rules for playing a game without exploiting the M2TW engine deficiencies.
    Thrones of Britannia: review, opinion on the battles, ideas for modding. No good mod yet, alas!
    Dominant strategy in Rome 2 TW and Attila TW: “Sniping groups of armies”. Still there, alas!
    .................................................................................................................................................................................
    Developer of the SSHIP: traits, ancillaries, script fixing, guides, historical improvements

  11. #51
    Aneirin's Avatar of flowing verse
    Join Date
    Nov 2012
    Location
    Gododdin
    Posts
    2,717

    Default Re: {IND} Download - Beta

    Quote Originally Posted by ThePianist View Post
    This is my problem right now.
    Running the mod shortcut makes the game run vanilla M2TW.
    Could the developers help me?
    Did you install the game on Steam?
    Proud son of Aikanár and brother of Iskar

  12. #52

    Default Re: {IND} Bugs & Problems

    Hello, I have installed the files of the K/T patch (the small zip with the four text files, including the EDU), the game loads and plays normal with these new files, but after I edit the EDU (basically I change the unit sizes by adding more soldiers), the game crashes upon loading.

    I never had this issue before with other mods, simple changes in the EDU shouldn't cause CTDs like this. I know that some mods have CTDs when loading an old campaign after making new changes in the EDU, but this is not my case here, the mod crashes just before loading the main menu; I even tried changing the size of just one unit (like putting 40 soldiers instead of 20 in a cavalry unit), but I keep having the CTD.

    Why the EDU in this mod is so "rigid", if I may say so? Is there a way I can modify it without crashing?

    By the way I don't know if the base EDU of the mod has the same problem as K/T's, I overwrote it with the latter just after installing.

    cheers.

  13. #53
    Aneirin's Avatar of flowing verse
    Join Date
    Nov 2012
    Location
    Gododdin
    Posts
    2,717

    Default Re: {IND} Bugs & Problems

    Have you already had a look at the system.log?
    That would shed some light on the issue.

    As for your question, k/T's file should already be included in the download.
    Proud son of Aikanár and brother of Iskar

  14. #54

    Default Re: {IND} Bugs & Problems

    Hello, thanks for your reply. I attach herein the system log file.

    I have reinstalled the mod, without changes the game loads normally.

    Then I made some changes in the EDU file: I changed the general units' base size from 8 to 40 men, and the general unit's hit points from 1 to 2. After these changes, the game crashes upon loading the main menu.

    I paste here below some lines from the system log file, which might be the culprit (?):

    17:46:07.203 [script.err] [error] Script Error in mods/in_nomine_dei/data/export_descr_unit.txt, at line 1, column 1
    Unknown identifier when new type expected.
    17:46:07.203 [data.invalid] [error] DATABASE_TABLE error found : error reading record from file mods/in_nomine_dei/data/export_descr_unit.txt.
    Attached Files Attached Files

  15. #55
    Aneirin's Avatar of flowing verse
    Join Date
    Nov 2012
    Location
    Gododdin
    Posts
    2,717

    Default Re: {IND} Bugs & Problems

    Hm.. hardly to say what causes the crash. Could you send me that modified edu file?
    Then I might be able to figure it out
    Proud son of Aikanár and brother of Iskar

  16. #56

    Default Re: {IND} Bugs & Problems

    I'm sorry, I don't have it anymore

    but if you want you could just make a single small change in the edu (for example changing the hit points of an infantry unit or the number of soldiers in any one unit), and see if the mod crashes upon loading, just like it happened to me.

    I recently uninstalled the mod; by the way, while uninstalling I noticed that there were a number of files in the mod folder that I was asked permission to delete during the uninstallation process, instead of the uninstaller deleting them automatically (it seemed they had some sort of protection but I don't remember which one).

    this rarely happened to me when uninstalling or deleting mods, if ever at all. I wonder if there is some connection.

    Anyway, thank you for you reply!
    Last edited by Ulakanakulot; December 03, 2019 at 07:11 PM.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •