Results 1 to 4 of 4

Thread: Changes of modfiles don't work ingame

  1. #1

    Default Changes of modfiles don't work ingame

    Hi,

    I got the problem, that I change something at the mod data but the changes don't show up ingame.

    For example:

    I'm playing with Darthmod 8.0.1. I wanted to remove rank fire for most units while just leaving it for some elite units. So I opened units_to_units_abillities_junctions_tables from "DME_darthmod.pack" with DB Editor and removed several rows with "rank_fire". Then I saved the file and started the game. But with my savegame as well as a new started game all units still could fire by rank.

    If for example I change unit stats, again nothing changes ingame.

    Does anybody know what I'm doing wrong?
    And, are those changes mentioned above generally savegame compatible?

  2. #2
    Bran Mac Born's Avatar Artifex
    Join Date
    Jun 2005
    Location
    Southern California
    Posts
    2,976

    Default Re: Changes of modfiles don't work ingame

    You need to replace it with some other firing drill-do not leave blank.

  3. #3

    Default Re: Changes of modfiles don't work ingame

    Thanks for your reply!

    Alright, I replaced rank_fire with fire_and_advance and after that with platoon_fire_grouped, neither worked. Replacing with fire_volley doesn't work, because all those units already have that drill.

    Any other ideas?

    And what about savegame compatibillity? Didn't try it with a new game, because then I'd have to wait until rank fire was researched.

    In general, I'm wondering why I can't simply change files and see the effects ingame as in all the other total war games including Rome II (no experience with Shogun though)?

    edit: Ok, just found out that everything is savegame compatible. I also found out that when I replaced rank_fire with platoon_fire_grouped, as long as rank fire isn't researched yet they fire platoon style instead of volley fire. But as soon as rank fire is researched, they fire by rank again. Weird?
    Last edited by Danny087; December 06, 2014 at 10:58 AM.

  4. #4

    Default Re: Changes of modfiles don't work ingame

    Alright got the solution. I had to delete the rank_fire rows in unit_to_unit_abillities_junctions_tables for every unit I wished to disable it for. AND I had to delete the rank_fire rows in unit_class_to_unit_abillities_junctions for every unit class (for example elite, grenadiers, etc.) that includes units I wanted to disable rank fire for. In fact I just deleted it for every unit class.

    Then it worked!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •