Page 1 of 4 1234 LastLast
Results 1 to 20 of 62

Thread: Problems getting the mod installed or running? Try these things before posting! Updated 6th of March 2017

  1. #1

    Default Problems getting the mod installed or running? Try these things before posting! Updated 6th of March 2017

    Here there will be collected the most common problems people have with getting the mod up and running. When new solutions are discovered, I will update the post. Please post here only about new solutions which I have failed to update, or errors in what is written.

    Create a new thread, if these doesn't cover your problem.

    ----------------
    NEW! Mod(s) crashing often

    Spoiler Alert, click show to read: 

    It's common users encounter technical issues while using old software like M2TW - it's only designed to address 2GB of RAM regardless of the users actual hardware capabilities - and that limitation can cause stability problems with large mods like EB2.


    There are 3rd party utilities which can address this problem, but there might be legal ramifications and any software modification is potentially problematic, so users should do their own research and make their own independent decisions. Note, it's strongly encouraged that users do their own research!


    ----------------

    The download speed is abysmal!
    Spoiler Alert, click show to read: 
    Adorable panda, if you try a direct download, you will be competing for the server's attention with everyone else trying to get it at the same time. Right after a release, that means the world and their pets, so you'll have a hard time getting that attention. It is much better to download by TORRENT, as then everyone downloading the mod will cooperate in getting the mod downloaded instead of competing.

    You will need a torrent client. There are a zillion good ones out there, and it's only to take your pick. uTorrent, BitComet, Shareaza, Google search results...


    ----------------

    I am running the installer exe, and it asks for some sort of disc!
    Spoiler Alert, click show to read: 
    Wonderful tiger, you forgot a step in the installation instructions. You need to extract the installer from the zip file you downloaded. There are several ways to accomplish this:

    1. Right-click the EBII.zip and choose "Extract all". Click your way through the wizard, no changes should be necessary while doing so.

    2. Enter the EBII.zip. Select all the files and choose Edit => Copy. Step back out of the zip file and choose Edit => Paste.

    Then, run EBII.exe. It should work a lot better now.


    ----------------

    I installed the mod, but now I got two EB shortcuts on my desktop. What should I do?
    Spoiler Alert, click show to read: 
    Splendid fox, you need to figure out whether your M2TW version is purchased from Steam or not.

    If your copy of M2TW is of the steaming sort, you need to run the shortcut named "Europa Barbarorum II (for Steam users - using launcher)". If your copy is not purchased from Steam, but another vendor such as Gamersgate, Amazon, a physical game store or anywhere else in the world, you need to run the shortcut named "Europa Barbarorum II (for disc installs)".

    You can safely delete the shortcut that does not correspond to your M2TW version. Confusion averted! Away!


    ----------------

    When I run the Steam shortcut on my Steam M2TW, I get an error that it cannot find medieval2.exe!
    Spoiler Alert, click show to read: 
    Energetic koala, before running EB2, you need to have started the vanilla M2TW at least once. We're flattered that you didn't care to try the base game and just wanted to play our mod, of course. But do so, then try again.


    ----------------

    When I run the Steam shortcut on my Steam M2TW, I get an error about CA_LIBS, or it otherwise doesn't run. Other mods are installed.
    Spoiler Alert, click show to read: 
    Fervent grasshopper, you may have a conflicting configuration in Steam.

    1) Right click on Medieval 2 Total War from the Steam Game Library and select Properties.
    2) Click on “SET LAUNCH OPTIONS…”
    3) If you see something like "--features.mod=mods/name_of_the_mod_folder" in there, delete it.

    Then try to run EB2 again.


    ----------------

    I have tried the files in the items above, and am still not getting the game to run.
    Spoiler Alert, click show to read: 
    Stalwart gecko, there is a good chance that you have M2TW installed under Program Files. Yes? This can lead to several different and weird ways of misbehaviour from the game. There are ways to alleviate this. Use option 1 if it works for you.

    1.
    Add more permissions to the M2TW folder. Refer to this thread, search for "3)" on the page to find instructions with screenshots.

    2.
    Uninstall EB2.
    Uninstall M2TW.
    Reinstall M2TW somewhere outside of Program Files, for instance C:\M2TW, or C:\Games\M2TW.
    Reinstall EB2.


    ----------------

    Actually, the game runs. But it crashes pretty often, every 10 turns or so.
    Spoiler Alert, click show to read: 
    Magnificent walrus, are you running the game in fullscreen mode? This appears to be a lot less stable than running it windowed - particularly if you alt-tab out of the game. Run it windowed and it will probably work better for you!


    ----------------

    I get no sounds! (but I get up again)
    Spoiler Alert, click show to read: 
    Contemplative salamander, there is a good chance that you have M2TW installed under Program Files. Yes? This can lead to several different and weird ways of misbehaviour from the game. There are ways to alleviate this. Use option 1 if it works for you.

    1.
    Add more permissions to the M2TW folder. Refer to this thread, search for "3)" on the page to find instructions with screenshots.

    2.
    Uninstall EB2.
    Uninstall M2TW.
    Reinstall M2TW somewhere outside of Program Files, for instance C:\M2TW, or C:\Games\M2TW.
    Reinstall EB2.


    Solutions which are hopefully obsolete by 2.01:
    Spoiler Alert, click show to read: 
    When I run the non-Steam shortcut on my non-Steam M2TW, it fails to run and I get an error saying M2TW has encountered an error and needs to close.
    When I run the non-Steam shortcut on my non-Steam M2TW, fails to run and I get an error saying something about permission denied.
    Spoiler Alert, click show to read: 
    Masterful dromedary, unfortunately a small number of users get this error. It is usually fixed by getting this file.

    Extract it into M2TW\mods\EBII, where M2TW means the path where your Medieval 2 game is installed. Then try to run the game again.


    ----------------

    When I run the game all or most of the texts are wonky, like "STRAT.TXT:{SMT_CAPITAL_TITLE}".
    When I run the game, it fails to run and I get an error saying "shared.txt:{GERR_GENERIC}".
    Spoiler Alert, click show to read: 
    Brilliant badger, unfortunately a significant number of users get these errors. It is usually fixed by getting this file.

    Extract it into M2TW\mods\EBII\data, where M2TW means the path where your Medieval 2 game is installed. Then try to run the game again.

    If that didn't work, you can try once again. For a few people, it works the second time around.

    -----------

    If it still doesn't work, there is another thing you can try short of starting over and reinstalling the whole thing. You need java installed, and you need to have done the permissions step (found under "I have tried the files in the items above, and am still not getting the game to run.") first.

    * Go to M2TW/documentation/tools, and open build_scripts.ini.
    * Update it with the location where you have java installed.
    * Go to M2TW/documentation/tools/cuf, and run build_strings_bin.wsf. It should run for at least 20 seconds.

    Then try again. This step can also be repeated if necessary.


    Last edited by z3n; March 06, 2017 at 12:08 PM. Reason: Important update about crashes

    Having problems getting EB2 to run? Try these solutions.
    ================
    I do NOT answer PM requests for help with EB. Ask in a new help thread in the tech help forum.
    ================
    I think computer viruses should count as life. I think it says something about human nature that the only form of life we have created so far is purely destructive. We've created life in our own image. - Stephen Hawking

  2. #2

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    If you use the mod launcher for M2:TW which comes for example with EBII if you are a Steam-User.

    Rename the d3d9.dll to d3d9.dllx before starting the launcher. GEM is also applied to the launcher somehow. Forgot to mention that. Before starting the game from the launcher, rename the d3d9.dllx again to d3d9.dll. Fix for GEM users also

  3. #3

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    @IMZ INFADEL, sorry for not reacting earlier. What is the symptom displayed when the solution you posted will work?

    Having problems getting EB2 to run? Try these solutions.
    ================
    I do NOT answer PM requests for help with EB. Ask in a new help thread in the tech help forum.
    ================
    I think computer viruses should count as life. I think it says something about human nature that the only form of life we have created so far is purely destructive. We've created life in our own image. - Stephen Hawking

  4. #4
    ger217's Avatar Libertus
    Join Date
    Feb 2013
    Location
    Michigan, USA
    Posts
    74

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    Setting changes every time a load a game. The video and audio settings never stay the same. Please help!

  5. #5

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    2.0 or 2.01?

    Having problems getting EB2 to run? Try these solutions.
    ================
    I do NOT answer PM requests for help with EB. Ask in a new help thread in the tech help forum.
    ================
    I think computer viruses should count as life. I think it says something about human nature that the only form of life we have created so far is purely destructive. We've created life in our own image. - Stephen Hawking

  6. #6
    ger217's Avatar Libertus
    Join Date
    Feb 2013
    Location
    Michigan, USA
    Posts
    74

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    Quote Originally Posted by bovi View Post
    2.0 or 2.01?
    2.01


    Thaxs bovi, I got it working now.
    Last edited by ger217; September 13, 2014 at 07:59 AM.

  7. #7
    Darkan's Avatar Senator
    Join Date
    Nov 2007
    Location
    Searching...
    Posts
    1,332

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    Version 2.01 - Non Steam
    Tried loading kingdoms and it didn't, tried loading EB after that and it just stood there. In the end I alt tabbed and got the "not responding" message.
    Loaded Britannia successfully, started new campaign, quit, loaded EB, after about 3-5 minutes it loaded fine. Maybe update the "When I run the Steam shortcut on my Steam M2TW, I get an error that it cannot find medieval2.exe! " to say load the kingdoms campaign installed.

    Also, I loaded Britannia from the Launcher.

    Oh, in the resolution section of the options I have both Campaign and Battle option 0X0, as well as the others.
    [DLV 6.2 AAR] - The Danish House of Hen - updated 20/08/18 - on hold
    [King of Dragon Pass AAR] - The Drakkar Saga - updated 14/04/18 - on hold
    Participate in the TotW!!! PARTICIPATE!!!
    DuckDuckGo

  8. #8

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    With the text fix incorporated, the first time you run the mod can take a couple more minutes. Could explain what you perceived to be "standing there".

    Having problems getting EB2 to run? Try these solutions.
    ================
    I do NOT answer PM requests for help with EB. Ask in a new help thread in the tech help forum.
    ================
    I think computer viruses should count as life. I think it says something about human nature that the only form of life we have created so far is purely destructive. We've created life in our own image. - Stephen Hawking

  9. #9
    ipwnu678's Avatar Semisalis
    Join Date
    Jul 2012
    Location
    England
    Posts
    411

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    i try to start a campaign and this happens
    20:39:00.446 [system.io] [info] exists: missing mods/EBII/preferences/player.txt
    Last edited by ipwnu678; September 22, 2014 at 02:41 PM.

  10. #10
    Laetus
    Join Date
    Jul 2013
    Location
    Nederland
    Posts
    22

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    I installed the mod and it runs fine, but only if I use the Kingdoms launcher and not when using the newly added shortcuts from EB II itself. Given that it runs fine, I can assume that the data is in the right folder right?

  11. #11

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    Yes.

    Having problems getting EB2 to run? Try these solutions.
    ================
    I do NOT answer PM requests for help with EB. Ask in a new help thread in the tech help forum.
    ================
    I think computer viruses should count as life. I think it says something about human nature that the only form of life we have created so far is purely destructive. We've created life in our own image. - Stephen Hawking

  12. #12

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    I am a Windows Vista user and have had the same problem as outlined in the spoiler below. When I apply the advised remedy of overwritting the EBII.cfg and launch.bat files the bat file flashes up for all of a split second then nothing happens. Any ideas anybody?



    Quote Originally Posted by bovi View Post

    Solutions which are hopefully obsolete by 2.01:
    [SPOILER]When I run the non-Steam shortcut on my non-Steam M2TW, it fails to run and I get an error saying M2TW has encountered an error and needs to close.
    When I run the non-Steam shortcut on my non-Steam M2TW, fails to run and I get an error saying something about permission denied.
    Spoiler Alert, click show to read: 
    Masterful dromedary, unfortunately a small number of users get this error. It is usually fixed by getting this file.

    Extract it into M2TW\mods\EBII, where M2TW means the path where your Medieval 2 game is installed. Then try to run the game again.


  13. #13

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    That remedy is no longer advised for 2.01 (note the obsolete warning at the top of the quoted piece). It shouldn't do any damage, but it won't make any positive difference either.

    You could try to run the cine-edit bat file which is alongside launch.bat. Note that this will overwrite the EBII cfg file, so make a backup first. Or run it through the launcher, that might work too (but you'll suffer from the launcher music not stopping when until it's done).

    Having problems getting EB2 to run? Try these solutions.
    ================
    I do NOT answer PM requests for help with EB. Ask in a new help thread in the tech help forum.
    ================
    I think computer viruses should count as life. I think it says something about human nature that the only form of life we have created so far is purely destructive. We've created life in our own image. - Stephen Hawking

  14. #14

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    Quote Originally Posted by bovi View Post
    That remedy is no longer advised for 2.01 (note the obsolete warning at the top of the quoted piece). It shouldn't do any damage, but it won't make any positive difference either.

    You could try to run the cine-edit bat file which is alongside launch.bat. Note that this will overwrite the EBII cfg file, so make a backup first. Or run it through the launcher, that might work too (but you'll suffer from the launcher music not stopping when until it's done).
    No need to get snarky chief, the obsolescence warning read like a "what if" so that's why I asked the question in the first place. Simply a lack of good articulation on the part of the person who posted the obsolescence warning lead to my misunderstanding.

    I tried the first thing you said with the cine-edit batch file - the game doesn't start to load and it comes up with an error message (see attachment)

    I also used the Launcher and that just causes my original problem again.

    Does the original Vanilla version have to be patched to 1.3 or 1.5 or should it just be a clean Vanilla?
    Attached Thumbnails Attached Thumbnails 001.jpg  

  15. #15

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    I did not mean to be snarky, but if pointing out already available information in a sticky is being snarky, I guess I am snarky again, unlike everyone else who is polite enough to not help.

    Having problems getting EB2 to run? Try these solutions.
    ================
    I do NOT answer PM requests for help with EB. Ask in a new help thread in the tech help forum.
    ================
    I think computer viruses should count as life. I think it says something about human nature that the only form of life we have created so far is purely destructive. We've created life in our own image. - Stephen Hawking

  16. #16

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    Hi, Id tried to install EBII in my Medieval 2 no stream version, and when I execute Europa Barbarorum II (for non-Steam installs), I get the message "Medieval 2: Total War encountered an unespecified error and will now exit", I have installed it outside Program Files and I tried EBII_launch-fix
    Any solution, please?

  17. #17

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    Patched the main game to 1.05? Ran a Kingdoms campaign before running EBII?

    Having problems getting EB2 to run? Try these solutions.
    ================
    I do NOT answer PM requests for help with EB. Ask in a new help thread in the tech help forum.
    ================
    I think computer viruses should count as life. I think it says something about human nature that the only form of life we have created so far is purely destructive. We've created life in our own image. - Stephen Hawking

  18. #18

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    Quote Originally Posted by albertomv View Post
    Hi, Id tried to install EBII in my Medieval 2 no stream version, and when I execute Europa Barbarorum II (for non-Steam installs), I get the message "Medieval 2: Total War encountered an unespecified error and will now exit", I have installed it outside Program Files and I tried EBII_launch-fix
    Any solution, please?
    Im having this same problem. I also installed outside Program files and tried EBII_launch fix. I patched the game to 1.5 and ran a kingdoms campaign before EBII.

    Any clue how to get this fixed?

  19. #19

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    Hi i had EB2 1.0 in my Medieval 2 folder and it worked just fine. i unistaled it and installed the latest version but now i get "Medieval 2: Total War encountered an unespecified error and will now exit" after some time in the "lauching box"

  20. #20

    Default Re: Problems getting the mod installed or running? Try these things before posting!

    I hope this is the right thread to post my problem. I constantly getting error massage on installing this mod. First i downloaded the torent file, and the error massage was on the eb saka earky noble textures. So after few tries i downloaded EB from new link, and now i get error on the very beginning, the files se_walls_small stone texture... I tried retry option over and over again, but no success.
    I newer played this mod before, and i am hopping i will make this to work. If you have some ideas or anyone had the same problem, i would appreciate some help with this.

    Thank you in advance

    edit:
    tried it on my other PC but the error with texture still remains, now downloading link from Mod Db.
    And just to make sure my files size goes 197mb for 1a file, 200mb for the rest, then for 1o is 28.6 mb and EBII is 2.54 mb
    Last edited by bojan811; October 27, 2014 at 08:44 AM.

Page 1 of 4 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •