Thread: Bugs Reports & Technical Help

  1. #2681
    Lifthrasir's Avatar A Clockwork Orange
    Patrician Artifex Moderation Mentor Content Emeritus

    Join Date
    Jan 2010
    Location
    Dunkirk - France
    Posts
    13,178
    Blog Entries
    4

    Default Re: Bugs Reports & Technical Help

    No, sorry Mate. These 2 last weeks have been very busy for me in RL.
    Under the patronage of Flinn, proud patron of Jadli, of the Imperial House of Hader


    - Results published

  2. #2682
    Antonius's Avatar Decanus
    Join Date
    Jun 2007
    Location
    Europe - Britain, Austria, Italy, Belgium....
    Posts
    514

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by Lifthrasir View Post
    No, sorry Mate. These 2 last weeks have been very busy for me in RL.
    I worries. Don't you hate it when real life interferes with gaming?
    It is always easier to fight for one’s principles than to live up to them.
    ~Alfred Adler

  3. #2683
    Lifthrasir's Avatar A Clockwork Orange
    Patrician Artifex Moderation Mentor Content Emeritus

    Join Date
    Jan 2010
    Location
    Dunkirk - France
    Posts
    13,178
    Blog Entries
    4

    Default Re: Bugs Reports & Technical Help

    Oh man, you have no idea
    Under the patronage of Flinn, proud patron of Jadli, of the Imperial House of Hader


    - Results published

  4. #2684
    Lethal Jakkson's Avatar Civis
    Join Date
    Apr 2008
    Location
    Somerset, England
    Posts
    140

    Default Re: Bugs Reports & Technical Help

    Hi there finally got round to reporting back on instalment issue, its about the d/l links, once d/l complet and all files put into the SSHIP fold, as I had to d/l one of the .vlc files sepratly as it would not be inclued in main fold how ever many ways i tried, on installing it asked for disk 2 so i sorted that out but some how apart of the install still ended up creating a Saga file and installing there, after 2 or 3 weeks away from that endless circle Im starting over again now will see if the same thing happens again, andy clues or ideas why and how to stop this from happening? I tried alot of difrent ways around it
    Working for myself for 3years and still finding time to play Total War

    "power down now. Have your crew step out or we will kill you!" -
    Conl Sharp (Transformers)
    "wh
    at you talkin 'bout willis?"
    -Gary Coleman aka Arnold Jackson (Diff'rent Strokes)

  5. #2685
    kostic's Avatar Biarchus
    Join Date
    Jan 2007
    Location
    Near Lyon in France
    Posts
    662

    Default Re: Bugs Reports & Technical Help

    @Letahl Jakkson : I admit that I do not quite understand what you write. Google translation does not help me more ...
    Do you have trouble installing SSHIP only or are you stuck installing Medieval II total War Kingdoms (ver 1.05) ???

  6. #2686
    Lifthrasir's Avatar A Clockwork Orange
    Patrician Artifex Moderation Mentor Content Emeritus

    Join Date
    Jan 2010
    Location
    Dunkirk - France
    Posts
    13,178
    Blog Entries
    4

    Default Re: Bugs Reports & Technical Help

    @ Lethal Jakkson, you're obviously trying to install the v0.9.2. and v0.9.5 (from this post). That's actually the previous version of the od, only left for people who want to use one of the Mini-mods.

    If you want to use the last version, v0.9.6, you need to refer to the 1st post only.

    Let me know which version you want to install and I'll do my best to guide you.
    Under the patronage of Flinn, proud patron of Jadli, of the Imperial House of Hader


    - Results published

  7. #2687
    VineFynn's Avatar Miles
    Join Date
    Feb 2012
    Location
    Victoria, Australia
    Posts
    337

    Default Re: Bugs Reports & Technical Help

    Please keep in mind that changes to the campaign script file require a new game to take effect, and existing saves may be incompatible with the newer version.
    Real life is balanced.

  8. #2688
    kostic's Avatar Biarchus
    Join Date
    Jan 2007
    Location
    Near Lyon in France
    Posts
    662

    Icon4 Re: Bugs Reports & Technical Help

    I tested all factions to find out which ones have no voice, neither campaign card characters, nor units on the battlefield.

    This experiment is done with a non-Steam and non-English version. (I tested 2 versions 0.9.6 with 2 different computers).
    I hope there will be a patch soon. I don't want to spend time modifying an incomplete version.

    Voiceless factions:

    Scotland
    Denmark
    Poland
    Norway
    Hungary
    Serbia
    Lithuania
    Novgorod
    Kiev
    Cuman

  9. #2689
    Lifthrasir's Avatar A Clockwork Orange
    Patrician Artifex Moderation Mentor Content Emeritus

    Join Date
    Jan 2010
    Location
    Dunkirk - France
    Posts
    13,178
    Blog Entries
    4

    Default Re: Bugs Reports & Technical Help

    Thanks Mate
    Can you tell me if you have any missing voices or sounds with SS6.4 alone? Thanks in advance.
    Under the patronage of Flinn, proud patron of Jadli, of the Imperial House of Hader


    - Results published

  10. #2690
    kostic's Avatar Biarchus
    Join Date
    Jan 2007
    Location
    Near Lyon in France
    Posts
    662

    Default Re: Bugs Reports & Technical Help

    Yes, voices are also missing in SS6.4. With SSHIP 0.9.2 and SSHIP 0.9.5 + the sound patch the voices come back.

  11. #2691
    Lifthrasir's Avatar A Clockwork Orange
    Patrician Artifex Moderation Mentor Content Emeritus

    Join Date
    Jan 2010
    Location
    Dunkirk - France
    Posts
    13,178
    Blog Entries
    4

    Default Re: Bugs Reports & Technical Help

    I think I start to see where the problem comes from. What is the sound patch you're referring to?
    Under the patronage of Flinn, proud patron of Jadli, of the Imperial House of Hader


    - Results published

  12. #2692
    kostic's Avatar Biarchus
    Join Date
    Jan 2007
    Location
    Near Lyon in France
    Posts
    662

    Default Re: Bugs Reports & Technical Help

    I think this is the patch proposed for the installation of version 0.9.5:

    DOWNLOAD SOUNDFIX - only for non-English players
    SoundFix

    In my archives, I use a patch (from your version 0.9.2) called SSHIP Sound Fix 0.8
    I guess it's the same.

  13. #2693
    Lifthrasir's Avatar A Clockwork Orange
    Patrician Artifex Moderation Mentor Content Emeritus

    Join Date
    Jan 2010
    Location
    Dunkirk - France
    Posts
    13,178
    Blog Entries
    4

    Default Re: Bugs Reports & Technical Help

    The download link is empty, I mean, the file is gone
    Under the patronage of Flinn, proud patron of Jadli, of the Imperial House of Hader


    - Results published

  14. #2694
    Foederatus
    Join Date
    Aug 2009
    Location
    Karantanija
    Posts
    26

    Default Re: Bugs Reports & Technical Help

    Playing as HRE I'm currently having a crash on turn 128/129, after Poland finishes its turn and just before Byzantiums turn. Thats with patch 10_1_2020 and with updated 14_1_2020. System log says this:

    11:57:16.506 [script.err] [error] Script Error in mods/SS6.3/data/export_descr_ancillaries.txt, at line 6458, column 11
    Could'n find ancillary name string <idearmad_tripoli>.
    11:57:16.506 [script.err] [error] Script Error in mods/SS6.3/data/export_descr_ancillaries.txt, at line 6462, column 14
    Could'n find ancillary description string <idearmad_tripoli_desc>.
    11:57:16.506 [script.err] [error] Script Error in mods/SS6.3/data/export_descr_ancillaries.txt, at line 6463, column 21
    Could'n find ancillary effect description string <idearmad_tripoli_effects_desc>.
    11:57:25.878 [game.script] [always] Germanicu5 ReallyBadAI v5.7 Running. Please upload log and savegames when reporting battle CTDs for SS.
    11:58:09.452 [system.rpt] [error] Medieval 2: Total War encountered an unspecified error and will now exit.

  15. #2695
    Jurand of Cracow's Avatar History and gameplay!
    Join Date
    Oct 2012
    Location
    Cracovia
    Posts
    3,950

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by Prugalo View Post
    Playing as HRE I'm currently having a crash on turn 128/129, after Poland finishes its turn and just before Byzantiums turn. Thats with patch 10_1_2020 and with updated 14_1_2020. System log says this:

    11:57:16.506 [script.err] [error] Script Error in mods/SS6.3/data/export_descr_ancillaries.txt, at line 6458, column 11
    Could'n find ancillary name string <idearmad_tripoli>.
    11:57:16.506 [script.err] [error] Script Error in mods/SS6.3/data/export_descr_ancillaries.txt, at line 6462, column 14
    Could'n find ancillary description string <idearmad_tripoli_desc>.
    11:57:16.506 [script.err] [error] Script Error in mods/SS6.3/data/export_descr_ancillaries.txt, at line 6463, column 21
    Could'n find ancillary effect description string <idearmad_tripoli_effects_desc>.
    11:57:25.878 [game.script] [always] Germanicu5 ReallyBadAI v5.7 Running. Please upload log and savegames when reporting battle CTDs for SS.
    11:58:09.452 [system.rpt] [error] Medieval 2: Total War encountered an unspecified error and will now exit.
    Given that the RBAI is loaded after the problems with "idearmad_tripoli", I'm not sure if this is a problem. However, just to check it, try this:
    go to in the folder "data/text" and delete all files with extension "bin".
    Run the game and check if it works.

    Besides, check if you've got in the config file
    ""level = * trace"
    (you may have "level = * error" - then change to trace - more info will be visible)
    Last edited by Jurand of Cracow; January 15, 2020 at 05:30 AM.

  16. #2696
    Foederatus
    Join Date
    Aug 2009
    Location
    Karantanija
    Posts
    26

    Default Re: Bugs Reports & Technical Help

    Removed all bin files from text folder and sadly it didn't help, still crashing at Polands turn. Tried level trace in config and the log is more detailed, but can't really find anything wrong. Last few lines mention teutonic historic event, could it be a problem with me installing 0.96 over 0.95? Last couple of lines:

    13:07:09.230 [game.script.anc] [trace] Ancillary <architect> not added - chance 3, random 82
    13:07:09.230 [game.script.trigger] [trace] Trigger <Global_Settlement_Building_Completed> fired
    13:07:09.230 [game.script.trigger] [trace] Trigger <Masons_Building_Completed> fired
    13:07:09.231 [game.script.exec] [trace] exec <historic_event> at line 10316 in mods/SS6.3/data/world/maps/campaign/imperial_campaign/campaign_script.txt
    13:07:09.231 [system.io] [info] exists: found mods/SS6.3/data/ui/northern_european/eventpics/teutonic_order.tga (from: F:\Igre\Medieval II Total War Collection)
    13:07:09.231 [system.io] [info] exists: missing mods/SS6.3/data/ui/northern_european/eventpics/teutonic_order.tga.dds
    13:07:09.231 [system.io] [info] exists: found mods/SS6.3/data/ui/northern_european/eventpics/teutonic_order.tga (from: F:\Igre\Medieval II Total War Collection)
    13:07:09.247 [system.rpt] [error] Uh oh. This isn't good. No idea why, but exiting now. Sorry pal.

  17. #2697
    Jurand of Cracow's Avatar History and gameplay!
    Join Date
    Oct 2012
    Location
    Cracovia
    Posts
    3,950

    Default Re: Bugs Reports & Technical Help

    As far as I know, installing 096 over 095 is a bad idea. Lifth probably knows it (he compiled the version), but I'd expect crashes. And this is a miracle that you've managed till turn 128, I'd say.

  18. #2698
    Lifthrasir's Avatar A Clockwork Orange
    Patrician Artifex Moderation Mentor Content Emeritus

    Join Date
    Jan 2010
    Location
    Dunkirk - France
    Posts
    13,178
    Blog Entries
    4

    Default Re: Bugs Reports & Technical Help

    Actually, it shouldn't be a problem to install v0.9.6 over v0.9.5. However, it's better to be safe than sorry. Hence my recon about doing a clean install.

    @ Prugalo, have you installed the patch as well? If not, that could be the reason of the ctd.
    Under the patronage of Flinn, proud patron of Jadli, of the Imperial House of Hader


    - Results published

  19. #2699
    Foederatus
    Join Date
    Aug 2009
    Location
    Karantanija
    Posts
    26

    Default Re: Bugs Reports & Technical Help

    Yes its installed with latest patches. Funny thing is, this is actually my third playthrough this last month (all were good so far, played for roughly 300 turns), and my first SSHIP ctd in years. Doesn't matter, will make a fresh install and start my fourth playthrough Thanx for all your help guys.

  20. #2700
    Gigantus's Avatar I am thinking more about running away now then I did as a kid, but by the time I put my teeth in, my glasses on and find my car keys I forget why I am going.
    Moderator Emeritus Administrator Emeritus Modding Emeritus

    Join Date
    Aug 2006
    Location
    Goa - India
    Posts
    48,609
    Blog Entries
    23

    Default Re: Bugs Reports & Technical Help

    Fix for "No voices in non english game"

    Simply open \[mod folder]\data\descr_sounds_accents.txt and move the 'mute' factions into a fitting, working accent slot then save the file. See example below.
    Then delete the \[mod folder]\data\sounds\events.DAT and IDX file and start your mod.

    Code:
    accent English
        factions england, normans, saxons, scotland
    
    accent Scottish
        factions scotland
    Last edited by Gigantus; January 16, 2020 at 03:42 AM.




Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •