Thread: Bugs Reports & Technical Help

  1. #3781
    Gigantus's Avatar I am thinking more about running away now then I did as a kid, but by the time I put my teeth in, my glasses on and find my car keys I forget why I am going.
    Moderator Emeritus Administrator Emeritus Modding Emeritus

    Join Date
    Aug 2006
    Location
    Goa - India
    Posts
    49,451
    Blog Entries
    26

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by kaiser29 View Post
    No, but restarting a campaign from scratch worked fine! Now i'm playing with 0.97 + Patch F + KCC + edited modeldb file + Windows 7 compatibility mode and... it works like a charm! no more CTDs! For the moment lol. I managed to play 20+ turns without one

    Only downside are the longer turns, but i can live with that (for the moment i takes just 1-2 minutes)
    I suppose eventually it was some kind of save incompatibility if it works now. Enjoy the mod!




  2. #3782

    Default Re: Bugs Reports & Technical Help

    Hi there, I really hope someone can help me, as I have used up all my options except to ask here.

    SSHIP does not work. Everytime I try to open the game, "unscepcified error" occurs and the game shuts down before I could even see a loading screen. It is worth to mention that I checked both vanilla M2TW and basic Stainless Steel 6.4 and both work well. Only after SSHIP installation the game does not work. I have Steam version of M2TW, installed with English language in a separate Steam library on another drive. Im operating on Win10. I followed all instructions on both creating a separate Steam library and installing the mod, having 6.3 installed, then patched to 6.4 and merging SSHIP data folder with SS data folder. I have set file compatibility to Windows 7, tried also with Vista and XP. All the time I tried starting the game as administrator. I have checked every corner of internet and could not find a solution. It is worth to mention, that it is the first time such a thing happens to me. I played SSHIP before on my PC couple of months ago, but I have decided to try out Titanium submod. Now I have decided to return to SSHIP, I have reinstalled M2TW and tried installing the mod multiple times on clean vanilla, nothing helps.

  3. #3783

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by Gen_Poniatowski View Post
    Hi there, I really hope someone can help me, as I have used up all my options except to ask here.

    SSHIP does not work. Everytime I try to open the game, "unscepcified error" occurs and the game shuts down before I could even see a loading screen. It is worth to mention that I checked both vanilla M2TW and basic Stainless Steel 6.4 and both work well. Only after SSHIP installation the game does not work. I have Steam version of M2TW, installed with English language in a separate Steam library on another drive. Im operating on Win10. I followed all instructions on both creating a separate Steam library and installing the mod, having 6.3 installed, then patched to 6.4 and merging SSHIP data folder with SS data folder. I have set file compatibility to Windows 7, tried also with Vista and XP. All the time I tried starting the game as administrator. I have checked every corner of internet and could not find a solution. It is worth to mention, that it is the first time such a thing happens to me. I played SSHIP before on my PC couple of months ago, but I have decided to try out Titanium submod. Now I have decided to return to SSHIP, I have reinstalled M2TW and tried installing the mod multiple times on clean vanilla, nothing helps.
    Hey, hope we can make it work! few things:
    - did you run the SS_setup (early campaign and so on) before launching installing SSHIP?
    - did you put the compatibility and admin rights in both medieval2.exe and kingdom.exe properties?
    - can you check in you mod folder properties if it did not get the "read only" attribute? If yes uncheck that.
    - does the log say anything?
    Belovèse's Toolbox: export text files to spreadsheet, detailed unit stats
    Stainless Steel Historical Improvement Project (SSHIP) team member.
    Mini-mods: diplomacy and relation/reputation - detailled unit stats

  4. #3784
    Jurand of Cracow's Avatar History and gameplay!
    Join Date
    Oct 2012
    Location
    Cracovia
    Posts
    4,618

    Default Re: Bugs Reports & Technical Help

    Here you have 5,7 GB installed SS6.4+SSHIP097+KCC. It works for Drtad. Just unpack it into the /mod folder.

  5. #3785

    Default Re: Bugs Reports & Technical Help

    Yes, I run the setup before installing SSHIP. I checked early campaign and savage AI.
    In fact, I had no compatibility and admin rights on kingdom.exe, aswell as "read only" attribute was checked. I have corrected this, but the mod still crashes.
    If I understand correctly, you mean the file that is in SS folder? It says:
    23:18:37.303 [system.rpt] [always] CPU: SSE2
    23:18:37.303 [system.rpt] [always] ==== system log start, build date: Sep 5 2014 version development ===
    23:18:37.307 [system.io] [always] mounted pack packs/data_0.pack
    23:18:37.308 [system.io] [always] mounted pack packs/data_1.pack
    23:18:37.310 [system.io] [always] mounted pack packs/data_2.pack
    23:18:37.311 [system.io] [always] mounted pack packs/data_3.pack
    23:18:37.312 [system.io] [always] mounted pack packs/data_4.pack
    23:18:37.312 [system.io] [always] mounted pack packs/localized.pack
    23:18:42.864 [system.rpt] [error] Medieval 2: Total War encountered an unspecified error and will now exit.

  6. #3786

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by Jurand of Cracow View Post
    Here you have 5,7 GB installed SS6.4+SSHIP097+KCC. It works for Drtad. Just unpack it into the /mod folder.
    Thanks, I will use it if everything else will prove to be uneffective.

  7. #3787

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by Jurand of Cracow View Post
    Here you have 5,7 GB installed SS6.4+SSHIP097+KCC. It works for Drtad. Just unpack it into the /mod folder.
    I have decided to try this out and it works like a charm now. It must have been a problem with installation process. Thanks for help, glad to know that the community is still strong and helpful.

  8. #3788
    Jurand of Cracow's Avatar History and gameplay!
    Join Date
    Oct 2012
    Location
    Cracovia
    Posts
    4,618

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by Gen_Poniatowski View Post
    I have decided to try this out and it works like a charm now. It must have been a problem with installation process. Thanks for help, glad to know that the community is still strong and helpful.
    Community is strong if one contributes - if you play a game, please report on your experience . Poland is an interesting faction to play, you've got the most recent version of the mod, it may be interesting to see what you think

  9. #3789

    Default Re: Bugs Reports & Technical Help

    Wow is that an "all in one" download? Does it even include the patches including patch F? Much easier if so!

  10. #3790
    Jurand of Cracow's Avatar History and gameplay!
    Join Date
    Oct 2012
    Location
    Cracovia
    Posts
    4,618

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by Cleaver428 View Post
    Wow is that an "all in one" download? Does it even include the patches including patch F? Much easier if so!
    all patches, KCC095, and more

  11. #3791

    Default Re: Bugs Reports & Technical Help

    This is much superior to downloading each file individual!

  12. #3792
    Ducenarius
    Join Date
    Mar 2009
    Location
    Hellas
    Posts
    914

    Default Re: Bugs Reports & Technical Help

    Jurand mind uploading the intergrated file to nopy or mediashare since mega is not limitless

    And another thing i have noticed during my play is that due to the fact that most if not all factions get terrible relations become untrustworthy nobody can recruit religious units.i havent seen a single one nor have i recruited one myself during 150 turns with france






  13. #3793

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by Jurand of Cracow View Post
    Community is strong if one contributes - if you play a game, please report on your experience . Poland is an interesting faction to play, you've got the most recent version of the mod, it may be interesting to see what you think
    Thanks, I'll certainly share my experience after couple of dozens of turns. I can see that a lot has changed since I played it last time. For now I'm playing as Scotland to experience rebuilding a poor country into a strong economy and modernising my poor quality units into a proper western army. And I'll check Poland later aswell as I can see that really a lot has changed.

  14. #3794
    Jurand of Cracow's Avatar History and gameplay!
    Join Date
    Oct 2012
    Location
    Cracovia
    Posts
    4,618

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by Gen_Poniatowski View Post
    Thanks, I'll certainly share my experience after couple of dozens of turns. I can see that a lot has changed since I played it last time. For now I'm playing as Scotland to experience rebuilding a poor country into a strong economy and modernising my poor quality units into a proper western army. And I'll check Poland later aswell as I can see that really a lot has changed.
    Well, Scotland should be one of the weakest factions so it's not the best choice for a start, I think. I doubt we've made recently any effort to give it a new look or new events, so it should be like before.

  15. #3795

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by Jurand of Cracow View Post
    Here you have 5,7 GB installed SS6.4+SSHIP097+KCC. It works for Drtad. Just unpack it into the /mod folder.
    it appears that in some countries mega.nz has a limit of 5 GB per day, so i cannot download it

  16. #3796

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by kaiser29 View Post
    it appears that in some countries mega.nz has a limit of 5 GB per day, so i cannot download it

    Mine is less than 2GB sometimes, but I downloaded the MEGAsync client and it lets me close the browser and the download continues minimized, then, when it reaches the limit, it takes like 6 hours to download another 2GB, but it does it all automatically, so I queue stuff and just use the pc, then after a day or two I got all the files downloaded.

  17. #3797

    Default Re: Bugs Reports & Technical Help

    I recently got a new computer so I am restarting the process of installing SSHIP, however, I am running into problems with SS6.4. I keep getting the 'unable to find kingdoms.exe' when installing SS6.4. The issue is that I've already copied medieval2exe and renamed it kingdoms. This worked for SS6.3 but is no longer working for SS6.4. Have any of you all run into this issue before.

  18. #3798

    Default Re: Bugs Reports & Technical Help

    I'm having no problems with random CTD's, but after several attempts and re-installs and campaign re-starts I always get to a point and begin crashing out due to these:


    when testing <IsFactionLeader> condition
    14:47:28.606 [game.script] [error] Trigger processing error in <BrotherAdopted_Money>
    : IsFactionLeader needs a living character.


    when testing <IsFactionLeader> condition
    14:47:28.606 [game.script] [error] Trigger processing error in <BrotherAdopted_Loyalty>
    : IsFactionLeader needs a living character.


    I've tried reinstalling from scratch all the way back to 6.3 clean and a few other things. I've done some slight modifications to the EDU,EDB,STRAT, and the campaign events file. I've gotten as far as the 1220's, and also not made it past a dozen turns sometimes.

    I'm guessing if any of the changes I have made it would be in the events file.

    Currently downloading the 5,7 GB installed SS6.4+SSHIP097+KCC.

  19. #3799

    Default Re: Bugs Reports & Technical Help

    Quote Originally Posted by george0433 View Post
    I'm having no problems with random CTD's, but after several attempts and re-installs and campaign re-starts I always get to a point and begin crashing out due to these:


    when testing <IsFactionLeader> condition
    14:47:28.606 [game.script] [error] Trigger processing error in <BrotherAdopted_Money>
    : IsFactionLeader needs a living character.


    when testing <IsFactionLeader> condition
    14:47:28.606 [game.script] [error] Trigger processing error in <BrotherAdopted_Loyalty>
    : IsFactionLeader needs a living character.
    The "isfactionleader needs living character" is a know problem, and we will work later on solutions to avoid relying on this trigger. Bit according to gigantus it should not always be fatal, so I wouldn't rule out your own changes as the ctd source.
    Belovèse's Toolbox: export text files to spreadsheet, detailed unit stats
    Stainless Steel Historical Improvement Project (SSHIP) team member.
    Mini-mods: diplomacy and relation/reputation - detailled unit stats

  20. #3800
    Jurand of Cracow's Avatar History and gameplay!
    Join Date
    Oct 2012
    Location
    Cracovia
    Posts
    4,618

    Default Re: Bugs Reports & Technical Help

    Two brother adopted errors don't cause the game to crash.

    Quote Originally Posted by george0433 View Post
    I've done some slight modifications to the EDU,EDB,STRAT, and the campaign events file. I've gotten as far as the 1220's, and also not made it past a dozen turns sometimes.
    I'm guessing if any of the changes I have made it would be in the events file.
    In my experience, it's very, very easy to make a small error that at some point ends with a crash. Especially with the events file, EDB is safer, and EDU/strat are pretty safe if you've managed to go a few turns.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •