Results 1 to 3 of 3

Thread: [MOST RECENT OF OLD LAUNCHER] Ottoman turn bug

  1. #1

    Default [MOST RECENT OF OLD LAUNCHER] Ottoman turn bug

    Hey guys

    Searched the forums before and the only thread I could find said it was solved in 6.3
    Well I'm playing 8.0 Beta with Casus Belli and Sokh hates sieges. Ten turns into the game, it gets stuck during an ottoman turn. I'm playing as France. I used a clean install of Empire and followed every step. Real strange. Hope there is a solution.


  2. #2
    Tango12345's Avatar Never mind the manoeuvres...
    Moderation Overseer Patrician Citizen Content Emeritus

    Join Date
    Sep 2009
    Location
    London, UK
    Posts
    19,830

    Default Re: Ottoman turn bug

    Darth thought it was solved, but it wasn't, the occurrence was only reduced.

    There are a number of things that should be tried-starting a new campaign, going back to a previous save, blocking the Dardanelles/Hellespont bridge with a fleet, wiping out the Ottomans etc.

  3. #3

    Default Re: Ottoman turn bug

    Going out of the game (ctrl+alt+del) and going back in (alt+tab) seems to speed up the process considerably. Still very annoying though.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •