Results 1 to 15 of 15

Thread: Widescreen UI?

  1. #1

    Default Widescreen UI?

    I've just recently reinstalled M2TW, making sure the widescreen box (16:9) is checked, setting the ingame resolution to 1920:1050 also with the widescreen box checked. Here is my problem: Battle map looks fine, campaign map looks OK, UI is STRETCHHHHHHHHHED! (Ok, maybe not that many Hs, but it's stretched alright).

    I did search the forum but no answer was found. Perhaps, there is a UI mod that fixes this, anyone?

  2. #2
    Caesar Clivus's Avatar SS Forum Moderator
    Join Date
    May 2007
    Location
    Australia
    Posts
    12,693

    Default Re: Widescreen UI?

    Have you tried unchecking the widescreen box?

    BftB2 UPDATED 22nd DECEMBER. Member of the Complete Byzantine Unit Roster team

  3. #3

    Default Re: Widescreen UI?

    Okie, I tried unchecking the widescreen box, but there seems to be no change at all. As if whether or not the widescreen box is checked, my UI and only my UI looks stretched. I don't understand

  4. #4
    Stario's Avatar Domesticus
    Join Date
    Dec 2009
    Location
    Not the CCCP
    Posts
    2,053

    Default Re: Widescreen UI?

    I play 1920:1080 and get the same problem. It is unfortunately a limitation of the M2TW game engine. After a while you will get used to it somewhat; but yeah it sux a bit.

  5. #5

    Default Re: Widescreen UI?

    Right there with you buddy. One of my biggest problems with M2TW is how undistinguishible the building icons are from each other, amplified of course by the low-res UI. Sure when you have a few cities you can afford to mouse the cursor on the icon and glance to see what it is but when you have 30+ settlements?

  6. #6

    Default Re: Widescreen UI?

    So that's how it is...

    @ AdolphbinStalin: I think your portrait mod could solve the issue with low-res character's portrait getting stretched. As it is now designed for 4:3 screen aspect, it gets stretched horizontally when changed to 16:9. What if it is stretched vertically a bit so that upon changing the screen aspect to 16:9, it can compensate the distortion? Like, I am asking for a widescreen version of your mod. Is that possible?

  7. #7
    Caesar Clivus's Avatar SS Forum Moderator
    Join Date
    May 2007
    Location
    Australia
    Posts
    12,693

    Default Re: Widescreen UI?

    I play at 1680x1050 and I've had no noticeable stretching.

    edit: I assume your game resolution is the same as your desktop resolution. Try disabling borderless windowed mode in default.cfg in your SS folder.

    BftB2 UPDATED 22nd DECEMBER. Member of the Complete Byzantine Unit Roster team

  8. #8
    Stario's Avatar Domesticus
    Join Date
    Dec 2009
    Location
    Not the CCCP
    Posts
    2,053

    Default Re: Widescreen UI?

    Quote Originally Posted by Fatecheater View Post
    So that's how it is...

    @ AdolphbinStalin: I think your portrait mod could solve the issue with low-res character's portrait getting stretched. As it is now designed for 4:3 screen aspect, it gets stretched horizontally when changed to 16:9. What if it is stretched vertically a bit so that upon changing the screen aspect to 16:9, it can compensate the distortion? Like, I am asking for a widescreen version of your mod. Is that possible?
    I will release in a couple of weeks. It will be major overhaul. I pretty much went and sharpened and improved contrast etc. of every portrait and added 50 more portraits to the Generals (a total of 250 unique generals portraits) on top of the princess and agent portraits. With that said, I've been playing on 1920:1080 for so long I can honestly say I hardly notice the stretch these days (your eyes will get used to it I suppose). The problem is also that it is not just the portraits that are stretched but the whole UI interface (as you probably already noticed). The other thing you can do is reduce the game resolution but then you have to also reduce desktop resolution as it will screw thing up otherwise. For me this wasn't an option as I like my desktop resolution at 1920:1080.

    Quote Originally Posted by Caesar Clivus
    I play at 1680x1050 and I've had no noticeable stretching.

    edit: I assume your game resolution is the same as your desktop resolution. Try disabling borderless windowed mode in default.cfg in your SS folder.
    There seems to be a limit to resolution. This is what I played on prior to my 5 year old monitor dying on me a few month ago. Disabling borderless windowed mode unfortunately does not work. In fact no amount of changes to the default.cfg seems to work, in the end I gave up on it. Its also limited to the UI interface, the map and the rest of the game otherwise benefits from the increased resolution.
    Last edited by Stario; December 12, 2011 at 04:43 AM.

  9. #9
    Caesar Clivus's Avatar SS Forum Moderator
    Join Date
    May 2007
    Location
    Australia
    Posts
    12,693

    Default Re: Widescreen UI?

    Did you actually disable the borderless windowed mode? Some people (myself included ) didn't realise there was an automatic borderless windowed mode setting that keeps it turned on even if you disable it elsewhere in the file.

    BftB2 UPDATED 22nd DECEMBER. Member of the Complete Byzantine Unit Roster team

  10. #10
    Stario's Avatar Domesticus
    Join Date
    Dec 2009
    Location
    Not the CCCP
    Posts
    2,053

    Default Re: Widescreen UI?

    Quote Originally Posted by Caesar Clivus View Post
    Did you actually disable the borderless windowed mode? Some people (myself included ) didn't realise there was an automatic borderless windowed mode setting that keeps it turned on even if you disable it elsewhere in the file.
    [launcher]
    kingdomsDir=..\..
    swapMenuBackground=true
    swapMenuMusic=true
    swapBAI=true
    autoLocateLogFile=true
    autoBorderlessMode=true
    steamCheck=false
    firstRun=false
    steam=false
    [features]
    mod=mods/SS6.3
    [log]
    to=mods/SS6.3/system.log.txt
    level=* error
    level=* trace
    [io]
    file_first=true
    [video]
    no_background_fmv=true
    grass_distance=9000
    unit_detail=highest
    movies=false
    windowed=false
    borderless_window=false
    [game]
    unlimited_men_on_battlefield=1
    label_settlements=1
    event_cutscenes=0
    allusers=1
    micromanage_all_settlements=1
    advisor_verbosity=0
    [misc]
    show_hud_date=true
    #remove the # in the next line if you want launcher to bypass straight to the last save when you start mtw2
    #bypass_to_strategy_save=true
    These are my current settings. I am no expert so if you/anyone else recommends any changes please do tell.
    Last edited by Stario; December 12, 2011 at 05:59 AM.

  11. #11
    Caesar Clivus's Avatar SS Forum Moderator
    Join Date
    May 2007
    Location
    Australia
    Posts
    12,693

    Default Re: Widescreen UI?

    This is what I was talking about:
    Code:
    autoBorderlessMode=true
    You have to also set this to false.

    BftB2 UPDATED 22nd DECEMBER. Member of the Complete Byzantine Unit Roster team

  12. #12
    Stario's Avatar Domesticus
    Join Date
    Dec 2009
    Location
    Not the CCCP
    Posts
    2,053

    Default Re: Widescreen UI?

    @ Caesar Clivus,

    Unfortunately I've already tried that and it doesn't work. I tried again just now and still the same. With that said the situation isn't so bad the UI interface still looks pretty good (though maybe I am just used to it now).

  13. #13

    Default Re: Widescreen UI?

    I also don't have window mode enabled (partly because I wasn't aware of the fact there was one). I'll be sure to watch your portrait mod closely, Adolph.

  14. #14
    Caesar Clivus's Avatar SS Forum Moderator
    Join Date
    May 2007
    Location
    Australia
    Posts
    12,693

    Default Re: Widescreen UI?

    It's enabled by default so if you weren't aware of it, chances are it's on

    BftB2 UPDATED 22nd DECEMBER. Member of the Complete Byzantine Unit Roster team

  15. #15

    Default Re: Widescreen UI?

    Allow me to add to a 13 year old thread just in case another nostalgia seeker's looking for a solution to this.

    So I was finally able to fix this using a workaround.

    At first the problem was that the UI behaves completely independently from whatever you put into your preferences.cfg. Those lines only affect in-game resolutions, not UI. What the UI in fact does is it'll stretch to fit any aspect ratio that's wider than 4:3. Meaning, if you wanna get rid of UI stretch, your native resolution has to be 4:3.
    So I did that on my Mac (which, natively you can only do 1024x768 but it's no problem because I think it's the base resolution for 2006's M2TW). And UI stretching was gone. What's more is if you don't enable widescreen at this resolution, in-game graphics as well as movies run in the correct aspect ratio as well.
    So now the whole game is stretching-free, which happens to be one of my worst pet peeves ever. Yay.

    TL;DR
    Computer's native resolution > 4:3
    Then disable widescreen prefs in case you'd enabled it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •