Page 3 of 7 FirstFirst 1234567 LastLast
Results 41 to 60 of 139

Thread: Forcing a higher LOD (level of detail, i.e. no more sprites!)

  1. #41

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Yeah but doing that doesn't change anything for me...

  2. #42

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    To clarify, yes make sure you decompress the file from the zip file and put the .pack file in your data directory. That's all you need to do. Step by step instructions are not necessary. The pack is a patch pack so it WILL override the files in models.pack, there is no need to mess with that file!

  3. #43
    Hunterbear's Avatar Civis
    Join Date
    Sep 2008
    Location
    California
    Posts
    121

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Nice mod Lt.
    Going to try it out later tonight.
    Whatever lod problems still exist, I'm sure will be rectified in the near future once there is a better understanding of the file structure and further improvements in your pack program.
    +rep for this and your pack tool

  4. #44

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    So I assume the way we should mod is to create new pack files not change existing files...

  5. #45
    Breoghan's Avatar Civis
    Join Date
    Dec 2006
    Location
    Lvcvs Avgvsti
    Posts
    132

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Quote Originally Posted by Roope View Post
    Yeah but doing that doesn't change anything for me...
    The same for me...after unpack the contents of the zip. file in the data folder, annoying 2d sprites stillappear ingame

  6. #46

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Ehh, so I download that .zip, unzip it, then simply put the local_en.pack in the data folder.
    Nothing changes, are you sure that there's nothing else to do?

    Nothing to do with the Pack File Manager or anything? Because this doesn't work like this.
    And I have everything on ultra by the way.

  7. #47

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Same for me, everything on ultra, copied .pack file into /data dir and nothing change.

  8. #48

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Try going to C:\Documents and Settings\"yourname"\Application Data\The Creative Assembly\Empire\scripts, open preferences file in notepad, look for gfx_unit_quality and change it to 3. this worked for me.

  9. #49

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Quote Originally Posted by pete13 View Post
    Try going to C:\Documents and Settings\"yourname"\Application Data\The Creative Assembly\Empire\scripts, open preferences file in notepad, look for gfx_unit_quality and change it to 3. this worked for me.
    that same thing can be done in game... thats just the code version of what your unit detail is set to.... right under that in the preferences folder is the ship detail one... 0-3 are the possible entries and that corresponds to the ingame of like low medium high and ultra... just incase you needed proof that im right?

  10. #50

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Yes, this does not work for me as well. Could if because I have main.pack extracted?

  11. #51

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Quote Originally Posted by pete13 View Post
    Try going to C:\Documents and Settings\"yourname"\Application Data\The Creative Assembly\Empire\scripts, open preferences file in notepad, look for gfx_unit_quality and change it to 3. this worked for me.
    Maybe I'm crazy but I've looked for that on Vista many times before and I can't find where saved files go. I'd really like to try this out because those 2D people aren't too pretty.

  12. #52

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Whether on Vista or on XP, the quickest way to find the settings/save folder is to open windows explorer and type %appdata% in the address bar and press enter. There you'll see a bunch of folders, open the one named The Creative Assembly.

  13. #53

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    yea only the thing you will be changing to 3 is just the unit detail quality which can be changed in game in the graphics menu so stop wasting your own time changing the file when you can do it in game.

  14. #54

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Chambers any chance you can double check if the .pack file is working correctly? I still see sprites with it on Ultra settings.
    ETW ship combat with pirate rap:
    http://www.youtube.com/watch?v=4SyN0QdEZyA

  15. #55

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    I'm not noticing any difference here. The sprites are certainly still there. I still see those doom animations sliding across the screen in the distance

  16. #56

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Quote Originally Posted by kaypo View Post
    I'm not noticing any difference here. The sprites are certainly still there. I still see those doom animations sliding across the screen in the distance
    lol me too! Its annoying I want to see this great sounding mod in action.

    Anyone who has it up and running could you please post a screenie? Be much appreciated

  17. #57

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    I also am not seeing a difference. One thing I noticed when I opened the file with the packmanager is that it is saved as a "release" and not as a "patch". When it is saved as a patch, it will supposedly over-ride other other files in the data folder.

  18. #58

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    I think this mod only works on unit size Normal, somehow when I increased unit size I got the dreaded "blobs" in my units. Going to test some more today.

    Maybe the game change to the "blobs" based on your performance or number of men on the field?

  19. #59
    Laetus
    Join Date
    Mar 2009
    Location
    Fredrikstad, Norway
    Posts
    4

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    Tried this right now, and it worked great tried a battle on my previous settings first, there was definatily an improvement in FPS. tried another battle with all settings turned on ultra (except for trees and grass) and there was barely any difference in the FPS, great job, thanks

  20. #60

    Default Re: Forcing a higher LOD (level of detail, i.e. no more sprites!)

    I'm pretty sure its relying on the Lod2 Sprites 50% of the time and the LOD1 models which are the ones we want the rest of the time.. The other sprites (ie. the ones that aren't lighted at all by the engine) have been removed using this mod so it DOES work- but doesn't remove the sprites entirely- I'm really considering doing it manually to force it to the highest LOD possible.

Page 3 of 7 FirstFirst 1234567 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •