Downloads: Medieval II Patch v1.2

Medieval II Patch v1.2

Uploaded by gigagaia - July 31, 2007
Author Author the Creative Assembly
File Size File Size 607.49 MB
Downloads Downloads 47,073
+ Download

Images

None

Comments

MunichRules
July 31, 2007 at 06:45 AM
What is that new philosophie about ???

I have to pay for downloading a patch ??????

Can someone upload the Patch to a normal platform ????

Thanks !

Human Race always thinking in profits
imperialism
July 31, 2007 at 06:55 AM
it seems we just have to pay for the patch,lol
erasmus777
July 31, 2007 at 07:59 PM
Try http://www.gamershell.com/download_19011.shtml. It's free.
MunichRules
August 06, 2007 at 01:20 PM
@ erasmus777

thanks a lot
Joe012
August 19, 2007 at 09:51 AM
every time i install this patch (using the gamershell link) the game freezes on startup, i'll see the first load screen come up, then i hear the "windows alert bell" and my screen goes black. ctrl alt delete doesnt work to get me back to desktop and i have to restart my computer by turning the power off. is anyone else having this problem? how do i fix it?
Joe012
August 19, 2007 at 10:05 AM
BTW, im upgrading from 1.00 to 1.2. Ive also downloaded the patch from filefront, and have the same problem.
Joe012
August 19, 2007 at 05:42 PM
nevermind, i found the answer in another forum
Snoopy
August 21, 2007 at 06:54 PM
Same as Joe, and I don't know how.

And I won't think the average person wants to pay 3-20 bucks for some patch.
Torelli
August 24, 2007 at 04:47 AM
i downloaded from fileplanet and everythings ok
w4n4d00
October 03, 2007 at 12:57 PM
Problem with the patch is that the game may become unplayable on some computers and may require re-installation of the game. For many people this issue is as yet unresolved, and the game, although playable, still contains many bugs and gameplay issues, as they cannot use the patch without reinstalling the game, and may be unwilling/unable to do so. At the time of writing there is no comment from CA or SEGA regarding fixing this issue, except to suggest that users experiencing problems applying the patch should re-install the game. Most, but not all issues relating to patch failure have been traced to the presence of third-party file modifications (user-installed Mods) or to user-modifications of certain game files.
Milos the Dragon
October 25, 2007 at 03:16 PM
I click on to the icon, and there is message "Please insert the correct CD-ROM, select Ok and restar application
Ogisha
February 24, 2008 at 09:10 AM
miloseeeee srbine ale ale ale
Incu_volta (Crown Prince)
February 27, 2008 at 12:50 PM
Hi, I'm new here but I have been coming to this forums for the last couple weeks. I do have a question though.

I have finally got back to playing MTWII after about a six month hiatus. And I'm already down-right sick of the vanilla version. So I decided to download the patch as so I could download and install one of the great many interesting mods out there. So after downloading and installing the patch the first time I tried to run the game, it would load and everything but the main image would only appear for like a split second. Then however, it would be taken up by a black screen and not do anything at all. I litterallly let it sit there for like half hour as to see if it was just some loading problem, or perhaps my computer being ever so slow, which never happens. But nothing happens at all. So i un-installed MTWII and then re-installed it, then tried the patch again. But still, same bloody problem.

So as to my question:

What is the cause of these (if known) and is there any solution to it at all??


Thank you for any feedback. It would be much appreciated!
Karkhan
February 28, 2008 at 03:09 PM
You all realize that this link is for the EU patch and there is a US patch also. Just making sure you are downloading the correct patch!
Eranshahr
April 04, 2008 at 07:48 PM
This link didn't lead me to the EU patch.