Results 1 to 12 of 12

Thread: Weird drop of FPS

  1. #1

    Default Weird drop of FPS

    I recently noticed a strange drop of FPS linked with AA.
    Both on Warhammer I and II.

    When I launch the test of performances, I get a miserable 17 FPS average on Warhammer I, where I used to have around 50. When I switch from AA 2x to FXAA, I jump to 70 FPS.

    With Warhammer II, it is even weirdier : I get an average 44 FPS with AA 2x, if I switch to 4x and then revert back to 2X, I jump to 52 FPS. But if I stop the game, restart it and launch a new test, I'm back to 44 FPS.

    I have changed nothing to my computer since the last time I played, just updated to the last Nvidia drivers.

    I have honestly no idea what to do. It is not a drama , but I really wonder how it could happens.
    Last edited by Blackader; March 15, 2019 at 10:01 AM.

  2. #2
    Steph's Avatar Maréchal de France
    Patrician Artifex

    Join Date
    Apr 2010
    Location
    Pont de l'Arn, France
    Posts
    8,028

    Default Re: Weird drop of FPS

    What's your GPU?

  3. #3

    Default Re: Weird drop of FPS

    It's true, I forgot to put my specs, sorry : Intel-Core i5-8500 3Ghz
    RAM 8 Go
    Nvidia 1070 8 Go

  4. #4
    Steph's Avatar Maréchal de France
    Patrician Artifex

    Join Date
    Apr 2010
    Location
    Pont de l'Arn, France
    Posts
    8,028

    Default Re: Weird drop of FPS

    I'm not sure in that case. There were some FPS drop reported with NVidia latest drivers, but I think it was mostly for RTX series

  5. #5

    Default Re: Weird drop of FPS

    What puzzle me more than just FPS drop (even if it is just with warhammer and no other games) is that I can gain (in performances test) 10 just by switching to AA 4x and then revert back to AA 2x. As if changing some options could say to my computer to use more ressources or something like that...

  6. #6
    ♔Greek Strategos♔'s Avatar Bearded Moderation
    Artifex Content Staff Modding Staff

    Join Date
    Feb 2008
    Location
    Athens
    Posts
    10,450

    Default Re: Weird drop of FPS

    @Blackader
    You should only update your graphics drivers when you're having specific unsolved performance issues and always check their stability-reliability first, on dedicated Tech sites.
    You can try the App Data Fix in case your settings are just bugged. Click on my Sig and follow step 6 from the opening post. It's the same method for any TW title.
    Also, are you aware of the latest problematic Microsoft's update? Are you using Win 10 ? if yes, just uninstall the following update: KB4482887.

    Last edited by ♔Greek Strategos♔; March 17, 2019 at 03:22 PM.

  7. #7

    Default Re: Weird drop of FPS

    I didn't know about problems of windows update, thanks.
    What are they ?

    As a rule, I confess that I let updates install automatically. Probably a mistake...

    I forgot to say that, following advices on the forum, I put my warhammer files on my SSD, to avoid too long loading times.

    Edit : I tried both methods (reinstalling directx after deleting script and uninstalling windows update) with no avail. I still have a 10FPS difference by just launching performances test, set AA to 4x, relaunch the test, and then go back to AA 2x. Odd enough, if I don't launch the test at every step, I do not have any FPS gain.
    Last edited by Blackader; March 18, 2019 at 05:14 PM.

  8. #8
    Kurisu Paifuaa's Avatar Biarchus
    Join Date
    Mar 2009
    Location
    Pennsylvania, US
    Posts
    621

    Default Re: Weird drop of FPS

    @Blackader

    Try reverting to an earlier (pre 400.x) Nvidia driver. I'm using 399.24, and it fixed a similar slowdown for me on a fairly new machine (i7 -8086k; gtx 1080) when applying any level of msaa.

    I found this solution by searching for anecdotes of similar performance drops... sorry I don't have a link for reference, it was likely either here, reddit, or guru3D.
    Last edited by Kurisu Paifuaa; Yesterday at 02:50 AM.

  9. #9

    Default Re: Weird drop of FPS

    Thanks for the advice. How I could revert to an earlier Nvidia driver ?

  10. #10
    ♔Greek Strategos♔'s Avatar Bearded Moderation
    Artifex Content Staff Modding Staff

    Join Date
    Feb 2008
    Location
    Athens
    Posts
    10,450

    Default Re: Weird drop of FPS

    Quote Originally Posted by Blackader View Post
    I didn't know about problems of windows update, thanks.
    What are they ?
    As a rule, I confess that I let updates install automatically. Probably a mistake...
    It's in the link I previously posted for you
    Yeap, a big one actually...

    Quote Originally Posted by Blackader View Post
    Thanks for the advice. How I could revert to an earlier Nvidia driver ?
    1) Just grab the most stable previous driver release.
    2) Clean unistall with DDU.
    3) Install the driver of your choice.
    Last edited by ♔Greek Strategos♔; Yesterday at 03:36 PM.

  11. #11

    Default Re: Weird drop of FPS

    Thanks again !

    Edit : well, thank you very much, I revert to a 388 Nividia driver version, and no more FPS malarkey ! Very usefull and +rep ! Problem solved !
    Last edited by Blackader; Yesterday at 05:11 PM.

  12. #12
    ♔Greek Strategos♔'s Avatar Bearded Moderation
    Artifex Content Staff Modding Staff

    Join Date
    Feb 2008
    Location
    Athens
    Posts
    10,450

    Default Re: Weird drop of FPS

    Quote Originally Posted by Blackader View Post
    Thanks again !

    Edit : well, thank you very much, I revert to a 388 Nividia driver version, and no more FPS malarkey ! Very usefull and +rep ! Problem solved !
    My pleasure

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •