Page 2 of 2 FirstFirst 12
Results 21 to 25 of 25

Thread: Windows 10

  1. #21
    Daruwind's Avatar Citizen
    Join Date
    Oct 2013
    Location
    Prague
    Posts
    1,720

    Default Re: Windows 10

    Why not try to fresh install in your desktop anyway? No copying? Like I would be surprised if your game is not working on two unrelated systems...

  2. #22

    Default Re: Windows 10

    That was the first thing what I tried.

  3. #23
    ♔Greek Strategos♔'s Avatar Bearded Moderation
    Artifex Content Staff Modding Staff

    Join Date
    Feb 2008
    Location
    Athens
    Posts
    10,678

    Default Re: Windows 10

    Quote Originally Posted by DAR View Post
    Hy guys,
    I have the general problem that mentioned earlier, but after hours of reading forum threads I cant find the solution, pls. help me.
    Some days ago Rome 2 started to crash by each an every launch (after the launcher opened, I click on the "Play" button, and then come the black screen for a second and I'm dropping back to the Desktop -and a crash report .txt appears in the Rome 2 directory) - I have to mention, that once time, somehow started to work but only for one time, I dont know how it happaned but I hope that it means not impossible to work again).
    Methods that I tried but didn't worked:
    - uninstall, and clean, fresh reinstall the game,
    - repalce TW Attila launcher files (Steamapps/common/Attila/launcher > Rome2/launcher...),
    - run as adminstrator / compatibility mod,
    - changed the language of the game,
    (OS is Windows 10 64bit, and the hardware requirements of course enough).


    I'm really sorrowful, because I've never had this kind of problem since the game announced.
    Is there any solution?


    Thank you for your attention, have a nice day to all!
    Hi, please give me your detailed hardware's list (ofc enough isn't a detailed answer) and I'll see what I can do.

    Off the top of my head:

    1) Win 10 automatically messes with your drivers if you haven't disabled the auto driver updates.
    2) Your antivirus is acting weird.
    3) Try using STEAM's exe (NOT THE GAME) with Admin or Compatibility rights.
    4) Try running the game on DirectX9 instead of DirecXt11 by going to your Preferences.script.txt in C: User/your name/The Creative Assembly/Rome2/Scripts/preferences and then find the entry gfx_device_type 1; and change it to gfx_device_type 0; save it and launch the game.

  4. #24

    Default Re: Windows 10

    First of all thank You to the answers!
    Quote Originally Posted by ♔Greek Strategos♔ View Post
    Hi, please give me your detailed hardware's list
    - ASUS Z97-P Motherboard
    - 16GB RAM (DDR3 3, If I remeber corretly, -I dont know wheter is important or not)
    - nVidia 970GTX (ASUS ed.), - 399 WHQL driver (but the basic and the brand new, and one driver from aug. of 2018 were also tested)
    - STRIX SOAR soundcard (ASUS ed.)
    - CoreI5 3.5GHz
    - Windows 10, 64-bit (I don't remember the original build number - I think this version is from year 2017), but the first thing what I managed after a fresh Windows 10 installation is to DISABLE the auto updates (through special cmd commands, in order to prevent any further updates and compatibility problems), I use this method by different windows 10 versions and I had no problem till now).
    I have to note: the game was able to run on this config, without problems (the first problem came maybe after a MANUAL nVidia driver update).

    Quote Originally Posted by ♔Greek Strategos♔ View Post
    3) Try using STEAM's exe (NOT THE GAME) with Admin or Compatibility rights.
    Sorry, but I cant understand it, what do you mean by that? (I tried to start it both Rome2.exe and via Steam but in both case the total war launcher will open), compatibility and administrator mode also were tested (and not worked).

    Quote Originally Posted by ♔Greek Strategos♔ View Post
    4) Try running the game on DirectX9 instead of DirecXt11 by going to your Preferences.script.txt in C: User/your name/The Creative Assembly/Rome2/Scripts/preferences and then find the entry gfx_device_type 1; and change it to gfx_device_type 0; save it and launch the game.
    And where can I get a preference file?
    I'm afraid I don't have such .txt (I think these file generated after the first - SUCCESSFUL - launch of the game), and I have a fresh installation (actually).
    I'd try this solution, maybe, this will be a new one, but to say the truth, I don't believe it... (of course I'll try it when I get home afternoon).

    I'm really curious the source,- and the solution of this problem.
    Before last week, and at this weekend I sent some e-mails to the CA group about this issue (to every shown adresses), but already no answers. I hope they will bring a solution.
    Have a nice day guys, thanks to All!

    Quote Originally Posted by ♔Greek Strategos♔ View Post
    4) Try running the game on DirectX9 instead of DirecXt11 by going to your Preferences.script.txt in C: User/your name/The Creative Assembly/Rome2/Scripts/preferences and then find the entry gfx_device_type 1; and change it to gfx_device_type 0; save it and launch the game.
    - this one worked Me! Thank You!
    Last edited by ♔Greek Strategos♔; Today at 05:04 AM. Reason: Merged posts.

  5. #25
    ♔Greek Strategos♔'s Avatar Bearded Moderation
    Artifex Content Staff Modding Staff

    Join Date
    Feb 2008
    Location
    Athens
    Posts
    10,678

    Default Re: Windows 10

    Quote Originally Posted by ♔Greek Strategos♔ View Post
    4) Try running the game on DirectX9 instead of DirecXt11 by going to your Preferences.script.txt in C: User/your name/The Creative Assembly/Rome2/Scripts/preferences and then find the entry gfx_device_type 1; and change it to gfx_device_type 0; save it and launch the game.
    Quote Originally Posted by DAR View Post
    This one worked Me! Thank You!
    No problem. I'm here too hep
    Last edited by ♔Greek Strategos♔; Today at 05:08 AM. Reason: Merged posts.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •