Page 1 of 9 1 2 3 4 5 6 7 8 9 LastLast
Results 1 to 20 of 175

Thread: PFM 5.0 - Warhammer 2 support

  1. #1

    Default PFM 5.0 - Warhammer 2 support

    I just uploaded the PFM version 5.0, supporting Warhammer 2 packs.

    Download Current Version 5.0

    Note that Larynja has taken over updating the schema; the support thread for db editing schemas is available here.
    Tools: PFM 4.1 - EditSF 1.2.0
    (Download PFM - Download EditSF)
    Warscape Modding Guide
    Join the PFM User Group on Steam to receive PackFileManager update notifications.

    Respecto Patronum

  2. #2

    Default Re: PFM 5.0 - Warhammer 2 support

    Hi,

    I have a tiny problem with the recent versions (this one and the 5.0 beta) - I cannot set them as default program for opening .pack files. So, I cannot open them by double-clicking, only by starting PFM and going through File->Open. I did not have that issue with PFM 4.1.2.

    I'm using Windows 7 64-bit.

    Has anyone encountered this / know how to fix it?

    P.S. Thank you to daniu and everyone else who's worked on PFM! I probably wouldn't even bother with the new game if I didn't have PFM to fix CA's countless messes =)

  3. #3

    Default Re: PFM 5.0 - Warhammer 2 support

    I dont know if its just me, but the file you uploaded has no file extension

    I still opened it by putting .zip at the end, but yeah it comes up blank for me

  4. #4

    Default Re: PFM 5.0 - Warhammer 2 support

    Quote Originally Posted by MrHoon View Post
    I dont know if its just me, but the file you uploaded has no file extension
    Oh, thanks for the hint, I accidentally renamed the file when I wanted to remove the ".zip" to change the download button text.

    Quote Originally Posted by HumbleWarlock View Post
    I have a tiny problem with the recent versions (this one and the 5.0 beta) - I cannot set them as default program for opening .pack files. So, I cannot open them by double-clicking, only by starting PFM and going through File->Open. I did not have that issue with PFM 4.1.2.
    I'm using Windows 7 64-bit.
    Has anyone encountered this / know how to fix it?
    That's a problem with Windows not being able to reassign the default program to another program with the same name in another location.
    It should work fine if you just unzip in the previous 4.1.2 location.
    Tools: PFM 4.1 - EditSF 1.2.0
    (Download PFM - Download EditSF)
    Warscape Modding Guide
    Join the PFM User Group on Steam to receive PackFileManager update notifications.

    Respecto Patronum

  5. #5

    Default Re: PFM 5.0 - Warhammer 2 support

    Quote Originally Posted by daniu View Post
    That's a problem with Windows not being able to reassign the default program to another program with the same name in another location.
    It should work fine if you just unzip in the previous 4.1.2 location.
    It worked! Thanks!

  6. #6

    Default Re: PFM 5.0 - Warhammer 2 support

    Quick question is it intended that you cant copy-paste the name of one table onto another one?
    for example if you rename land_units from data__ to Example. Why cant i copy and paste Example unto other tables?

  7. #7

    Default Re: PFM 5.0 - Warhammer 2 support

    Hello all.

    I've recently downloaded PFM for the first time to try my hand at modding. I wanted to start by changing the colors of faction uniforms. When i navigate to the faction_uniform_colors table i get the following message:

    Unhandled exception has occurred in your application...so on and so forth. Then it says:

    Object reference not set to an instance of an object. Could anyone possibly help me figure out what I've done wrong. For reference I'm using Windows 10 64-bit Home.

    Cheers!

  8. #8

    Default Re: PFM 5.0 - Warhammer 2 support

    Hi daniu, thanks a lot for keeping up your amazing PFM work!

    Here is probably some helpful information for Windows 10 users.

    If the PFM 5.0 executable file PackFileManager.exe will be launched the first time on Windows 10, then it can happen that the internal "Microsoft Smart Screen Filter" will prohibit the launch. Just click there in the pop-up on the link "Additional information" and click below on "execute anyway". Then it should start and work fine.

  9. #9
    Commissar Caligula_'s Avatar The Ectasy of Potatoes
    Content Emeritus

    Join Date
    Dec 2013
    Location
    Melbourne
    Posts
    5,097

    Default Re: PFM 5.0 - Warhammer 2 support

    This is a bit of a weird question, but do you have copies of the Warhammer 1 or Attila icon files for PFM? I don't really like the Warhammer 2 icon, and I'd rather revert to an old version.




  10. #10

    Default Re: PFM 5.0 - Warhammer 2 support

    Quote Originally Posted by Swiss Halberdier View Post
    I got some questions about the various PFM versions.

    PFM 3.5.2 > supports Empire, Napoleon, Shogun 2, Rome 2 and Attila

    PFM 4.1.2 > supports Empire, Napoleon, Shogun 2, Rome 2, Attila and Warhammer 1

    PFM 5.0 > supports Empire, Napoleon, Shogun 2, Rome 2, Attila and Warhammer 1 + 2


    Do you recommend to use now also PFM 5.0 for modding all older TW games before Warhammer 1+2?

    Is there any other reason why we should still use for these older games PFM 3.5.2 or PFM 4.1.2 besides they are both stable and long time used?
    I do recommend that, and it was my goal to support all games at once.
    There were some bug fixes along the way that are still present in the old versions, and I don't think there were a lot of new bugs introduced.

    The only problem that might arise is that during schema updates, a table definition of an old game got overwritten; however, that would have been accidental and there should be no problem just reinserting the old version again.

    Quote Originally Posted by Caligula View Post
    This is a bit of a weird question, but do you have copies of the Warhammer 1 or Attila icon files for PFM? I don't really like the Warhammer 2 icon, and I'd rather revert to an old version.
    I do have those icons, but I don't want ot use an old one in general since the main icon marks what major version you are using.

    BTW, the old icons are still contained in the exe - you may not have noticed, but the PFM's windowbar icon actually changes depending on what game you are modding - so if you want to use a hack like this, you should be able to get the icon you want from the exe.
    Tools: PFM 4.1 - EditSF 1.2.0
    (Download PFM - Download EditSF)
    Warscape Modding Guide
    Join the PFM User Group on Steam to receive PackFileManager update notifications.

    Respecto Patronum

  11. #11
    Commissar Caligula_'s Avatar The Ectasy of Potatoes
    Content Emeritus

    Join Date
    Dec 2013
    Location
    Melbourne
    Posts
    5,097

    Default Re: PFM 5.0 - Warhammer 2 support

    Quote Originally Posted by daniu View Post
    BTW, the old icons are still contained in the exe - you may not have noticed, but the PFM's windowbar icon actually changes depending on what game you are modding - so if you want to use a hack like this, you should be able to get the icon you want from the exe.
    Thanks for the help, I had an old version of the Attila PFM and I grabbed the icon from that exe using that Resource Hacker.




  12. #12

    Default Re: PFM 5.0 - Warhammer 2 support

    I just downloaded the PFM 5.0 for Warhammer 2 and I immediately started editing some unit stats(projectile range). So I saved the data.pack, then looked at the units in-game and it didn't change the stats (Lothern Sea Guards range still 160). The steps I did worked well with NTW and ATW. Is there a step I missed. I'm using an existing campaign save. Or do you have to start a new game for the edits to change?

  13. #13

    Default Re: PFM 5.0 - Warhammer 2 support

    Quote Originally Posted by Divi View Post
    I just downloaded the PFM 5.0 for Warhammer 2 and I immediately started editing some unit stats(projectile range). So I saved the data.pack, then looked at the units in-game and it didn't change the stats (Lothern Sea Guards range still 160). The steps I did worked well with NTW and ATW. Is there a step I missed. I'm using an existing campaign save. Or do you have to start a new game for the edits to change?
    Just tried it, works fine. You don't have to start a new game. To be sure, you edited the projectiles_table in the column effective_range?
    By saying "saved the data.pack" do you mean the actual data.pack file or your mod pack file?

  14. #14

    Default Re: PFM 5.0 - Warhammer 2 support

    Yes. I edited it. And save it directly into the actual data.pack file. I opened the data.pack to see if it was edited and it was. That was how I did it with NTW. Maybe there is a correct way to do it?
    Here's the steps I did. Correct me if I did something wrong.

    1.Opened PFM 5.0
    2. Opened File>open>selected data.pack
    3. Edited variables
    4. Unchecked read only
    5. Then saved File>Save..

  15. #15

    Default Re: PFM 5.0 - Warhammer 2 support

    I never tried to edit the actual data.pack file myself, just heard that it can lead to various problems if you do that.
    If you create your own mod file, it will work fine.
    In case you have never done that before, here are the steps:
    Start PFM, create an empty mod (File -> New), then import the table you want to edit (File -> Add -> from pack -> data.pack) and select the projectiles table or whichever you want to edit. Do your changes, save, copy the mod in your TWW2 installation directory in the data folder, start the game launcher -> mod manager -> enable out of date mods and select your mod.

  16. #16

    Default Re: PFM 5.0 - Warhammer 2 support

    Quote Originally Posted by ratatack906 View Post
    Hello all.

    I've recently downloaded PFM for the first time to try my hand at modding. I wanted to start by changing the colors of faction uniforms. When i navigate to the faction_uniform_colors table i get the following message:

    Unhandled exception has occurred in your application...so on and so forth. Then it says:

    Object reference not set to an instance of an object. Could anyone possibly help me figure out what I've done wrong. For reference I'm using Windows 10 64-bit Home.

    Cheers!
    Anyone?

  17. #17

    Default Re: PFM 5.0 - Warhammer 2 support

    I've been having similar problems, I think some of it may come from antivirus software interfering, but I have no fix for it I'm afraid. I was using PFM 5.0 for hours yesterday, but today no chance, I get "convocation error array was out of bounds" and a series of other errors that pop up too fast for me to read them!

    I've actually just re-downloaded PFM 4.1.2, and so far it's working so I'm going to stick with that for now. Kep up the good work, PFM is so much better than using DAVE and whatnot, hope you manage to smooth out any bugs.

  18. #18

    Default Re: PFM 5.0 - Warhammer 2 support

    Hello guys. I have made a few personal mods many times, but all of a sudden I keep getting problems making any changes to the .loc files in PFM 5.0, and since installing it, with my old 3.5 version.

    Anytime I make a change to one, I get an unhanded exception error, stating that "object cannot be cast from DB Null to other types".

    It errors all over the place when the .loc files are loaded, or trying to be extracted.

    Any help appreciated. The error messages are huge in full, but if you need them its easy to recreate.

    Thanks

  19. #19

    Default Re: PFM 5.0 - Warhammer 2 support

    PFM isn't linking to other tables so no dropdown box for other options in the fields.

  20. #20

    Default

    when I try to open the data file from character_skills_nodes_table in PFM 5.0 I have the following error:

    "Failed to open data: System.NullReferenceException: La référence d'objet n'est pas définie à une instance d'un objet [...]"

    Did i mess up something or does PFM needs an update after Mortal Empires?

    EDIT: It's all goo I fixed it thanks to RoninX2807.

    Here is the way to do it.
    Last edited by Frunk; October 29, 2017 at 01:58 AM. Reason: Posts merged (page break).

Page 1 of 9 1 2 3 4 5 6 7 8 9 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •