Results 1 to 4 of 4

Thread: Crashing caused by Archers

  1. #1

    Default Crashing caused by Archers

    I've been having some strange crashes in relation to archer heavy armies. For some reason whenever I field an army made up entirely of archers the game will always crash as the battle is loading up. It doesnt crash with an army of anything else (100% Infantry is fine, 100% Cavalry is fine etc) so I dont believe its a case of my computer not being able to handle the numbers. In fact even if I was to field 2 half stacks of archers against each other the game will still crash. Whats even more strange is that the crash doesn't happen with any other kind of missile unit, and it seems to be only this mod that is affected by this problem (I have done thorough checks on other mods and vanilla M2TW). Ive even tried reinstalling, scrubbing all sub mods and playing SS exactly as it comes, and yet the crashing persists. Is it the animations? Have the arrows been modified in any way from the base game? Has anyone else experienced this problem? And if so then have you been able to fix it? It's really annoying seeing as archer heavy tactics are my prefered strategy.

    On the off chance anyone may ask, here are my cpu specs:

    Operating System: Windows 10 Home 64-bit (10.0, Build 14393) (14393.rs1_release.160915-0644)
    Language: English (Regional Setting: English)
    System Manufacturer: System manufacturer
    System Model: System Product Name
    BIOS: 9003
    Processor: Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz (4 CPUs), ~3.5GHz
    Memory: 16384MB RAM
    Available OS Memory: 16312MB RAM
    Page File: 4956MB used, 21356MB available
    Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 12
    DX Setup Parameters: Not found
    User DPI Setting: Using System DPI
    System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
    Miracast: Available, with HDCP
    Microsoft Graphics Hybrid: Not Supported
    DxDiag Version: 10.00.14393.0000 64bit Unicode

    GPU: Nvidia 980 Ti

    I have also checked my crash logs and it's not giving me anything. Just goes from everything running fine to unspecified error message.

  2. #2

    Default Re: Crashing caused by Archers

    Hmm... Ive never seen this specific problem, but ive never gone with a full archer army either.
    Ill try it and see if I get any crashes.
    Stand by....

    Hmm cant find a problem when I try it.
    I assume you are using SS 6.4?
    Last edited by Duck of Death; June 04, 2017 at 01:39 PM.
    Honest and truly, I AM Robin Hood!

  3. #3

    Default Re: Crashing caused by Archers

    Yeah SS 6.4. Completely fresh reinstallation and it's still the same problem no matter what archer units I test on. Savage AI, BGR2, Next Heir Ancillary, Disable RR, Permanent Watchtowers and Longer Assimilation. I had this same problem on my previous computer as well which is even stranger. I've no idea what could be causing it

  4. #4

    Default Re: Crashing caused by Archers

    Maybe try disabling/changing some of the installation choices (next heir ancillary, BGR, etc...) one by one. See if a different combination will stop the crashing.
    You shouldn't have a problem with them all but, worth a try in your specific case.

    Also, just thought...
    If this happened on different computers and regardless of mods, is it possible your installation files have become corrupt?
    If nothing else works, you might try re-downloading all the installation files (a pain I know, but as last resort).

    If still you get crashes after that, I could only suggest throwing a few infantry/cavalry units into your army to work around the glitch.
    Last edited by Duck of Death; June 05, 2017 at 09:26 PM.
    Honest and truly, I AM Robin Hood!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •