Page 2 of 9 FirstFirst 1 2 3 4 5 6 7 8 9 LastLast
Results 21 to 40 of 177

Thread: Discussion about the ents, spiders and wolves crashes.

  1. #21
    alreadyded's Avatar Work up a #6 on 'em!
    Join Date
    Mar 2009
    Location
    Stayin' Alive
    Posts
    3,051

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Trolls are not elephants, they are infantry as far as the game is concerned. The ents, spiders, balrog, sauron, etc. are all elephants to the game (in the code). So are mumakil, so it may be a simple matter of comparing the code. I did find a bug long ago (before tatw 2.0 I think) with these "elephant" units in TATW that caused a instant crash when they should catch on fire due to some code being wrong, so it may be a simple mistake like that.

    I use Win7 Ultimate, I never tested any of this in Vista or Win8 and above. I avoid them like the plague .

    If someone that does get crashes often can try a battle with 20 mumakil in it a couple times and see if it crashes. The number of units seems matter, which I assume is why ents, balrog, and sauron do not cause crashes as much as units with larger numbers. I used to get random crashes rarely but I made a lot of tweaks to the BAI and it went away for me for a long time now.

  2. #22
    badass7's Avatar Foederatus
    Join Date
    Jun 2005
    Location
    United Kingdom
    Posts
    46

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Quote Originally Posted by alreadyded View Post
    If someone that does get crashes often can try a battle with 20 mumakil in it a couple times and see if it crashes. The number of units seems matter, which I assume is why ents, balrog, and sauron do not cause crashes as much as units with larger numbers. I used to get random crashes rarely but I made a lot of tweaks to the BAI and it went away for me for a long time now.
    Just tried a few custom battles, with Rhun and Gondor full stack mixed armies vs 20 units of Mumakill, and no crashes at all. Definitely something specific to the Wolves, Ents and Spiders. I will say the Ents seem to crash a lot less for me, I've fought them in campaign a few times absolutely fine. It's mainly the spiders for me.

  3. #23
    ElvenKind's Avatar Enjoy your life!
    Join Date
    Apr 2012
    Location
    Croatia, Zadar
    Posts
    6,523

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    My Video settings with Unit size set to small for PCP submod, and a laptop with a low end GPU ATI Radeon HD545V 512 MB DDR3 ( no crashes regarding any creature unit ):

    Spoiler Alert, click show to read: 
    TATW Local Moderator
    Proud supporter of TATW,MOS,PCP, DaC!! -
    TWC Guide for new members by
    Shankbot- EK`s Install Thread - * Under proud patronage of one and only StealthFox *
    Want to be a new Justin B ?
    Want to learn pro photo editing?
    Best food in your own kitchen!
    Start your own business, and enjoy it!

  4. #24
    Veteraan's Avatar TATW Local Moderator
    Join Date
    Jul 2013
    Location
    Tilburg, Kingdom of The Netherlands
    Posts
    3,000

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Are there any players out there are running Windows 8 (1) that have NO crashes with Ents, Spiders or Wolves?
    Please provide your data if that is the case.

    Of course reports from other configurations are still very welcome too.

    Edit: Reports from players that do NOT have Windows 8(1), but are experiencing crashes with Ents, Spiders or Wolves would also be very interesting.
    Last edited by Veteraan; July 14, 2015 at 09:13 AM.

    Citizenised by Shankbot - Patron of b0Gia - House de Bodemloze

  5. #25

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Just tried a battle with 39 Mumakill units and I did not get a crash.

  6. #26
    alreadyded's Avatar Work up a #6 on 'em!
    Join Date
    Mar 2009
    Location
    Stayin' Alive
    Posts
    3,051

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    It does seem to be OS specific, however as I said, I did have these crashes rarely and randomly long ago (with win7 Ult) until I edited the BAI script. However my crashes may have been unrelated and had something more to do with the BAI reinforcements causing a ctd. Which may be what you guys are experiencing only amplified due to software/firmware/hardware. The ents literally use vanilla M2TW animations, so if the animations were a problem it should crash with any unit that uses the same animations (mace and axe units). Unless KK messed with some code that I am unaware of. But as others have said this happens in the Zelda mod too (I am guessing that doesn't use TATW as a base). Wonder if that mod uses G5's BAI? I never played it.

    The animations code (not the actual packed animations but the in game code that says when to use what animation) may be messed up as well. I have found problems with it in the past with the ents, sauron, balrog, that I fixed and told KK about. I don't play vanilla TATW or even have it installed so I don't know if he ever did these fixes, and maybe more fixes are needed that even I am unaware of but I haven't noticed any problems and crashes due to that would happen for everyone instantly, not some randomly.

    I don't have or use vista/8+, but for those of you that do I would try googling how to disable some more of that useless "security" crap that it comes with. Maybe the OS just doesn't like certain files and isn't reading them leading to a crash. Running the game in compatibility mode for XP might be worth a try (I have no clue how good compatibility mode is in vista/8+, probably terrible) and setting your antivirus software to "gaming mode."
    Last edited by alreadyded; July 15, 2015 at 07:04 PM.

  7. #27

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    I've tried xp compatibility mode and there wasn't a significant difference in the percentage of crashes.

    Also, the OS thing makes me worry if more things will cause crashes after I upgrade to Windows 10.

  8. #28
    alreadyded's Avatar Work up a #6 on 'em!
    Join Date
    Mar 2009
    Location
    Stayin' Alive
    Posts
    3,051

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Also; the game can randomly mess up and crash or just not start after running it for awhile or opening and closes it a lot, or even just running it once and leaving your PC on for a long time before you run it again.

    Errors like this usually say a animation can not be found (even though it does exist and works), like so;
    Code:
    19:04:24.934 [system.io] [trace] file open,,mods/Third_Age_3/data/animations/MTS2_Troll_Mace/MTW2_Mace_advance_to_combat_jog.cas,,not found
    19:04:24.934 [system.io] [warning] open: mods/Third_Age_3/data/animations/MTS2_Troll_Mace/MTW2_Mace_advance_to_combat_jog.cas is missing
    It can also do this for many other files of all sorts as well. It does not always show an error however, or may show something that doesn't relate, restarting your PC is necessary to resolve these. So maybe this battle crash problem has some similarities to the above random problem.
    Last edited by alreadyded; July 16, 2015 at 09:18 PM.

  9. #29
    Vifarc's Avatar Senator
    Join Date
    May 2009
    Location
    Grenoble, France
    Posts
    1,007

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Won't you ask saves? we should easily find some battles where we always crash:
    Playing Silvans, in my first encounter with spiders the battle always crash (after setting the units, at the begining once launched) even I reload many times.
    And there were no reinforcement.

    Other battles with some (same?) silvan units against same (IIRC) spider army it may not crash, I don't know why.
    Last edited by Vifarc; July 17, 2015 at 12:59 PM.
    > > Divide&Conquer submod user, playing Galadhrim'sRealm (Third Age mod). < <
    My small products here.

  10. #30
    Veteraan's Avatar TATW Local Moderator
    Join Date
    Jul 2013
    Location
    Tilburg, Kingdom of The Netherlands
    Posts
    3,000

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Of course some discussion about the problem is welcome here as it keeps everything neatly in one place. However I would like to stress to everybody who has not yet filed a report about their specs the importance of doing just that. There are not nearly enough reports posted yet to be able to draw some even remotely reliable conclusions from them.

    Every report is useful. Crashes or no crashes we need info on both. Especially reports from people having no crashes while running Windows 8 or 8.1 (probably 10 too) and those who do have crashes without running Windows 8 or 8.1 (probably 10 too).

    Come on, I'm sure we can do a lot better than the few (much appreciated) reports that have been posted thus far.

    Citizenised by Shankbot - Patron of b0Gia - House de Bodemloze

  11. #31
    Greymane's Avatar Senator
    Join Date
    Dec 2013
    Location
    Amsterdam, the Netherlands
    Posts
    1,076

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    - Crashes Yes/No: Only some with wolves. I believe them to be related to the version of Germanicu's AI that MOS uses, as the wolves crash only in specific places. Ents and Spiders have never crashed for me in over 2 years of playing TATW/MOS. The same goes for Mūmaks, Trolls, Sauron and pretty much everything else.

    - Windows version: Windows 7 64 home premium

    - CPU: Intel Core i3 530 2.93GHz

    - RAM (memory): 4 GB

    - Video card (GPU) : NVIDIA GeForce GT 220 1 GB

    - Video driver version:

    - Game shader version: 2

    - Additional info: Graphics always on the highest settings.

  12. #32

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Sorry for bumping this thread (I'm not sure it is actually a bump since it has only been about 10 days since the last post ) but I think I have great news for people with this problem. I downloaded TATW again today out of nostalgia and because it is one of the best mods ever made (period). However, my sweet nostalgia trip was soon disturbed by my first battle involving spiders. Time had faded away these memories of frustration regarding the spider crash but alas, it all came back to me in an instant during that first ctd... Deciding I wasn't going to let this ruin the game for me anymore I started reading through the forum and gathering information. I tried all possible fixes mentioned in every possible thread, but to no avail. (Lowered the graphical settings; deleted the maps.rwm in the right folders etc...) So I had decided to give up on the game again and just install MOS 1.7 and play some skirmishes. Nevertheless I couldn't withstand the temptation of trying to have a skirmish with spiders, ents and wargs with MOS 1.7 installed. Who knows, maybe something could have changed? I launched said custom battle and I was shocked! No CTD at first. This was nice, but this already had happened a few times in the past whereafter the game eventually did crash to desktop... That's why I continued playing with the knowledge that the battle could end abruptly at any given moment. But it didn't! I got smashed to pieces by the ents after finishing off the wargs and that was it! I repeated this three times with different amounts of spiders, different maps and different settings and I never got a crash again! So, while this might be a bit of premature conclusion and more testing is needed I think this might actually be a solution to this dreaded problem!

    PS: My specifications:

    - Windows Version: Windows 8.1 64-bit

    - CPU: Intel Core i7-4790K (4.00 GHz)

    - RAM : 16 GB (DDR 3)

    -Video Card (GPU): Nvidea GTX 780

    - Game Shader Version: 2

    - Additional Information: All settings maxed out, playing at a resolution of 1920x1080

  13. #33
    Veteraan's Avatar TATW Local Moderator
    Join Date
    Jul 2013
    Location
    Tilburg, Kingdom of The Netherlands
    Posts
    3,000

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Welcome to the forum nm4991.

    Answering after 10 days since the last activity does indeed qualify as a very light bump and is a far cry from necroing which is indeed frowned upon (heavily).
    This is not even a real bump since you make a very on topic post. I wish there were a lot of other people that would "bump" this thread the way you just did as we still have far to less info about the crashes.

    As for not having crashes with MOS 1.70 installed, I would say: Enjoy it while it lasts. I really hope you never have a crash again, but there have been cases of people having a run of non crashing games before. Sadly there are also a lot of reports from people playing MOS 1.70 who do have (a lot of) crashes. I myself did a lot of testing of this (being a MOS team member) with MOS and other mods but the crashes always returned.

    It would be interesting to see if you can successfully play a custom battle in MOS 1.70 with an army of 20 Ent units and see if that does not crash. If it doesn't a game of 20 Ent against 20 spider units would be most interesting. If you are willing to try it, please report back here about what happened.

    Citizenised by Shankbot - Patron of b0Gia - House de Bodemloze

  14. #34

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Well, I really wanted to go and "prove you wrong" telling you that I had an epic battle between 20 ent units and 20 spider units, but unfortunately you were right. Crashed immediately. Went at it for a second time, could have a glance at my army for about a second or two before I got the ctd. The third time I just got the ctd again...

    Now I have a question for you guys. Will this issue be solved if the game is played on a Windows 7 system? Because I am surely willing to get a dual boot. Honestly I find Windows 8.1 having no actual advantages to my pc usage as I don't use all the hip "apps" and such and also because I don't have a touch screen and I'm not planning on getting one very soon. Windows 10 only seems to be building on this kind of apple-ish system and I don't think all this "new functionality" is worth the loss of not being able to play TATW, with or without MOS that is.

    PS: Gee, do I feel stupid now. Thinking the problem was completely solved by downloading a submod thousands of people had already tested before I did

  15. #35
    Veteraan's Avatar TATW Local Moderator
    Join Date
    Jul 2013
    Location
    Tilburg, Kingdom of The Netherlands
    Posts
    3,000

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Don't ever feel stupid about trying to help.

    Windows 7. I really don't know if it would help. It is true however that everybody that reported crashes in this thread is on windows 8 or higher. It would be a very useful test to set up a dual boot to see if the crashes are there with Windows 7 as the hardware used in that scenario is exactly the same. So if you are willing to put in the effort even though it might not solve the problem that would be much appreciated. I currently lack the resources to do it myself.

    Of course it's up to you to decide, but if you try it please let us know what happened regardless of the outcome.

    Citizenised by Shankbot - Patron of b0Gia - House de Bodemloze

  16. #36

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    I happen to have 3 disks of which one is completely unused at the moment. So I will give it a shot and get back to you as soon as possible!

  17. #37
    Veteraan's Avatar TATW Local Moderator
    Join Date
    Jul 2013
    Location
    Tilburg, Kingdom of The Netherlands
    Posts
    3,000

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Quote Originally Posted by nm4991 View Post
    I happen to have 3 disks of which one is completely unused at the moment. So I will give it a shot and get back to you as soon as possible!
    Excellent, this may give us some insight. I don't expect a solution right away (far from) but depending on the outcome, it could narrow down the search for what causes the crashes quite a bit.

    Citizenised by Shankbot - Patron of b0Gia - House de Bodemloze

  18. #38

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Hi There,

    - Crashes Yes/No: Yes Wolves about 40% and spiders maybe 30% on prior mod builds

    - Windows version: Win 7 pro 64 bit sp1

    - CPU: AMD Phenom 2 960T 4X at 3.8 GHz

    - RAM (memory): 8 GB DDR2 on Gigabyte 790gp ud4h and 16 GB DDR3 on MSI 970 Gaming

    - Video card (GPU) : HD 7850 2 GB on the 790 mobo and GFX 970 4 GB on MSI 970 Gaming mobo

    - Video card (GPU) type and memory:

    - Video driver version: all radeon driver packages since 2010 and current Nvidia drivers for the 970 card

    - Game shader version: 2

    - Additional info: DX version up to date via MS update and address aware installed

    I ran some tests as it appears that Win 7 for others does not crash. I have admin rights, no UAC, no virtual store. All tests are huge unit size, grassy plain, gondor/arnor pikemen [5] vs. various mounted/animal units:
    DAC 0.5 custom battles using Mumakil [2]; Great Beasts [3]; and Blog's Champions [6]; no crashes for each vs. pikemen
    Dagor Ennor 9.4 with Quick fix: This is more involved given the number of creatures in the submod. Y is Young, A is Adult, M is Matriarch, P is Patriarch; S is small, L is large
    wolfhounds: S [5]; L [5]; S [5] and L [2]; no crashes for each vs. pikemen
    wolves: Y [5]; A [5]; P [3]; Y [5] and A [2]; Y [5] and P [2]; A[4] and P [1]; Y [4] and A [2] and P [1]; no crashes for each vs. pikemen
    wargs: Y [5]; A [5]; P [3]; Y [5] and A [2]; Y [5] and P [2]; A [4] and P [2]; Y [4] and A [2] and P [1]; no crashes for each vs. pikemen
    Spiders: Y [5]; A [5]; M [3]; Y [5] and A [2]; Y [5] amd P [2]; A [4] and P [2]; Y {4] and A [2] and P [1]; no crashes for each...
    No crashes for other mounts, Balrog, Mumakil, All four Ent types fighting pikemen.

    I really thought I'd get a crash as I have had two or three campaign crashes involving wolves in my most recent game of D.E. 9.4. Clearly there isn't a problem with these types in custom battle encounters. I hope this helps, Tyee.

  19. #39

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    I didn't manage to get Windows 7 installed. Apparently it's not exactly a cake-walk installing Windows 7 on a rig built for Windows 8.1 and up. (Everything runs fine until after a certain amount of time usb-ports stop working entirely in the Windows 7 environment... Don't know what's causing it...) I might go at it again tomorrow but till then I won't be able to give any usable information since I didn't even get to the point of being able to install Medieval Total War II, let alone TATW... And I see that Tyee also has issues and he's running Win 7 Professional 64 bit So I guess running Windows 7 doesn't fix the issue... Maybe it has something to do with 32-bit/64-bit architectural differences? I assume M2TW was built for 32-bit OS environments, so maybe that is part of the problem?

  20. #40
    Veteraan's Avatar TATW Local Moderator
    Join Date
    Jul 2013
    Location
    Tilburg, Kingdom of The Netherlands
    Posts
    3,000

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Quote Originally Posted by Tyee View Post
    Spoiler Alert, click show to read: 
    Hi There,

    - Crashes Yes/No: Yes Wolves about 40% and spiders maybe 30% on prior mod builds

    - Windows version: Win 7 pro 64 bit sp1

    - CPU: AMD Phenom 2 960T 4X at 3.8 GHz

    - RAM (memory): 8 GB DDR2 on Gigabyte 790gp ud4h and 16 GB DDR3 on MSI 970 Gaming

    - Video card (GPU) : HD 7850 2 GB on the 790 mobo and GFX 970 4 GB on MSI 970 Gaming mobo

    - Video card (GPU) type and memory:

    - Video driver version: all radeon driver packages since 2010 and current Nvidia drivers for the 970 card

    - Game shader version: 2

    - Additional info: DX version up to date via MS update and address aware installed

    I ran some tests as it appears that Win 7 for others does not crash. I have admin rights, no UAC, no virtual store. All tests are huge unit size, grassy plain, gondor/arnor pikemen [5] vs. various mounted/animal units:
    DAC 0.5 custom battles using Mumakil [2]; Great Beasts [3]; and Blog's Champions [6]; no crashes for each vs. pikemen
    Dagor Ennor 9.4 with Quick fix: This is more involved given the number of creatures in the submod. Y is Young, A is Adult, M is Matriarch, P is Patriarch; S is small, L is large
    wolfhounds: S [5]; L [5]; S [5] and L [2]; no crashes for each vs. pikemen
    wolves: Y [5]; A [5]; P [3]; Y [5] and A [2]; Y [5] and P [2]; A[4] and P [1]; Y [4] and A [2] and P [1]; no crashes for each vs. pikemen
    wargs: Y [5]; A [5]; P [3]; Y [5] and A [2]; Y [5] and P [2]; A [4] and P [2]; Y [4] and A [2] and P [1]; no crashes for each vs. pikemen
    Spiders: Y [5]; A [5]; M [3]; Y [5] and A [2]; Y [5] amd P [2]; A [4] and P [2]; Y {4] and A [2] and P [1]; no crashes for each...
    No crashes for other mounts, Balrog, Mumakil, All four Ent types fighting pikemen.

    I really thought I'd get a crash as I have had two or three campaign crashes involving wolves in my most recent game of D.E. 9.4. Clearly there isn't a problem with these types in custom battle encounters. I hope this helps, Tyee.
    Thanks, that is a lot of info.

    In TATW and it's submods only Ents, Spiders and Wolves regularly crash for a part of the players. These 3 units are all based on the same model. So Mumakil, Balrogs and other mounts should not cause problems for anybody.

    I don't know what model is used for the DAC units "Great Beasts" and "Blog's Champions", perhaps someone who does can tell if they share the same base model as Ents, Spiders and Wolves.

    Perhaps alreadyded can shed some light on your Dagor Ennor results. I suspect at least the Ent types should have crashed if you would have the crash problem that is described here. Perhaps you can test the Ents with a full stack (20 units) of them in battle. Preferably in vanilla TATW if you have that available.
    Quote Originally Posted by nm4991 View Post
    I didn't manage to get Windows 7 installed. Apparently it's not exactly a cake-walk installing Windows 7 on a rig built for Windows 8.1 and up. (Everything runs fine until after a certain amount of time usb-ports stop working entirely in the Windows 7 environment... Don't know what's causing it...) I might go at it again tomorrow but till then I won't be able to give any usable information since I didn't even get to the point of being able to install Medieval Total War II, let alone TATW... And I see that Tyee also has issues and he's running Win 7 Professional 64 bit So I guess running Windows 7 doesn't fix the issue... Maybe it has something to do with 32-bit/64-bit architectural differences? I assume M2TW was built for 32-bit OS environments, so maybe that is part of the problem?
    Thanks for trying.
    It seems Tyees results are a bit "inconclusive", at least to me.
    Therefore it would still be very useful to see this tested on a dual boot as it will give us a result for two different Windows versions on exactly the same hardware. But if you can't get it to work properly than leave it. I would hate to see you ruining your main setup because of this.
    Last edited by Veteraan; July 31, 2015 at 05:17 AM.

    Citizenised by Shankbot - Patron of b0Gia - House de Bodemloze

Page 2 of 9 FirstFirst 1 2 3 4 5 6 7 8 9 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •