Page 9 of 10 FirstFirst 1 2 3 4 5 6 7 8 9 10 LastLast
Results 161 to 180 of 189

Thread: Discussion about the ents, spiders and wolves crashes.

  1. #161

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    I wonder if it's being caused by my use of .iso files ('virtual disks') for mtw2, which I made a few years ago when my disks got too scratched up to use. I never used to have spider/wolf etc ctds when I played MOS a few years ago, although I do have a completely new system now (also a laptop vs desktop previously).

    - Crashes Yes/No: Yes

    - Windows version: Windows 10 Pro 64-bit

    - CPU: Intel i7-4710HQ 2.5ghz

    - RAM (memory): 8 GB DDR3 1600 MHz

    - Video card (GPU): AMD Radeon

    - Video card (GPU) type and memory: R9 M265X

    - Video driver version: 16.7.3

    - Game shader version: not sure

    - Additional info:
    It's usually the 'unspecified error' CTD, but sometimes I just get a run of the mill no error and black screen CTD. I've just installed MOS and I'm getting wolves CTD - but only on the battle map. In Vanilla 3.2 I got spider CTDs in the third age campaign (only on the battle map) but I can play against spiders in custom battles perfectly (yet to try this with wolves in MOS). haven't had any problems with Ents or Balrogs yet!

  2. #162
    alreadyded's Avatar Work up a #6 on 'em!
    Join Date
    Mar 2009
    Location
    Stayin' Alive
    Posts
    3,108

    Default Re: We need your help in collecting data about the ents, spiders and wolves crashes! please read the first post of this thread before replying

    Really no point in posting in this thread anymore, I already tried to get people to test specific things so I could easily figure out what needs fixing and no one cared. Literally zero feedback from my request and the feedback you guys are all posting here is completely useless and already known. It has been known for a long while that it crashes for people with vista/8+, no point in reporting it if no one cares to find out why. I am just gonna unsubscribe to this thread though, you guys can carry on if you wish.

  3. #163

    Default Re: Discussion about the ents, spiders and wolves crashes.

    Sorry bud I'm afraid I missed your second suggestion about testing the dragons in your mod. ...I saw the long quoted paragraph and just kept scrolling. I've run out of data but when I get a chance ill dl pcp and have a go.

  4. #164

    Default Re: Discussion about the ents, spiders and wolves crashes.

    I know it seems that you've all but given up, but I have some information that may or may not be of use. I was crashing on Sauron on W10, 3.2 with Alternative Patch 4.8, and while I couldn't get it to work on my gaming PC I moved my save to another computer which has exactly the same installation of TATW on.... and it worked. Weirdly, I got some graphical bugs when I zoomed in on Sauron (on the working PC) and it appeared that an Orc (I think the general of the Sauron unit) was fighting as if standing on my screen towards the top (so I was looking up his shorts - if that makes sense). It kind of flickered in and out like an artefact and went away and came back relatively randomly when I was looking at Sauron but I definitely didn't get that on the gaming pc. My suspicion is that this was causing the crash before it showed.

    Anyway, I'll subscribe to this thread in case any of you want more information.
    Last edited by Mackey18; November 15, 2016 at 04:59 PM.

  5. #165
    alreadyded's Avatar Work up a #6 on 'em!
    Join Date
    Mar 2009
    Location
    Stayin' Alive
    Posts
    3,108

    Default Re: Discussion about the ents, spiders and wolves crashes.

    Fix it yo self.

    maybe? That is what I did.

    If different people try different settings you should get it figured out fast which works best.


    Edit;

    You can also try removing them all by putting a ; in front with replace all, but the scripts will not work the same. I would try 0.4 and 0.8 first myself. Setting it too low could mess with how the BAI functions on the battlefield, the timers are there for a reason. Why is not worth my time explaining and the script is far too large for me to know how it all works myself.


    Edit2; I just remembered, vanilla TATW BAI is different than mine. Do a search for battle_wait to make sure you are getting them all when you do replace all. In my BAI they all use the same number and I think there are ~840 if I remember right. I haven't messed with it in years and I doubt I was sober at the time so I could be wrong. Sounds legit though.
    Last edited by alreadyded; March 02, 2017 at 07:34 PM.

  6. #166

    Default Re: Discussion about the ents, spiders and wolves crashes.

    Quote Originally Posted by alreadyded View Post
    Fix it yo self.

    maybe? That is what I did.
    It worked, amazing, thanks a lot! But I changed all the battle_wait to 0.4, some where at 30, others at 6 or so on. Which ones should i change, I might have not understood your instructions correctly and thus broken the whole script. Can i just use the modified script only when there are ents or spiders involved, is it save compatible? Also should i have the advisor disabled or enabled?

  7. #167

    Default Re: Discussion about the ents, spiders and wolves crashes.

    Actually, i just crashed again, with the new script, on the same battle :|

  8. #168
    atthias's Avatar Citizen
    Join Date
    Mar 2013
    Location
    the netherlands
    Posts
    2,577

    Default Re: Discussion about the ents, spiders and wolves crashes.

    @ moddders can this solve the problem
    http://www.twcenter.net/forums/showt...1#post15287945
    Total War - Rise of Mordor

    Are you a 3D Environment and Character artist, or a Character Animator?
    If yes, then the Rise of Mordor team linked above is looking for you!

    DO you want some uints back in MOS 1.7 then install this mod http://www.twcenter.net/forums/showt...n-1-1-RELEASED
    it adds back units who are deleted from campaing in MOS 1.7
    namely the Winged swordsmen the Citadel guard archers and the gondor dismounted bodyguard.

    under the proud patronage of Frunk of the house of Siblesz

  9. #169
    Veteraan's Avatar TATW Local Moderator
    Citizen

    Join Date
    Jul 2013
    Location
    Tilburg, Kingdom of The Netherlands
    Posts
    3,068

    Default Re: Discussion about the ents, spiders and wolves crashes.

    Quote Originally Posted by atthias View Post
    @ moddders can this solve the problem
    http://www.twcenter.net/forums/showt...1#post15287945
    I doubt that and IMO that is a much too firm statement to make at this point. If that really was the single cause of the crashes, everybody would experience them. That is the same reason I think alreadyded's proposed battle AI fixes won't solve this (and the fact that we tested without the battle AI working when we tried to solve the problem in the DCI:LA team). Unless there is a second factor at play, like a particular combination of hard and/or software that causes the problem together with what is written in the post you refer to. If that is the case, looking at the (and editing) the "Bounding Spheres" might help. However, Zarathos states that he thinks that 99,9% of the current models have wrong Bounding Spheres, which to me makes it unlikely that only a few Elephant based models for a part of the players cause problems.
    Spoiler Alert, click show to read: 
    Quote Originally Posted by Zarathos View Post
    After discovering how bounding spheres are calculated for M2TW meshes (a variant of the Ritter's algorithm), I can now say for sure that 99,9% of the custom models created to this day have wrong enclosures that can potentially lead to one or more of the above listed problems. Since creating custom models for M2TW became possible, modelers started using ready-made values for their new models taken from existing Vanilla M2TW units (from a similar archer's model for a new archer unit, from a similar pikeman's model for a new pikeman unit and so on)... an approach that was probably enough to obtain a working bounding sphere, but that was also producing bounding spheres completely unrelated to the real models themselves.

    Personally, I think it's most likely that a certain combination of hard and software and/or (Windows) settings on its own is the culprit. Finding that should point to a solution, but it proves very difficult to do. AFAIK nobody has a clue about this.

    A solution which will probably work for sure is that somebody makes new Ents (and Wolves and Spiders), not based on the "Elephant" models. Műmakil, Sauron and the Balrog don't seem to crash much. There aren't that many people around that have the skills to pull that off though and they probably are quite busy doing other stuff.
    Last edited by Veteraan; April 01, 2017 at 07:03 AM.

    Citizenised by Shankbot - Patron of b0Gia - House de Bodemloze

  10. #170
    alreadyded's Avatar Work up a #6 on 'em!
    Join Date
    Mar 2009
    Location
    Stayin' Alive
    Posts
    3,108

    Default Re: Discussion about the ents, spiders and wolves crashes.

    The mount units have their own bounding spheres, that is not the problem for my units. Also that would not cause a crash from what I know, and it would cause crashes for everyone regardless of windows version. That is what I think anyway.

    The problem according to G5 was that too many mounts in relation to non-mounts in an army can cause a random ctd (most likely caused by animations code I think not the animations themselves which I have never seen cause a ctd). These battle wait timers cause additional strain, and this is probably causes crashes in vista/8+. So reducing this additional strain should make the problem go away, perhaps I should have said make it go away and no fix it.

    I did fix so really nasty coding bugs with mounts for TATW back when KK was still around, I haven't had the chance to look them over again yet though.
    Last edited by alreadyded; April 01, 2017 at 02:18 PM.

  11. #171

    Default Re: Discussion about the ents, spiders and wolves crashes.

    I believe i found the source of the crashes, at least for me

    I do not know if this situation was reported before, but here it is ::: every time I select ents and they are on my screen, my game crashes. If i select them outside of my field of view, everything is just fine. Hope it helps at something.

  12. #172

    Default Re: Discussion about the ents, spiders and wolves crashes.

    UPDATE, nevermind, just had a crash with ents deselected (

  13. #173
    alreadyded's Avatar Work up a #6 on 'em!
    Join Date
    Mar 2009
    Location
    Stayin' Alive
    Posts
    3,108

    Default Re: Discussion about the ents, spiders and wolves crashes.

    From what I remember not moving the screen or clicking/pushing anything for the first 3-5 seconds reduces the chances it will crash, or it did for me back before I fixed it.

    You should start by replacing all of the battle_wait settings for basic testing (only one or two timers under one script condition will actually be used at the start but unless you know which condition matches the battle you chose just do them all to make sure). I only ever had to change them all to the same number so you shouldn't have to change them to various numbers. Editing the campaign script is not saved game compatible, it is best to test it with the custom battle script to do lots of testing in a short time. I don't think you even need to restart the game, just change the script before starting another custom battle.


    Edit; do not PM me questions, ask in public so others can see the discussion.
    Last edited by alreadyded; April 05, 2017 at 10:53 PM.

  14. #174
    alreadyded's Avatar Work up a #6 on 'em!
    Join Date
    Mar 2009
    Location
    Stayin' Alive
    Posts
    3,108

    Default Re: Discussion about the ents, spiders and wolves crashes.

    It could be something as simple as you guys with vista/8+ not turning UAC off all the way. TRY THIS. This will only help though at best, the BAI timers will still need to be redone as far as I know, I had to redo them anyway.

  15. #175
    alreadyded's Avatar Work up a #6 on 'em!
    Join Date
    Mar 2009
    Location
    Stayin' Alive
    Posts
    3,108

    Default Re: Discussion about the ents, spiders and wolves crashes.

    z3n's BAI seems to be working just fine with Vista/8+. And I got G5's BAI to at least load the battle in vanilla TATW, before it crashed before loading on Win 8.1 in vanilla. My mod loaded the battle then crashed after start battle but the G5 BAI is way more up to date and also tweaked quite a bit so it works a lot better than vanilla's.

  16. #176

    Default Re: Discussion about the ents, spiders and wolves crashes.

    I'm having a bit of a problem with this. I run Windows 10, so I get crashes with spider units. Playing a Gondor campaign, I followed the steps in the original post to remove the spider units, as I kept crashing in a siege battle at Minas Tirith. I was up against three stacks, two of which were Harad, and strategically placing some wooden stakes inside the gate with a few units of pikemen and Lossarnach axemen absolutely slaughtered the Harad cavalry and generals, leaving only a few troll units and orcs storming the gate and seven or eight units of Trollmen easily dispatched by my faithful Gondor Infantry on the walls. Heavily outnumbered, it was still a very, very one sided battle, but the Mordor stack had ONE SINGLE unit of spiders that would hang back until the rest of the three armies was routing then, the second the spiders began to move, I would get a CTD. Three battles in a row! Once I removed the spiders, it was a smooth, easy battle in which I drove them to the river. Finish campaign, blah blah blah, no problems. But, I tried to stat a campaign as Rhun and I got a CTD right at the beginning of the new campaign. I tried a few new campaigns with different factions and they all immediately had a CTD. I copied my old unit files over the files from which I had removed the spiders, and things ran smoothly again. I doubt I'll have a problem, as I'm playing an evil faction and simply won't hire any spiders in Mirkwood, but does anyone know why the game would crash on startup with the removal of the spiders? Would it be an issue of scripted armies or generals not having the unit available, as required by script? Since there is a console command to add units to armies or settlements, is there a command to remove a specific unit in the same manner?

  17. #177

    Default Re: Discussion about the ents, spiders and wolves crashes.

    The first thing I'd do is open up the campaign script, descr_strat, the mercenary file (I forget what it's called off-hand), and the EDB and see if the spiders are referenced in there anywhere. If they are, that's probably why you get a CTD. Blotting a unit of the EDU but leaving it in everywhere else is just asking for trouble. If the game goes looking for it but it doesn't exist it's going to have some kind of aneurism or other about it. I can't say I remember offhand what kind though.

  18. #178

    Default Re: Discussion about the ents, spiders and wolves crashes.

    Hi everyone,

    Long time player, long time lurker and non poster. Been years since I've posted in these boards.

    I may have discovered a solution which has worked for me. I'll list off some specs and windows version first.

    Windows 10 64bit, i7 2600k , 16gb DDR3 ram, Nvidia 1080ti (ask if you need more detail)
    Running disk version of M2TW2 and kingdom plus running 1.5 patch.
    Running Third age 3.2 and MOS 1.7 (lastest version)
    *most my ingame settings are set quite high, i've not reduced ingame settings by much just shadows to medium*

    Anyway I was getting constant crashes with spiders ents etc and I have attempted every solution to get this working, (disable daylights, disable UAC,assigned ownership of the med2 folder, basically read any topic about this issue) nothing worked. I have attempted hours on hours attempting different solutions using custom battles to see if there is a crash. What I last tried was the following;

    *note* I have no idea which of these worked but these are the last three things I attempted after my last crash*
    1. (Like previously advised) I moved the entire M2TW folder outside program files so it sit at the top of my hard drive
    2. For both Kingdoms.exe and medieval2.exe I clicked "Change settings for all users" in the compatibility tab, set it to in Win98/ME, ticked "override high DPI Scaling" selected "system" in the drop down box, ticked "disable full screen optimizations" and ticked "run as administator"
    3. This is the interesting bit and the solution I think worked, when I looked at the "Medieval II Total War" folder it was set as "read only", I unticked this and allowed it to apply to all the folder and subfolders.

    Then I launched the game and attempted multiple custom battles. Now please note every time I attempted this over the pasty few days it always crashed regardless of map with spiders and Ents on custom battle. I started small a unit each, no crash. upped the number again no crash. Finally I threw a full team of spiders vs Ents and it didn't crash could not believe it.

    Now this may be a fluke or it may be something else I did in conjunction with the above but if this fixes the crashing issue for anyone using windows 10 give it a go. It may not work i'm going to try and keep testing on my end.

    I'll try and keep and eye on this thread if you have questions.

    *edit1*,Launched and quit out multiple times each time testing a match full stack of spiders vs full stack of Ents, slow down but no crash I left each battle play out, look at both armies, zoom and pan the camera and it's stable

    *edit2* Just tested a full match spiders vs wolves both full stacks zero crash and stable

    *edit3* Sauron leading a full stack of spiders vs full stack of Ents, zero crashes in custom battles. I am 100% satisfied my battles with these units are now stable.
    I have just tested removing the compatibility settings I did above, detailed in point 2, crashes returned. It seems applying for all users is essential.

    *Final edit* Let a full battle play out 100% stable. Word of warning however, alt tabbing during one of these battles will still crash the game. Perhaps this has something to do with DPI Scaling on the system? I'm not sure, all I know is I can have full battles with lots of these "cursed crashy units" so I'm happy. I hope this points others in the right direction.

    It's important to note, this has not stopped all my crashed the random ones, but has dropped the rate of critical crashes using known problem units considerably.
    Last edited by El-Vi-Riachi; October 14, 2017 at 07:59 AM.

  19. #179
    Ngugi's Avatar Circle of Zerthimon
    Citizen

    Join Date
    Jan 2011
    Location
    Sweden
    Posts
    9,784

    Default Re: Discussion about the ents, spiders and wolves crashes.

    Interesting find, EVR,

    anyone with issues who might try this out?

    Kingdom of Khazad-dűm preview video out



    DCI: Last Alliance
    - WIP Second Age mod
    | DCI: T˘l Acharn - mighty D˙nedain Counter Invasions |
    Additional Mercenary Minimod - more mercs; for TATW and DCI |Family Tree minimods - lore improvements | Remade Event Pictures - enhance cultures trough images |
    Favorite TATW compilation: Withwnars Submod Collection

    The Sundering
    - a M2 Warhammer Total War experience


    Patron of Mank, Kiliš Alý, FireFreak111, MIKEGOLF & Arachir Galudirithon

  20. #180

    Default Re: Discussion about the ents, spiders and wolves crashes.

    Quote Originally Posted by Ngugi View Post
    Interesting find, EVR,

    anyone with issues who might try this out?
    Thanks, I don't want to get anyone's hopes up but this is working for me after days of frustration trying to find a solution. I'm about to test a match of Sauron leading a full army of spiders against Ents then wolves. Is there other units that cause crashes? Those seem to be the primary culprits. I didn't want to just keep playing so thought sharing may help other.

    *Edit* i've updated my original post, tested multiple battles which should normally crash for me and no problems, fully stable. Really hope this works for others.
    Last edited by El-Vi-Riachi; October 14, 2017 at 07:32 AM.

Page 9 of 10 FirstFirst 1 2 3 4 5 6 7 8 9 10 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •