Page 2 of 6 FirstFirst 1 2 3 4 5 6 LastLast
Results 21 to 40 of 107

Thread: New Steam Update + "fix for mods"

  1. #21
    vin2579's Avatar Civis
    Join Date
    Nov 2013
    Location
    The Planet Earth
    Posts
    142

    Default Re: New Steam Update + "fix for mods"

    Quote Originally Posted by Darksaber11 View Post
    Has anyone else experienced this issue and found a fix for it?
    I have had this happen a fair deal of times in my hundreds of hours playing SS, most often simply restarting SS and loading back up the battle works and it doesn't crash.

    If you have not already make sure you are using Melooo's incredible bug fixing patch that gets rid of that one bug where SS crashes when 3 armies try to fight on one map.

  2. #22

    Default Re: New Steam Update + "fix for mods"

    I hope that this patch (01/08/2014)



    doesn't mess up anything. Although apparently it's just for sound issues..

  3. #23

    Default Re: New Steam Update + "fix for mods"

    I had the same 1.2gb patch appear in my Steam



    not trusting them

  4. #24

    Default Re: New Steam Update + "fix for mods"

    I think I've got the BAI switcher working again:

    I was able to restore the old kingdoms.exe 1.50 using the Windows Restore Point feature. What I did was to copy medieval2.exe 1.51 to kingdoms.exe, then right-click it on Windows Explorer, then Properties->Previous Versions. There I selected the oldest version, clicked copy and a dialog opens to choose where to save it to. Save it to the root M2TW directory.

    I then ran the SS Launcher, and it kept running in the background, contrary to what is happening with the 1.51 exe. So the BAI switcher is supposedly working.

    Steam integration won't work with the 1.50 exe, so multiplayer is a no-no.

    This needs more testing to check if the Vanilla and Kingdoms merger won't break anything else with the 1.50 exe.

    Gotta backup this old exe in multiple storages (internet, pendrive, etc), for it is holy.

  5. #25

    Default Re: New Steam Update + "fix for mods"

    Guys could someone help me?

    I have installed SS every which way im dizzy.I cannot get it to work,crash while loading up.

    Im on win 7, DO NOT have kingdoms,and am using version 3.0 as i heard thats compatible with vannilla M2TW.

    I get the error,an unnexpected error occured,medieval will exit now.

    I have tried the steps mentioned here,but they dont apply to me i think as my version is different.Has anyone got info to help?Otherwise il have to drop this game

  6. #26

    Default Re: New Steam Update + "fix for mods"

    Quote Originally Posted by redarmy1945ura View Post
    Guys could someone help me?

    I have installed SS every which way im dizzy.I cannot get it to work,crash while loading up.

    Im on win 7, DO NOT have kingdoms,and am using version 3.0 as i heard thats compatible with vannilla M2TW.

    I get the error,an unnexpected error occured,medieval will exit now.

    I have tried the steps mentioned here,but they dont apply to me i think as my version is different.Has anyone got info to help?Otherwise il have to drop this game
    You need Kingdoms for SS to work I think.

  7. #27

    Default Re: New Steam Update + "fix for mods"

    CA is always there to the modding community.

  8. #28

    Default Re: New Steam Update + "fix for mods"

    Please, this is unrelated, but i need a quick answer. People are not answering me in the proper threads.

    In my pc the Stainless steel 6.4 intro cutscenes (both the initial intro and the faction intro) do not seem to be working properly. The cutscenes regarding unit actions (ex; assassination missions) are still working normallly though. I worry about the possibility of this making other cutscenes in the game not work as they should.

    ->So, what im asking is if this (not having campaign and game intro) is normal in stainless steel 6.4.

    I have both 6.3 and 6.4 versions intalled in order. I also do have the Gem mod and steel crescent mods installed. steel crescent being also installed in order.

  9. #29

    Default Re: New Steam Update + "fix for mods"

    Not for version 3 or 4 or below i read.Please guys i used to use darthmod and CAs recent patch messed it all up.I live in china and am unable to purchase kingdoms via steam because of that.

    If you guys cant help get this old version of SS to work my M2TW days are done.

  10. #30

    Default Re: New Steam Update + "fix for mods"

    Ok please help me. I have SS6.4 installed in the mod folder of mtw2 and I have used all the steps I have found here to get it running. the game finally launches (which is a massive improvement from before) but as it opens open the flash screen saying SS 6.4 it just drops back to desktop and closes the game. It does not say anything about failing or that it stopped working, its almost as if the launcher runs but the only thing that it runs is that brief screen with the knight staring at the player.

  11. #31

    Default Re: New Steam Update + "fix for mods"

    you'll have to give more detailed info, like which OS do you have, installation dir, etc

  12. #32

    Default Re: New Steam Update + "fix for mods"

    Is this even needed anymore? I did a clean install of everything; medieval 2 and then SS 6.4 and have no issues. All I did was copy medieval.exe and rename the copy kingdoms.

    The only issues I have are unhandled exceptions that have been random. So I can't completely chalk that up to the update.

  13. #33

    Default Re: New Steam Update + "fix for mods"

    This is related to the steam issues, for solving the strings.bin not generating and causing the mod to use vanilla M2 strings.
    Quote Originally Posted by Melooo182 View Post
    Ok well in short the fix for this would be to get this launcher
    And do the following every time after you use the SS_setup.exe:
    - Launch Stainless Steel with v1c7r1x's launcher once, so it can recreate the missing strings.bin
    - Exit the game.
    - Launch Stainless Steel from it's own launcher (SS_launcher.exe) and play.
    Remember that everytime you activate/deactivate submods, change campaign era, etc using the SS_setup.exe
    you'll have to repeat the process above

    Alternatively you can extract these Attachment 313230 to the "...\SS6.3\data\text" folder after each time you use the SS_setup.exe

  14. #34

    Default Re: New Steam Update + "fix for mods"

    How can I know that the submods I selected arent working properly?
    I'm using the "rename to americas" folder solution, no bug, no nothing, what can/do I miss exactly?


    The solution you all propose confuse me and seem complicated, I want a bit more information before trying.

  15. #35

    Default Re: New Steam Update + "fix for mods"

    The solution you all propose confuse me and seem complicated, I want a bit more information before trying.
    blame CA and/or Valve for breaking the game in 1st place.
    since when running a batch file is complicated? xD

    With the modfolder rename method, you miss:
    - BAI swapper, randomizes Battle AI stances and stuff
    - random main menu music
    - some steam auto detect and optimization functions (what makes vin2579's solution work)
    - default.cfg autoconfig for things as borderless window etc
    - dunno if something else, I've not found in the forum what is exactly embedded in the launcher.

    Strings.bin issue solution is still half made, i just shortened what another forum member posted elsewhere...if you don't want to try it, that's your decision.
    AFAIK any submods that make use of the SS_setup.exe needs it, as the strings.bin are wiped for being regenerated with any possible change, even if none.
    Disc version does the regeneration fine, and so did steam version (pre multiplayer update) apparently through the launcher.exe...however since that update that ditched the launcher and merged kingdoms.exe into medieval2.exe, it fails to regenerate some of these strings.bin.

  16. #36
    High Fist's Avatar Vicarius
    Join Date
    Feb 2013
    Location
    Cavan, Ireland
    Posts
    2,943

    Default Re: New Steam Update + "fix for mods"

    Windowed mode still ain't working for me, and I did both those things that were suggested.

    What do the lines in your default.cfg file read as? Mine read:
    #windowed=false
    #borderless_windowed=false

    I've changed it any number of times but it hasn't got it as flawless as it was before. Best I could do was make it borderless, but the taskbar remained at the bottom of the screen.
    The only self-discipline you need is to finish what you sta-

  17. #37

    Default Re: New Steam Update + "fix for mods"

    The # at the begining of the line disables the function, remove it and change false to true
    the SS_launcher is supposed to that automatically though, also check that the specified screen resolution is the same as your desktop one.

  18. #38
    High Fist's Avatar Vicarius
    Join Date
    Feb 2013
    Location
    Cavan, Ireland
    Posts
    2,943

    Default Re: New Steam Update + "fix for mods"

    Quote Originally Posted by Melooo182 View Post
    check that the specified screen resolution is the same as your desktop one.
    That must be it because the resolution was reset after the update as well. Thanks man, +1.
    The only self-discipline you need is to finish what you sta-

  19. #39

    Default Re: New Steam Update + "fix for mods"

    Used the "copy med2 launcher - rename to kingdom" trick and its working fine.

  20. #40

    Default Steam

    I recently reinstalled steam and mIItw, but there's an issue. The old steam fix offered by SS is to mess with the extensions and launch options: http://www.twcenter.net/forums/showt...59#post7808159

    Unfortunately now there is only one exe that says medieval2. So, in light of this, I don't know how to run SS with steam. Any suggestions?

Page 2 of 6 FirstFirst 1 2 3 4 5 6 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •