Results 1 to 11 of 11

Thread: My empire total war is running slow?

  1. #1
    Yari-hei
    Join Date
    Dec 2009
    Posts
    129
    Tournaments Joined
    0
    Tournaments Won
    0

    Default My empire total war is running slow?

    Hey my empire total war is running slow even on medium/low setting and small battles and i dont know why here are my pc specs (more than good enough to run empire total war)

    2.1 GHZ Quad core processor
    4GB DDR2 Ram
    640GB Hard drive

    can anyone help me?

  2. #2
    Yari-hei
    Join Date
    Dec 2009
    Posts
    129
    Tournaments Joined
    0
    Tournaments Won
    0

    Default Re: My empire total war is running slow?

    oh and i have a 256 GB graphics card

  3. #3
    Princeps
    Join Date
    May 2009
    Posts
    1,051
    Tournaments Joined
    0
    Tournaments Won
    0

    Default Re: My empire total war is running slow?

    i have no idea what the problem is.

    maybe go to techservice so you can show everyone your awesome 256 GB video card
    Quote Originally Posted by Jean=A=Luc View Post
    What the hell is wrong with you people?

  4. #4
    OldCrowWhiskey's Avatar Kirā
    Join Date
    Mar 2009
    Posts
    268
    Tournaments Joined
    0
    Tournaments Won
    0

    Default Re: My empire total war is running slow?

    Quote Originally Posted by dan1993uk View Post
    oh and i have a 256 GB graphics card
    what exactly is the graphics card? 256mb doesn't really tell us anything except that it's probably a low end card. With a card like that you're not going to be pushing any high settings. What resolution are you using? A high resolution will tax your card.

    What settings are you using? If you're using the special effects (check boxes) those can slow down performance, especially v-sync. AA will do a number on a low-mid range graphics card so you'll want to turn that off. I would recommend maybe using all medium settings, dx9, and no extra eye candy. A better graphics card would go a long way. I have a 2.8ghz dual core AMD & 4gb ram (a mid-low end system on its own) with a GTX 260 strapped to it and I run high-very high settings with some extras.
    Last edited by OldCrowWhiskey; December 28, 2009 at 11:37 AM.

  5. #5
    Bloodzen's Avatar Pietsch
    Join Date
    Mar 2009
    Location
    Ireland
    Posts
    547
    Tournaments Joined
    0
    Tournaments Won
    0

    Default Re: My empire total war is running slow?

    Quote Originally Posted by eugenioso View Post
    i have no idea what the problem is.

    maybe go to techservice so you can show everyone your awesome 256 GB video card
    Go easy on the guy,not everybody's a tech geek like you

    Its more than likely your graphics card mate,you at least need a 512mb card for Empire to play it properly

  6. #6
    Oberbefehlshaber's Avatar Princeps
    Join Date
    Mar 2008
    Posts
    1,070
    Tournaments Joined
    0
    Tournaments Won
    0

    Default Re: My empire total war is running slow?

    Its your card. Period. Your processor could be better, but it deffinetly your card.

  7. #7
    Yari-hei
    Join Date
    Dec 2009
    Posts
    129
    Tournaments Joined
    0
    Tournaments Won
    0

    Default Re: My empire total war is running slow?

    Quote Originally Posted by OldCrowWhiskey View Post
    what exactly is the graphics card? 256mb doesn't really tell us anything except that it's probably a low end card. With a card like that you're not going to be pushing any high settings. What resolution are you using? A high resolution will tax your card.

    What settings are you using? If you're using the special effects (check boxes) those can slow down performance, especially v-sync. AA will do a number on a low-mid range graphics card so you'll want to turn that off. I would recommend maybe using all medium settings, dx9, and no extra eye candy. A better graphics card would go a long way. I have a 2.8ghz dual core AMD & 4gb ram (a mid-low end system on its own) with a GTX 260 strapped to it and I run high-very high settings with some extras.
    im using the 1024 x what ever and its an nvidia graphics card

  8. #8
    OldCrowWhiskey's Avatar Kirā
    Join Date
    Mar 2009
    Posts
    268
    Tournaments Joined
    0
    Tournaments Won
    0

    Default Re: My empire total war is running slow?

    Quote Originally Posted by dan1993uk View Post
    im using the 1024 x what ever and its an nvidia graphics card
    Ok well refer to my post above for tips on adjusting the settings to get better performance but don't expect to get very far.

    In reality you'll want to consider getting a new gfx card. We'll assume you have a pci express slot. Here's a mid range card that won't break the bank (nvidia gts 250): http://www.newegg.com/Product/Produc...ts+250&x=0&y=0

    If you want to get a new gfx card under $100 a 9800GT should do the trick.
    Last edited by OldCrowWhiskey; December 28, 2009 at 12:06 PM.

  9. #9
    Princeps
    Join Date
    May 2009
    Posts
    1,051
    Tournaments Joined
    0
    Tournaments Won
    0

    Default Re: My empire total war is running slow?

    [SPOILER]oh and i have a 256 GB graphics card [/SPOILER]

    a 256 GIGABYTE card?

    thats why i was so... harsh
    Quote Originally Posted by Jean=A=Luc View Post
    What the hell is wrong with you people?

  10. #10
    TheFirstONeill's Avatar Father of Thera
    Join Date
    May 2007
    Location
    Knutsford Cheshire, England
    Posts
    16,204
    Tournaments Joined
    0
    Tournaments Won
    0

    Default Re: My empire total war is running slow?

    moved to tech help

    House of Wilpuri :By the Patronage of Elrond: Patron of Caki : Aduellist : Borissomeone
    Proud Creator of Thera, Legacy of the Great Torment: Opifex :

  11. #11
    Yari-hei
    Join Date
    Dec 2009
    Posts
    129
    Tournaments Joined
    0
    Tournaments Won
    0

    Default Re: My empire total war is running slow?

    Quote Originally Posted by eugenioso View Post
    [SPOILER]oh and i have a 256 GB graphics card [/SPOILER]

    a 256 GIGABYTE card?

    thats why i was so... harsh
    you know i meant MB...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •