Page 1 of 2 1 2 LastLast
Results 1 to 20 of 32

Thread: Steam

  1. #1

    Default Steam

    Anyone have any idea how to get this to work for a steam version? I feel like an idiot for buying it. I didnt even stop to think about modding problems. Help is much appreciated, i was waiting eagerly to play 5.0

  2. #2

    Default Re: Steam

    Quote Originally Posted by Dingler View Post
    Anyone have any idea how to get this to work for a steam version? I feel like an idiot for buying it. I didnt even stop to think about modding problems. Help is much appreciated, i was waiting eagerly to play 5.0

    same here man, cant figure out what the problem is.

  3. #3

    Default Re: Steam

    I am also having problems just launching the game... with Deus Lo Vult 5.0 and past I could not play with steam either, I hope this can be resolved...

  4. #4

    Default Re: Steam

    Hey i found this page after lookin in technical support. Im doing what it says now..we'll see if it works..try it out.

    http://www.twcenter.net/forums/showt...ighlight=steam

  5. #5

    Default Re: Steam

    Hm, so that didnt help me at all sorry. Still need desperate help for this problem...last resort is buying the hard copy like i should have done in the first place

  6. #6

    Default Re: Steam

    No there has to be a fix Steam guarantees all 3rd party mods to work with it. Anyways I got it to launch then I got a german ctd my log says this


    18:17:44.703 [system.rpt] [always] CPU: SSE2
    18:17:44.703 [system.rpt] [always] ==== system log start, build date: Jun 25 2007 version bld-medieval2-update2.1-30 (43169) ===
    18:17:44.718 [system.io] [always] mounted pack packs/data_0.pack
    18:17:44.718 [system.io] [always] mounted pack packs/data_1.pack
    18:17:44.718 [system.io] [always] mounted pack packs/data_2.pack
    18:17:44.718 [system.io] [always] mounted pack packs/data_3.pack
    18:17:44.734 [system.io] [always] mounted pack packs/data_4.pack
    18:17:44.734 [system.io] [always] mounted pack packs/localized.pack
    18:17:45.718 [system.io] [warning] open: mods/Stainless_Steel/data/text/diplomacy.txt.strings.bin is missing
    18:17:45.718 [system.io] [warning] open: mods/Stainless_Steel/data/text/diplomacy.txt is missing
    18:17:45.718 [system.io] [warning] open: mods/Stainless_Steel/data/text/diplomacy_speech.txt.strings.bin is missing
    18:17:45.718 [system.io] [warning] open: mods/Stainless_Steel/data/text/diplomacy_speech.txt is missing
    18:17:45.718 [system.io] [warning] open: mods/Stainless_Steel/data/text/missions.txt.strings.bin is missing
    18:17:45.718 [system.io] [warning] open: mods/Stainless_Steel/data/text/missions.txt is missing
    18:17:45.734 [system.io] [warning] open: mods/Stainless_Steel/data/text/shortcut.txt.strings.bin is missing
    18:17:45.750 [system.io] [warning] open: mods/Stainless_Steel/data/text/shortcut.txt is missing
    18:17:45.750 [system.io] [warning] open: mods/Stainless_Steel/preferences/keys.dat is missing
    18:17:45.750 [system.io] [warning] open: mods/Stainless_Steel/preferences/keys.dat is missing
    18:17:52.187 [data.missing] [warning] missing/invalid cursor for ANISELECT
    18:17:52.203 [data.missing] [warning] missing/invalid cursor for MODIFIER_SABOTAGE
    18:17:52.203 [data.missing] [warning] missing/invalid cursor for MODIFIER_TRADE
    18:17:52.250 [data.missing] [warning] missing/invalid cursor for DRAGGABLE
    18:17:52.250 [data.missing] [warning] missing/invalid cursor for DRAGGING
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_MULTIPLE_SELECT
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_ATTACK
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_PLACE_CHARACTER
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_PLACE_RESOURCE
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_PLACE_FORT
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_MOVE_OBJECT
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_PLACE_WATCHTOWER
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_DEPLOYMENT_AREA
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_PLACE_TILE
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_PLACE_SPECIAL_PIECE
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_PAINT
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_ADJUST_HEIGHTS
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_ADD_UNIT
    18:17:52.265 [data.missing] [warning] missing/invalid cursor for MODIFIER_PLACE_SETTLEMENT
    18:17:55.109 [system.io] [warning] open: mods/Stainless_Steel/data/text/religions.txt.strings.bin is missing
    18:17:55.125 [system.io] [warning] open: mods/Stainless_Steel/data/text/religions.txt is missing
    18:17:55.187 [system.io] [warning] open: mods/Stainless_Steel/data/text/climates.txt.strings.bin is missing
    18:17:55.203 [system.io] [warning] open: mods/Stainless_Steel/data/text/climates.txt is missing
    18:17:55.437 [script.err] [error] Script Error in mods/Stainless_Steel/data/descr_projectile.txt, at line 2833, column 1
    Expected 'display'
    18:17:56.609 [system.rpt] [error] Medieval 2: Total War hat einen unbestimmten Fehler entdeckt und wird jetzt beendet.


    Using the advice of adding mods/Stainless_Steel in my medieval 2.cfg.

    Also its running off Medieval 2.exe and not Kingdoms that could be a problem (I have Kingdoms..)
    Last edited by Vash14132; October 13, 2007 at 06:03 PM.

  7. #7

    Default Re: Steam

    Can you explain a little better what you did? I cant even get mine to launch...

    I put @mods\Stainless_Steel\Stainless_Steel_Kingdoms.cfg in the launch options but when i launch the game, only the launcher comes up as usual, with the regular options

  8. #8

    Default Re: Steam

    What I did was go to medieval2.preference.cfg after that I added this to the bottom.

    [features]
    mod = mods/Stainless_Steel

    However I got a CTD at startup , atleast I saw the launch screen.. with that error log generated in my med2 folder.

    Tell me if you get a similar CTD.

  9. #9

    Default Re: Steam

    Quote Originally Posted by Vash14132 View Post
    What I did was go to medieval2.preference.cfg after that I added this to the bottom.

    [features]
    mod = mods/Stainless_Steel

    However I got a CTD at startup , atleast I saw the launch screen.. with that error log generated in my med2 folder.

    Tell me if you get a similar CTD.
    Man, that would be pretty lame if one has to go through hoops and loops to get this mod to work! guess ill better stay with the retro mod as it at least works right away without any bs.

    i am also surprised that the mod maker has no response to this issue.

    don't want to diminish the mod...just saying...

    -h

  10. #10

    Default Re: Steam

    Well he is a very busy person so I do not expect him to respond at all he is very busy.

    However an educated answer from an experienced modder would be much appreciated, and would be deserving of +rep if I could give it.

  11. #11

    Default Re: Steam

    Hi guys. Kind of a big time lurker but.. My personal advice, to those of you trying to get mods to work with the steam version of Kingdoms, is to give up.


    Honestly, give up. That probably sounds really pathetic and whiney, but just save up that money to buy both games right out of the box. Support for Steam users, and note this is of no fault of CA or the modding community, is basically nil.


    Why? Because it is Steam. The mod makers cannot really help much because they do not have the steam version, which generally involves completely different methods of launching games and mods.

    I've been doing my best across various forums in helping people get mods to work with Steam and it is my personal opinion that it is honestly not worth the effort. Steam, be it the Steam community or the company itself truely does -not- care about your end, as long as they're able to pull in the money.

    I know this probably just sounds like a whiney "don't bother" post, and.. Well, it kind of is. But in all honestly. Don't bother. Unless it's a game actually developed by one of Steam's companies and not just marketed through it, you will never get support on your end.

    Steam, in regards to acting as a digital publisher, exists to shove the game into your lap, do a mediocre job at keeping it up to date in regards to patching, and forcing you to use their program to launch your game. And if you decided on actually buying the game for real, you'd be able to actually play it when your internet is dead and you're not able to sign into steam without jumping through hoops configuring it for offline play.


    But then again, must of us only really looked into the TW community after making our digital dogfood purchase, so this probably isn't going to prevent that many people from making our mistake.





    And all that being said, I'm going to wait for the non-Kingdoms version to see if I can use that, as most mods not involving Kingdoms still do work to some degree on Steam purchases. But thats kind of moot because most mods are going to transition over to including Kingdoms content, and the way Kingdoms steam purchases work, you're basically forced to play vanilla, as it is pretty much impossible to get mods to work on the steam version of Kingdoms.

  12. #12

    Default Re: Steam

    Oh my god, this is so sad. I pity you people with the steam version...

    Hopefully there will be a fix for that. Isn't there a "tool" or something, that avoids this stupid steam launcher?

    Just a theoretical question:
    Would it be helpful, if you had the exe file of the "out of the box" game? Could you run the game then normally without the steam launcher? Of course you would need the DVD in this case, but if you had it, would it work?
    Last edited by mailor; October 14, 2007 at 03:39 AM.

    My Home is my Castle.

  13. #13

    Default Re: Steam

    Since you've already payed for it once, you might as well just download a normal working copy right? You have a cd key and all so that shouldn't be the problem.

    Placeholder signature till my own EB2 sig is done.


  14. #14

    Default Re: Steam

    grrrrr...i shalt never buy any games through steam again!

    thx for responding guys.


    himmelstoss

  15. #15

    Default Re: Steam

    Arghh, Il keep getting games off steam Im a steam addict. But yeah the retrofit mod worked fine, and I know why...

    In the medieval 2 launcher there is an option to play retrofit (for example an option to play retail medieval 2, a americas, a teutonic and so on.

    I hope you understand what Im saying, anyways if Stainless Steel could do what the retrofit mod did, and become an option on your medieval 2 launcher (nothing to do with steam) I believe it would work.

    Of course if its really hard dont worry about it... but if you can that would be really great, thanks anyways for the notice and responses guys.

    Edit: Oh and Mailor thanks a thousand times over but unfortunately steam scans your files and would just delete the exe and redownload theirs, Iv tried modifying the vanilla files...lol.

  16. #16

    Default Re: Steam

    Sorry for the double post but this is urgent


    Hello fellow Steam users DO NOT GIVE UP HOPE. I have found a very easy fix for this.

    1. Download the retro fit mod located here

    2. Go to Steamapps/Common/Medieval2/Mods, then remove everything in the retrofit folder, and replace it with all Stainless Steel files.

    3. Launch Kingdoms through Steam in the Medieval 2 Launcher choose to launch the Retrofit Mod

    4. You should now be playing Stainless Steel 5.0 Kingdoms Expansion. Good luck And I hope this works for you too, I will never give hope on my beloved Steam.

  17. #17

    Default Re: Steam

    DUDE!!!! YOU ROCK SOOO FING HARD, ITS NOT EVEN FUNNY ANYMORE!!!



    it totally worked...unbelievable!

    and such an easy trick too!!

    thx so much,

    himmelstoss

  18. #18

    Default Re: Steam

    Senior Kong forgot to add a registry entry for his mod.

    I wouldn't recommend doing this unless you confortable with regedit and I'm not liable if you mess anything up, but here's how you can get it to show up in the launch menu:

    1. Open regedit
    2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\SEGA\Medieval II Total War\Mods\Unofficial
    3. Add a new key called 0001SSMod
    4. Notice the other key called 0000RetrofitMod? Copy all it's values (Author, ConfigFile, etc.) into your new key.
    5. Change the values in the 0001SSMod to point to the stainless steel files and folder

    It should show up in the launcher's menu doing that.

  19. #19

    Default Re: Steam

    Thanks for the alternative solution, but yeah my way is still an alternative if you are uncomfortable with registry's, Ill be using your method however, thanks.

  20. #20

    Default Re: Steam

    For once, I'm very happy to be wrong. Thanks for posting the solution, guys. Saves me having to rebuy the game.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •